 1 モニタ機能

ネットワークに流れているパケットを計測し、トラフィックの統計情報やアドレス、TCP の接続に関する情報をウィンドウに表示する機能です。

モニタ機能を使って表示できる情報をモニタ情報と呼びます。
ASTEC Eyes には4種類のモニタ情報があります。

  • トラフィックの統計情報
    パケットの発信元、受信先、ホストペア、プロトコルなどで分類し、折れ線グラフ、棒グラフ、円グラフ、表の形式で表示します。
  • MAC アドレス、IP アドレスの一覧
    パケットに含まれる MAC アドレスや IP アドレスの一覧を表示します。
  • TCP の接続状態
    計測しているネットワークインタフェース上で TCP の接続の状態をモニタし、表示します。
  • ホストのポートの状態
    パケットから収集した各ホストのポートの状態を表示します。
トラフィックの統計情報、アドレスの一覧、およびTCPの接続状態を表示するウィンドウをモニタウィンドウと呼びます。
ASTEC Eyes には3種類のモニタウィンドウがあります。
  • トラフィックウィンドウ
  • アドレス表
  • TCPステータス情報
ホストのポートの状態は、ポートの状態一覧ダイアログに表示されます。


 1.1.1 モニタ情報を表示する

ネットワークのモニタ情報を表示するには次の操作を行います。

  1. モニタを開始します。
  2. モニタウィンドウを表示します。


 1.1.2 モニタを開始する

方法1

  1. インタフェースを選びます。
  2. メインウィンドウの[モニタ(M)]メニューから[モニタ開始(B)]を選びます。
方法2
  1. インタフェースを選びます。
  2. インタフェースツールバーの[モニタ開始]ボタン( [image])をクリックします。
方法3
  1. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  2. [モニタ開始(B)]を選びます。


 1.1.3 モニタを停止する

方法1

  1. インタフェースを選びます。
  2. メインウィンドウの[モニタ(M)]メニューから[モニタ停止(U)]を選びます。
方法2
  1. インタフェースを選びます。
  2. インタフェースツールバーの[モニタ停止]ボタン( [image])をクリックします。
方法3
  1. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  2. [モニタ停止(T)]を選びます。


 1.1.4 モニタウィンドウを表示する

方法1

  1. インタフェースを選びます。
  2. モニタを開始していない場合は、モニタを開始します。
  3. メインウィンドウの[モニタ(M)]メニューからモニタの種類に対応するメニュー項目を選びます。
方法2
  1. インタフェースを選びます。
  2. モニタを開始していない場合は、モニタを開始します。
  3. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  4. [モニタウィンドウ(M)]を選びます。
  5. モニタウィンドウに対応するメニュー項目を選びます。


 1.1.5 トラフィック情報を表示する

方法1

  1. インタフェースを選びます。
  2. モニタを開始していない場合は、モニタを開始します。
  3. メインウィンドウの[モニタ(M)]メニューからトラフィックの種類に対応するメニュー項目を選びます。
方法2
  1. インタフェースを選びます。
  2. モニタを開始していない場合は、モニタを開始します。
  3. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  4. [モニタウィンドウ(M)]を選びます。
  5. トラフィックの種類に対応するメニュー項目を選びます。


 1.1.6 アドレスの一覧を表示する

モニタ中に流れたパケットから得られた MAC アドレスと IP アドレスは、インタフェース毎に管理されています。
アドレス表には、

  • MAC アドレス表
  • IP アドレス表
  • MAC アドレスと IP アドレスの対応表
があります。

アドレス表を表示するには次の操作を行います。

方法1

  1. インタフェースを選びます。
  2. モニタを開始していない場合は、モニタを開始します。
  3. メインウィンドウの[モニタ(M)]メニューから[MACアドレス表(M)]、[IPアドレス表(I)]、または[MACアドレス-IPアドレス対応表(T)]を選びます。
方法2
  1. インタフェースを選びます。
  2. モニタを開始していない場合は、モニタを開始します。
  3. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  4. [モニタウィンドウ(M)]を選びます。
  5. [MACアドレス表(M)]、[IPアドレス表(I)]、または[MACアドレス-IPアドレス対応表(T)]を選びます。


 1.1.7 TCPの接続状態を表示する

方法1

  1. インタフェースを選びます。
  2. モニタを開始していない場合は、モニタを開始します。
  3. メインウィンドウの[モニタ(M)]メニューから[TCPステータス情報(P)]を選びます。
方法2
  1. インタフェースを選びます。
  2. モニタを開始していない場合は、モニタを開始します。
  3. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  4. [モニタウィンドウ(M)]を選びます。
  5. [TCPステータス情報(P)]を選びます。


 1.1.8 ホストのポートの状態を表示する

ネットワーク上を流れたパケットを解析して、トラフィックウィンドウやアドレス表に表示された特定のホストのUDPポートやTCPポートの状態の一覧を表示できます。

方法

  1. 次のいずれかのモニタウィンドウを開きます。
    • IP層発信元毎のトラフィック
    • IP層受信先毎のトラフィック
    • IP層ホストペア毎のトラフィック
    • IPアドレス表
    • MACアドレス-IPアドレス対応表
  2. 調べたいホストの行を右クリックします。
  3. [ポートの状態一覧(S)]を選びます。


 1.1.9 モニタをリセットする

ASTEC Eyesまたはリモートモジュールのモニタ情報を初期化(リセット)できます。モニタのリセットはインタフェース毎に行います。

方法1

  1. インタフェースを選びます。
  2. メインウィンドウの[モニタ(M)]メニューから[モニタリセット(R)]を選びます。
  3. [はい(Y)]ボタンをクリックします。

方法2

  1. インタフェースを選びます。
  2. インタフェースセレクタウィンドウで、インタフェースのエントリを右クリックします。
  3. [モニタリセット(R)]を選びます。
  4. [はい(Y)]ボタンをクリックします。

注

  • モニタをリセットすると、それまでに収集した統計情報やIPアドレス、MACアドレス、TCPの接続情報は失われます。 また、モニタウィンドウは何も表示されていない状態になります。
  • モニタをリセットすると自動的にモニタが停止します。
  • モニタをリセットするには、設定権限が必要です。


 1.1.10 トラフィックウィンドウの表示形式を切り替える

トラフィック情報は、折れ線グラフ、棒グラフ、 円グラフまたは表形式で表示できます。

方法1

トラフィックウィンドウのツールバーの

  • [折れ線グラフ(履歴)]ボタン( [image])
  • [棒グラフ(トータル)]ボタン( [image])
  • [円グラフ(比率)]ボタン( [image])
  • [表(詳細)]ボタン( [image])
のいずれかをクリックします。

方法2

  1. トラフィックウィンドウを右クリックします。
  2. [表示形式(V)]を選びます。
  3. 次のいずれかを選びます。
    • [折れ線グラフ(H)]
    • [棒グラフ(B)]
    • [円グラフ(P)]
    • [表形式(T)]

さらに、 折れ線グラフを積み重ね形式で表示するかどうかを指定できます。


 1.1.11 グラフのプロパティを表示する

ホスト名やファイル名、モニタ開始時刻、プロット間隔など、トラフィックウィンドウに表示しているグラフのデータに関連する情報を表示します。

方法

  1. トラフィックウィンドウを右クリックします。
  2. [プロパティ(O)...]を選びます。
  3. [情報]タブをクリックします。


 1.1.12 モニタ情報をファイルに保存する

モニタ情報を CSV(カンマ区切り)形式、bmp形式、メタファイル形式、およびエンハンスドメタファイルの形式で保存できます。

方法

  1. モニタウィンドウをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[モニタ情報の保存(G)...]を選びます。
  3. ファイル名とファイル形式を指定します。

注

  • 表形式のモニタウィンドウの場合は、CSV形式でのみ保存できます。
  • モニタウィンドウの表示形式によって、保存されるモニタ情報の内容が異なります。
    たとえば、棒グラフ形式で上位10項目を表示している場合は、10項目分の統計情報だけが保存されます。
  • 保存したモニタ情報は他のアプリケーションで利用できます。 例えば、Microsoft Wordにbmp形式の画像を挿入したり、Microsoft ExcelでCSV形式のデータを読み込めます。


 1.1.13 モニタ情報を他のアプリケーションにコピーする

方法 (グラフ形式の場合)

  1. コピー元のモニタウィンドウをクリックします。
  2. メインウィンドウの[編集(E)]メニューから[コピー(C)]を選ぶか、<Ctrl-C>キーを押します。
  3. ペースト先のアプリケーションをアクティブにし、<Ctrl-V>キーを押します。

方法 (表形式の場合)

  1. コピー元のモニタウィンドウをマウスの右ボタンでクリックします。
  2. [すべてコピー(W)]を選びます。
    表形式の場合に<Ctrl-C>キーを押すと、選択しているセル(白い枠で囲まれます)の文字列だけをコピーします。
  3. ペースト先のアプリケーションをアクティブにし、<Ctrl-V>キーを押します。

注

  • Microsoft WordやMicrosoft Excelなどのアプリケーションでは、<Ctrl-V>キーを押す代わりに、[編集(E)]メニューの[形式を選択して貼り付け(S)]を選ぶこともできます。
  • モニタウィンドウの表示形式によって、コピーされるモニタ情報の内容が異なります。
    たとえば、棒グラフ形式で上位10項目を表示している場合は、10項目分の統計情報だけがコピーされます。


 1.2.1 グラフアイテム(トラフィック)を選ぶ

方法1 (グラフの場合)

グラフアイテムまたは凡例をクリックします。
複数のグラフアイテムを選ぶには、<Ctrl>キーを押しながらグラフアイテムまたは凡例をクリックします。

グラフ解析機能を使っている場合には、<Alt>キーを押しながらグラフアイテムをクリックします。 グラフ解析機能を使っているときは、複数のグラフアイテムを選択できません。

方法2 (表の場合)

グラフアイテムに対応する行をクリックします。
複数のグラフアイテムを選ぶには、<Ctrl>キーを押しながら行をクリックします。

方法3

  1. モニタウィンドウをクリックします。
  2. <↑>または<↓>キーを押します。
    複数のグラフアイテムを選ぶには、 <Ctrl>キーを押しながら<↑>または<↓>キーで移動し、 <Space>キーで選択します。

注

  • 折れ線グラフの場合は、折れ線の頂点付近をクリックします。
  • <Ctrl-Space>キーでグラフアイテムの選択、非選択を切り替えられます。
  • 選びにくいグラフアイテムを選ぶ場合には、表形式に切り替えて選ぶと便利です。
    表形式のモニタウィンドウでは、表の中の文字列を検索できます。
  • ステータスバーには選んだグラフアイテムの名前が表示されます。


 1.2.2 特定のトラフィックだけを表示する

折れ線グラフ形式のトラフィックウィンドウで、特定のグラフアイテムだけを表示できます。

方法

  1. グラフアイテムを選びます。
  2. グラフを右クリックします。
  3. [他を隠す(M)]を選びます。

注

  • <Shift>キーを押したまま特定のグラフアイテムだけを表示すると、選んだグラフアイテムだけを表示した新しいトラフィックウィンドウが現れます。


 1.2.3 特定のトラフィックだけを隠す

  折れ線グラフ形式のトラフィックウィンドウで、特定のグラフアイテムだけを表示しないようにできます。

方法

  1. グラフアイテムを選びます。
  2. グラフを右クリックします。
  3. [このグラフアイテムを隠す(E)]を選びます。

注

  • <Shift>キーを押したまま特定のグラフアイテムだけを隠すと、選んだグラフアイテムだけを隠した新しいトラフィックウィンドウが現れます。


 1.2.4 トラフィックの内訳を表示する

方法

  1. グラフアイテムを選びます。
  2. トラフィックウィンドウを右クリックします。
  3. [内訳(D)]を選びます。
  4. 次のいずれかを選びます。
    • [発信元毎(S)]
    • [受信先毎(D)]
    • [ホストペア毎(H)]
    • [プロトコル毎(P)]

注

  • <Shift>キーを押したまま4.の操作を行うと、内訳を表示した新しいトラフィックウィンドウが現れます。
  • グラフアイテムを複数選択しているときは、トラフィックの内訳を表示できません。


 1.2.5 グラフの表示を元に戻す

特定のグラフアイテムのみを表示したり隠したりしたグラフ、内訳を表示したグラフを元に戻します。

方法

  1. トラフィックウィンドウを右クリックします。
  2. [元のグラフに戻る(B)]を選びます。

注

  • 新しいウィンドウに特定のグラフアイテムのみを表示したり、特定のグラフアイテムを隠したり、内訳を表示した場合、ポップアップメニューに[元のグラフに戻る(B)]はありません。


 1.2.6 グラフのX軸の値を読む

方法

  1. トラフィックウィンドウを折れ線グラフ形式にします。
  2. ツールバーの[グラフ解析機能]ボタン( [image])をクリックします。
  3. ツールバーの[垂直カーソル]ボタン( [image])をクリックします。
  4. 値を読み取りたい位置でマウスをクリックまたはドラッグします。
    5.  | マウスをクリック | マウスをドラッグ
グラフアイテムを選んでいないとき | 垂直カーソルの位置の時刻 | ドラッグの開始および終了位置の時刻 ドラッグの開始位置から終了位置までの時間
グラフアイテムを選んでいるとき | グラフアイテム名 垂直カーソルの位置の時刻 グラフアイテムの値 | グラフアイテム名 ドラッグの開始および終了位置の時刻 ドラッグの開始位置から終了位置までの時間 ドラッグの開始位置から終了位置までの範囲におけるグラフアイテムの累計値、最大値、最小値および平均値
  5. キーボードの操作で読み取る位置や範囲を変更できます。「モニタウィンドウのキーバインド」を参照してください。

注

  • [グラフ解析機能]ボタン( [image])を押すと、トラフィックウィンドウは次の状態になります。
    • グラフは更新されません。
    • ポップアップメニューが出ません。
    • グラフの表示形式を切り替えられません。
    • Y軸の範囲を指定できません。
  • [垂直カーソル]ボタン( [image])を押すと、マウスカーソルが十字カーソルに代わり、垂直方向の破線が現れます。この破線を垂直カーソルと呼びます。
  • グラフの値を読み取る状態から通常の状態に戻るには、もう一度[グラフ解析機能]ボタン( [image])をクリックします。
  • <Shift>キーを押しながらマウスをドラッグして範囲を指定すると、指定した範囲が拡大表示されます。元のグラフに戻すには、<Shift>キーを押しながら、右クリックします。
  • グラフアイテムを複数選択しているときは、[グラフ解析機能]ボタン( [image])をクリックできません。


 1.2.7 グラフのY軸の値を読む

方法

  1. トラフィックウィンドウを折れ線グラフ形式にします。
  2. ツールバーの[グラフ解析機能]ボタン( [image])をクリックします。
  3. ツールバーの[水平カーソル]ボタン( [image])をクリックします。
  4. 値を読み取りたい位置でマウスをクリックまたはドラッグします。
    マウスをクリック マウスをドラッグ
    グラフアイテムを選んでいないとき 水平カーソルの位置の値（バイトまたはフレーム数） ドラッグの開始および終了位置の値
    ドラッグの開始位置から終了位置までの値の差分
    グラフアイテムを選んでいるとき グラフアイテム名
    水平カーソルの位置の値とその値をプロットしたすべての時刻         		グラフアイテム名
    ドラッグの開始および終了位置の値
    ドラッグの開始位置から終了位置までの値の差分
  5. キーボードの操作で読み取る位置や範囲を変更できます。「モニタウィンドウのキーバインド」を参照してください。

注

  • [グラフ解析機能]ボタン( [image])を押すと、トラフィックウィンドウは次の状態になります。
    • グラフは更新されません。
    • ポップアップメニューが出ません。
    • グラフの表示形式を切り替えられません。
    • Y軸の範囲を指定できません。
  • [水平カーソル]ボタン( [image])を押すと、カーソルが十字カーソルになり、水平方向の破線が現れます。この破線を、水平カーソルと呼びます。
  • グラフの値を読み取る状態から通常の状態に戻るには、もう一度[グラフ解析機能]ボタン( [image])をクリックします。
  • グラフアイテムを選んだ状態では、水平カーソルはプロットされた値から値へ上下に移動し、プロットされた値のない位置には移動しません。
  • <Shift>キーを押しながらマウスをドラッグして範囲を指定すると、指定した範囲が拡大表示されます。元のグラフに戻すには、<Shift>キーを押しながら、右クリックします。
  • グラフアイテムを複数選択しているときは、[グラフ解析機能]ボタン( [image])をクリックできません。


 1.2.8 表形式のモニタウィンドウで文字列を検索する

方法

  1. メインウィンドウの[編集(E)]メニューから[検索(F)]を選ぶか、<Ctrl-F>キーを押します。
  2. 文字列を入力し[次を検索(F)]ボタンをクリックします。

注

  • 正規表現を使う場合は、[正規表現(E)]チェックボックスにチェックを付けます。


 1.2.9 表形式のモニタウィンドウの行を並べ替える

表形式のトラフィックウィンドウの行を、各カラムの内容順に並べ替えられます。

方法

各カラムの見出しをクリックします。一度クリックすると昇順に、もう一度クリックすると降順に並びます。


 1.2.10 IPアドレスの代わりにホスト名を表示する

DNS、WINS(NetBIOS)、およびNISネームサービスを利用してホスト名を検索し、IPアドレスの代わりにホスト名を表示できます。

方法1 (グラフの場合)

  1. グラフアイテムを選びます。
  2. ウィンドウを右クリックします。
  3. [ホスト名の検索(H)]を選びます。
  4. [DNS(D)]、[NetBIOS(B)]、または[NIS(ドメイン名)(N)]を選びます。

方法2 (表の場合)

  1. ホスト名で表示したい行を右クリックします。
  2. [ホスト名の検索(H)]を選びます。
  3. [DNS(D)]、[NetBIOS(B)]、または[NIS(ドメイン名)(N)]を選びます。

注

  • あらかじめNISのドメイン名を指定しておかないと、[NIS(ドメイン名)(N)]は選べません。


 1.2.11 ホストの識別にホスト名を使う

次のトラフィックウィンドウではホストを表すのに、アドレスのほかにホスト名も利用できます。

  • MAC層発信元毎のトラフィック
  • MAC層受信先毎のトラフィック
  • MAC層ホストペア毎のトラフィック
  • IP層発信元毎のトラフィック
  • IP層受信先毎のトラフィック
  • IP層ホストペア毎のトラフィック
使うホスト名の種類や設定方法は、「ホストの識別に使うホスト名を選ぶ」を参照してください。


 1.2.12 ホストの識別にアドレスを使う

モニタウィンドウではホストを表すのに、ホスト名のほかにIPアドレスやMACアドレスも利用できます。

方法1

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[ホスト名]をクリックします。
  3. [表示する名前と優先順位(P)]領域のチェックをすべて外します。
    • [ユーザー定義名(U)]
    • [NetBIOS名(B)]
    • [NIS名(N)]
    • [DNS名(D)]

方法2

  1. メインウィンドウの[ツール(T)]メニューから[ホスト名の検索(H)...]を選ぶか、<Ctrl-L>キーを押します。
  2. [表示の優先順位を設定(R)...]ボタンをクリックします。
  3. チェックをすべて外します。

方法3

  1. メインウィンドウの[編集(E)]メニューから[MAC層アドレス帳の編集(M)]または[IP層アドレス帳の編集(I)]を選びます。
  2. アドレス帳のウィンドウを右クリックします。
  3. [表示の優先順位を設定(P)...]を選びます。
  4. チェックをすべて外します。


 1.3 モニタフィルタ

モニタウィンドウに表示するデータを絞り込むためのフィルタです。
フィルタ条件はフィルタエディタで定義します。 モニタフィルタはインタフェースごとに設定します。
モニタフィルタを適用すると以下に示したウィンドウを除いて、適用したインタフェースのすべてのモニタウィンドウが影響を受けます。

  • 「MAC層サイズ毎のフレーム数」のトラフィックウィンドウ
  • 「MAC層エラーフレーム数」のトラフィックウィンドウ
  • MACアドレス表
  • IPアドレス表
  • MACアドレス-IPアドレス対応表
  • 「TCPステータス情報」のウィンドウ


 1.3.1 特定の条件を満たすトラフィックを表示する

特定の条件を満たすトラフィックのみをモニタするには、

  1. フィルタエディタでモニタフィルタを定義します。
  2. モニタフィルタをトラフィックウィンドウに適用します。

モニタフィルタを定義する

方法

  1. フィルタエディタを開きます。
  2. [ [image] モニタフィルタ]をクリックします。
  3. 論理式を定義します。
詳しくは、ユーザーズガイドの「7章 フィルタエディタ」を参照してください。

モニタフィルタを適用する

方法1

  1. メインウィンドウの[モニタ(M)]から[モニタフィルタ(F)]を選びます。
  2. 適用したいフィルタを選びます。

方法2

  1. モニタウィンドウのツールバーの[モニタフィルタ]ボタン( [image])をクリックします。
  2. 適用したいフィルタを選びます。

方法3

  1. モニタウィンドウを右クリックします。
  2. [モニタフィルタ(F)]を選びます。
  3. 適用したいフィルタを選びます。

注

  • モニタフィルタはインタフェースごとに適用されます。例えば、1つのインタフェースをモニタするために、3つのトラフィックウィンドウを表示している場合、モニタフィルタを適用すると、3つのトラフィックウィンドウすべてにモニタフィルタが適用されます。


 1.3.2 グラフ上のトラフィックからモニタフィルタを作る

トラフィックウィンドウ上の特定のグラフアイテムのみに絞り込む論理式を作成し、フィルタエディタに設定できます。

方法1

  1. グラフアイテムを選びます。
  2. トラフィックウィンドウを右クリックします。
  3. [フィルタの生成(I)]を選びます。
  4. [フィルタエディタに送る(F)]を選びます。

方法2

  1. フィルタエディタを開きます。
  2. トラフィックウィンドウ上のグラフアイテムをドラッグし、フィルタエディタの[ [image] モニタフィルタ]にドロップします。

注

  • グラフアイテムを複数選択しているときは、[フィルタの生成(I)]を選んだり、フィルタエディタにドラッグ&ドロップできません。


 1.3.3 一時的なモニタフィルタを使ってトラフィックを表示する

トラフィックウィンドウ上の特定のグラフアイテムのみに絞り込むモニタフィルタを一時的に作成し、適用できます。

方法

  1. グラフアイテムを選びます。
  2. トラフィックウィンドウを右クリックします。
  3. [フィルタの生成(I)]を選びます。
  4. [一時的に生成して適用する(I)]を選びます。

注

  • この操作で生成した論理式はフィルタエディタには設定されません。
  • グラフアイテムを複数選択しているときは、[フィルタの生成(I)]を選べません。


 1.4.1 グラフアイテムの数を制限する

トラフィックの種類によって、表示するグラフアイテムの数を制限できます。 以下のトラフィックはデフォルトでグラフアイテム数が制限されています。

  • MAC層発信元毎のトラフィック
  • MAC層受信先毎のトラフィック
  • MAC層ホストペア毎のトラフィック
  • IP層発信元毎のトラフィック
  • IP層受信先毎のトラフィック
  • IP層ホストペア毎のトラフィック
次の操作でグラフアイテム数の上限を変更できます。

方法1（折れ線グラフ形式で表示期間中の上限数を指定する場合）

  1. トラフィックウィンドウを右クリックします。
  2. [プロパティ(O)...]を選びます。
  3. [グラフ]タブをクリックします。
  4. [ホストとホストペアのグラフの項目数]領域の[表示する項目数(Top N)]に上限を入力します。

方法2（折れ線グラフ形式でプロット点ごとの上限数を指定する場合）

  1. トラフィックウィンドウを右クリックします。
  2. [プロパティ(O)...]を選びます。
  3. [グラフ]タブをクリックします。
  4. [ホストとホストペアのグラフの項目数]領域の[折れ線グラフの項目は別の方法で決定する]チェックボックスにチェックを付けます。
  5. [各時刻での値が上位のホストを項目に加える]を選び[各時刻での上位]に上限を入力します。

方法3（棒グラフまたは円グラフ形式の場合）

  1. トラフィックウィンドウを右クリックします。
  2. [プロパティ(O)...]を選びます。
  3. [グラフ]タブをクリックします。
  4. [ホストとホストペアのグラフの項目数]領域の[表示する項目数(Top N)]に上限を入力します。

注

  • 表示するグラフアイテムが多い場合には、グラフアイテム数を制限しないと、メモリの使用量が増えて描画が遅くなったり、グラフが見づらくなることがあります。
  • グラフアイテム数の制限は設定したモニタウィンドウでのみ有効です。新しく開くモニタウィンドウすべてについてグラフアイテム数を制限したい場合は、デフォルトの表示形式を設定する必要があります。


 1.4.2 グラフに表示する期間を切り替える

短期、中期、長期の3つのタイムスパンを選べます。また、それぞれのタイムスパンごとに、グラフに表示する期間を選べます。タイムスパンと選べる表示期間の対応は次のとおりです。

タイムスパン | 表示期間
 | 最短 | 最長
短期 | 5分 | 30分
中期 | 1時間 | 6時間
長期 | 1日 | 6日

タイムスパンを切り替える

方法1

トラフィックウィンドウのツールバーの[タイムスパン切り替え]ボタン( [image] 、 [image] 、 [image])をクリックします。このボタンを押すたびに、タイムスパンが切り替わります。

方法2

  1. トラフィックウィンドウを右クリックします。
  2. [タイムスパン(P)]を選びます。
  3. [短期(S)]、[中期(M)]、[長期(L)]のいずれかを選びます。

表示期間を変える

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[モニタ]をクリックします。
  3. 各タイムスパンごとに用意されている[表示期間]のドロップダウンリストボックスから期間を選びます。

注

  • 表示期間を長くすると、メモリの使用量が多くなります。


 1.4.3 グラフの更新間隔を変える

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[モニタ]をクリックします。
  3. [更新間隔(R)]のドロップダウンリストボックスからグラフの更新間隔を選びます。

注

  • この更新間隔が適用されるのは、短期のタイムスパンのみです。


 1.4.4 グラフのY軸の単位を変える

バイト、フレーム、使用率を切り替える方法

  1. トラフィックウィンドウを右クリックします。
  2. [データの単位(U)]を選びます。
  3. 単位を選びます。

注

  • 変更は設定したトラフィックウィンドウでのみ有効になります。新しく開くトラフィックウィンドウすべてについてグラフのY軸の単位を変更したい場合は、デフォルトの表示形式を設定する必要があります。
  • 使用率は、「MAC層トラフィック」でのみ選択できます。


 1.4.5 ネットワークの使用率とピーク値を調べる

「MAC層トラフィック」のウィンドウのY軸の単位を「使用率」にすると、ネットワークの使用率がわかります。

方法

  1. 「MAC層トラフィック」のウィンドウを右クリックします。
  2. [データの単位(U)]を選びます。
  3. [使用率(U)]を選びます。

「MAC層トラフィック」のタイムスパンが「中期」または「長期」のときに、Y軸の単位を「バイト」または「使用率」にすると、トラフィックのピーク値が薄紫色の破線で表示されます。

方法

  1. 「MAC層トラフィック」のタイムスパンを「中期」または「長期」に切り替えます。
  2. ウィンドウを右クリックします。
  3. [データの単位(U)]を選びます。
  4. [バイト(B)]または[使用率(U)]を選びます。

注

  • ネットワークのメディアの種類によっては、正確な使用率を表示できないことがあります。ネットワークの使用率を求める計算式については「ユーザーズガイド」の「2.2.3 Y軸の単位」の節をご覧ください。
  • リモートモジュールが監視しているネットワークの場合、リンクスピードがわからないことがあります。そのような場合は、[リンクスピードの設定]ダイアログが現れ、リンクスピードをたずねます。リモートモジュールのネットワークのリンクスピードがわからない場合は、システム管理者に問い合わせてください。


 1.4.6 グラフに表示するY軸の範囲を変える

折れ線グラフ、棒グラフ形式のトラフィックウィンドウでは、表示するY軸の範囲を指定できます。

方法1

  1. トラフィックウィンドウのツールバーの[Y軸の範囲]ボタン( [image])をクリックします。
  2. マウスの左ボタンを押したまま上下に動かし、Y軸の範囲を決めます。

方法2

  1. トラフィックウィンドウを右クリックします。
  2. [プロパティ(O)...]を選びます。
  3. [グラフ]タブをクリックします。
  4. [最大値]、[最小値]領域で、グラフに表示する最大値と最小値を指定します。

注

  • 設定したトラフィックウィンドウでのみY軸の範囲が変わります。新しく開くトラフィックウィンドウすべてについてグラフのY軸の範囲を指定したい場合は、デフォルトの表示形式を設定する必要があります。


 1.4.7 グラフのY軸の範囲を元に戻す

方法

  1. トラフィックウィンドウを右クリックします。
  2. [Y軸を戻す(Y)]を選びます。

注

Y軸の範囲を出荷時に設定されているデフォルト値に戻したい場合は、次の設定を行ってください。
  1. トラフィックウィンドウを右クリックします。
  2. [プロパティ(O)...]を選びます。
  3. [グラフ]タブをクリックします。
  4. [最大値]を「自動」に、[最小値]を「0」に設定します。


 1.4.8 デフォルトの表示形式を設定する

グラフのY軸の単位や、表示するグラフアイテム数など、グラフのデフォルトを変えられます。

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[グラフ]をクリックします。
  3. グラフのY軸の単位や範囲、グラフアイテム数などを設定します。

注

  • 設定したデフォルトの表示形式は、新たに開くトラフィックウィンドウについてのみ有効になります。すでに表示されているトラフィックウィンドウの表示形式は変わりません。
  • すでに表示されているトラフィックウィンドウの表示形式を変える方法については、関連項目を参照してください。


 1.4.9 グラフの前景色や背景色を変える

トラフィックウィンドウに表示したグラフの前景色と背景色を変えられます。グラフアイテムと前景色、背景色の色が似ていて見づらい場合は、いずれかの色を変えるとよいでしょう。
グラフアイテムの色を変える方法は「グラフアイテムの色を変える」を参照してください。

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[グラフの色]をクリックします。
  3. [前景(F)]または[背景(B)]ボタンをクリックします。
  4. [色の設定]ダイアログで色を指定します。

注

  • 前景色を変更すると、軸や軸の目盛り、凡例の文字の色などが変わります。
  • 背景色を変更すると、トラフィックウィンドウの背景の色が変わります。


 1.4.10 グラフアイテムの色を変える

特定のグラフアイテムの色を変えられます。前景色や背景色の色とグラフアイテムの色が似ていて見づらい場合、いずれかの色を変えるとよいでしょう。
前景色、背景色を変える方法は、「グラフの前景色や背景色を変える」を参照してください。

方法1

  1. グラフアイテムを選びます。
  2. トラフィックウィンドウを右クリックします。
  3. [色の設定(C)...]を選びます。
  4. [色の設定]ダイアログで色を指定します。
方法2
  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[グラフの色]をクリックします。
  3. [種類(Y)]のリストから、トラフィックの種類を選びます。
  4. [設定されている色(C)]の一覧に色を変えたいグラフアイテムが表示されていない場合は、 次の方法でグラフアイテムを追加します。
    • [追加(P)]ボタンをクリックする
    • 色を変えたいグラフアイテム をドラッグし、ダイアログの右側の領域にドロップする
  5. [設定されている色(C)]からグラフアイテムを選んでクリックします。
  6. [変更(M)]ボタンをクリックします。
  7. [色の設定]ダイアログで色を指定します。

注

  • 次のトラフィックについては、[設定されている色(C)]に表示される項目は固定です。項目の追加や削除はできません。
    • MAC層トラフィック
    • IP層トラフィック
    • MAC層アドレスタイプ
    • MAC層フレームサイズ
    • MAC層エラーフレーム
    • イベント


 1.4.11 デフォルトの色に戻す

変更した前景色、背景色、グラフアイテムの色をデフォルトの状態に戻せます。

特定のグラフアイテムの色をデフォルトに戻す方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[グラフの色]をクリックします。
  3. [種類(Y)]のリストから、トラフィックの種類を選びます。
  4. [設定されている色(C)]の一覧で、デフォルトの色に戻したいグラフアイテムをクリックします。
  5. [リセット(R)]ボタンをクリックします。

すべての色の設定をデフォルトに戻す方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[グラフの色]をクリックします。
  3. [すべての色をデフォルトに戻す(E)]ボタンをクリックします。


 1.4.12 凡例の表示、非表示を切り替える

方法1

トラフィックウィンドウのツールバーの[凡例]ボタン( [image])をクリックします。

方法2

  1. トラフィックウィンドウを右クリックします。
  2. [凡例(G)]を選びます。

方法3

  1. トラフィックウィンドウを右クリックします。
  2. [プロパティ(O)...]を選びます。
  3. [グラフ]タブをクリックします。
  4. [凡例を(G)]チェックボックスにチェックを付けます。 または、チェックをはずします。


 1.4.13 ツールバーの表示、非表示を切り替える

方法1

  1. トラフィックウィンドウを右クリックします。
  2. [ツールバーの表示(T)]を選びます。

方法2

  1. トラフィックウィンドウを右クリックします。
  2. [プロパティ(O)...]を選びます。
  3. [グラフ]タブをクリックします。
  4. [ツールバー(T)]チェックボックスにチェックを付けます。 またはチェックをはずします。


 1.4.14 折れ線グラフを積み重ね形式にするか切り替える

方法1

トラフィックウィンドウのツールバーの[積み重ね]ボタン( [image])をクリックします。

方法2

  1. トラフィックウィンドウを右クリックします。
  2. [積み重ね折れ線グラフ(K)]を選びます。

方法3

  1. トラフィックウィンドウを右クリックします。
  2. [プロパティ(O)...]を選びます。
  3. [グラフ]タブをクリックします。
  4. [積み重ね(S)]チェックボックスにチェックを付けます。 または、チェックをはずします。


 1.5.1 Well knownポートを使っていないプロトコルを正しくモニタする

ASTEC Eyesは、TCPまたはUDPのポート番号を使ってアプリケーション層のプロトコルを識別しています。 このため、プロキシサーバーを使っていてアプリケーション層のプロトコルがWell knownポート以外のポートを使っている場合や、Well knownポートを持たないプロトコルは正しくモニタできません。

このような場合、デコードヒントを設定します。

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[デコードヒント]をクリックします。
  3. デコードヒントを設定します。

注

  • ASTEC Eyesがアプリケーション層のプロトコルを正しく認識できない場合、プロトコルで分類したトラフィックウィンドウには“Unknown TCP Protocol”または“Unknown UDP Protocol”と表示されます。


 1.5.2 ASTEC Eyesが対応していないプロトコルをモニタする

デコードヒントを利用して、ASTEC Eyesが対応していないアプリケーション層のプロトコルをモニタできます。

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[デコードヒント]をクリックします。
  3. IPアドレス、トランスポート層、およびポート番号を指定し、プロトコル名のカラムに任意の文字列を入力します。


 2 ログ機能

ログは、モニタ情報とモニタイベントを一定時間ごとにファイルに出力する機能です。

ネットワークのトラフィックが多いのは何時ごろなのか、また、そのときにどのようなプロトコルが多く流れているのかなど、長期にわたるトラフィックのトレンドを調べたり、何時ごろ、どのようなモニタイベントが発生したかを調べるためには、ログ機能を使います。


 2.1.1 ログを開始する

方法

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [ログ]タブをクリックします。
  3. [出力する(L)]チェックボックスにチェックを付けます。
  4. ログを出力しないインタフェースのチェックボックスのチェックをはずします。
  5. 必要に応じて次の項目を指定します。
    • 出力間隔
    • 同一ファイルへの書き込み回数
    • ログを出力するディレクトリ
    • ログファイルを圧縮するかどうか
    • ログファイルを自動的に削除するかどうか

注

  • 書き込み中のログファイルの情報を参照したり、表示することはできません。 ログの情報を表示できるようになるまでの待ち時間は、 [出力間隔]×[同一ファイルへの書き込み回数] です。 出力間隔や同一ファイルへの書き込み回数を大きくすると、ログ情報を表示できるようになるまでの時間が長くなります。
  • ログを出力するディレクトリは、ASTEC Eyesまたはリモートモジュールをインストールしたディレクトリからの相対パスで指定します。
  • [圧縮して出力する(C)]チェックボックスにチェックを付けると、ログファイルをbzip2で圧縮します。
  • ログを出力するように設定すると、ASTEC Eyesを終了した後もログを出力するプロセスが動き続けます。


 2.1.2 ログを停止する

ログの出力を停止する

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [ログ]タブをクリックします。
  3. [出力する(L)]チェックボックスのチェックをはずします。

特定のインタフェースについてログの出力を停止する

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [ログ]タブをクリックします。
  3. [出力するインタフェース(I)]に表示されているインタフェースのうち、ログの出力を停止したいインタフェースのチェックボックスのチェックを外します。


 2.1.3 ログを表示する

ログの出力先として設定したディレクトリのログを表示します。

方法

  1. インタフェースセレクタウィンドウ内のホストのエントリを右クリックします。
  2. [ログの一覧を作成(L)]を選びます。
  3. ログのエントリを右クリックします。
  4. [ログを表示(L)...]を選びます。
  5. 期間とプロット間隔を指定します。
  6. [ログのグラフを表示...]ボタンをクリックします。
  7. ログの種類を選びます。

注

  • ログを見るためには、ログを出力した(している)ホストでASTEC Eyes基本パッケージまたはリモートモジュールが動作している必要があります。
  • ログを表示したモニタウィンドウでも、ネットワークの現在の状態を表示しているモニタウィンドウと全く同じようにグラフの表示形式を切り替えたり、モニタフィルタを利用できます。
    モニタウィンドウの操作については、モニタ機能の項目を参照してください。
  • イベントのログを表示したウィンドウでも、イベントビューアと全く同じように表示形式を切り替えたり、見出しフィルタを利用できます。
    イベントビューアの操作については、エキスパート機能の項目を参照してください。
  • ログの出力先として設定したディレクトリからログの一覧を作った場合には、インタフェースのエントリの下にログのエントリが作られます。


 2.1.4 ログファイルを保存したディレクトリを指定してログを表示する

ログファイルを保存したディレクトリを指定してログを表示します。

この方法では、ログの出力先のディレクトリを変更したり移動した場合でも、ログを表示できます。また、別のホストで動作しているASTEC Eyesやリモートモジュールで保存したログファイルをローカルホストへコピーして表示できます。

方法1

  1. メインウィンドウの[ファイル(F)]メニューから[ログのディレクトリを開く(L)...]を選びます。
  2. ログを保存したディレクトリを指定します。
  3. インタフェースセレクタウィンドウで、ログのエントリを右クリックします。
  4. [ログを表示(L)...]を選びます。
  5. 期間とプロット間隔を指定します。
  6. [ログのグラフを表示...]ボタンをクリックします。
  7. ログの種類に対応するメニュー項目を選びます。

方法2

  1. インタフェースセレクタウィンドウの何も表示されていない部分を右クリックします。
  2. [ログのディレクトリを開く(L)...]を選びます。
  3. ログを保存したディレクトリを指定します。
  4. インタフェースセレクタウィンドウで、ログのエントリを右クリックします。
  5. [ログを表示(L)...]を選びます。
  6. 期間とプロット間隔を指定します。
  7. [ログのグラフを表示...]ボタンをクリックします。
  8. ログの種類に対応するメニュー項目を選びます。

注

  • ログを表示したモニタウィンドウでも、ネットワークの現在の状態を表示しているモニタウィンドウと全く同じようにグラフの表示形式を切り替えたり、モニタフィルタを利用できます。
    モニタウィンドウの操作については、モニタ機能の項目を参照してください。
  • イベントのログを表示したウィンドウでは、イベントビューアと全く同じように表示形式を切り替えたり、見出しフィルタを利用できます。
    イベントビューアの操作については、エキスパート機能の項目を参照してください。
  • ログファイルを保存したディレクトリを指定してログの一覧を作った場合には、フォルダのエントリの下にログのエントリが作られます。


 2.1.5 ログのグラフのプロパティを表示する

ホスト名やリンクスピード、モニタ開始時刻、プロット間隔など、トラフィックウィンドウに表示しているログのグラフのデータに関連する情報を表示します。

方法

  1. ログのトラフィックウィンドウを右クリックします。
  2. [プロパティ(O)...]を選びます。
  3. [情報]タブをクリックします。


 2.1.6 ログをファイルに保存する

ウィンドウに表示したログをCSV(カンマ区切り)形式、bmp形式、メタファイル形式、およびエンハンスドメタファイルの形式で保存できます。

方法

  1. ログのウィンドウをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューの[モニタ情報の保存(G)...]を選びます。
  3. 保存するファイル名とその形式を指定します。

注

  • 表形式のログウィンドウの場合は、CSV形式でのみ保存できます。
  • ログウィンドウの表示形式によって、保存されるログの内容が異なります。
    たとえば、棒グラフ形式で上位10項目を表示している場合は、10項目分の統計情報だけが保存されます。
  • 保存したログは他のアプリケーションで利用できます。 例えば、Microsoft Wordにbmp形式の画像を挿入したり、Microsoft ExcelでCSV形式のデータを読み込めます。


 2.1.7 ログを他のアプリケーションにコピーする

方法1 (グラフ形式の場合)

  1. ログのウィンドウをクリックします。
  2. メインウィンドウの[編集(E)]メニューから[コピー(C)]を選ぶか、<Ctrl-C>キーを押します。
  3. ペースト先のアプリケーションをアクティブにし、<Ctrl-V>キーを押します。

方法2 (表形式の場合)

  1. ログのウィンドウを右クリックします。
  2. [すべてコピー(W)]を選びます。
    表形式の場合に<Ctrl-C>キーを押すと、選択しているセル(白い枠で囲まれます)の文字列だけをコピーします。
  3. ペースト先のアプリケーションをアクティブにし、<Ctrl-V>キーを押します。

注

  • Microsoft WordやMicrosoft Excelなどのアプリケーションでは、<Ctrl-V>キーを押す代わりに、[編集(E)]メニューの[形式を選択して貼り付け(S)]を選ぶこともできます。
  • ログのウィンドウの表示形式によって、コピーされるログの内容が異なります。
    たとえば、棒グラフ形式で上位10項目を表示している場合は、10項目分の統計情報だけがコピーされます。


 2.1.8 ログのプロパティを表示する

ログを収集したネットワークインタフェースの情報やログの期間を表示します。

方法

  1. インタフェースセレクタウィンドウ内のログのエントリを右クリックします。
  2. [プロパティ(P)...]を選びます。


 2.2.1 ログの出力間隔と書き込み回数を設定する

ログは指定した間隔で作成され、1つのログファイルに指定した回数分のログが書き込まれます。

方法

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [ログ]タブをクリックします。
  3. [出力間隔(O)]にログを作成する時間間隔を、[同一ファイルへの書き込み回数(S)]に1つのログファイルに書き込む回数を入力します。

注

  • 書き込み中のログファイルの情報を参照したり、表示することはできません。 ログの情報を表示できるようになるまでの待ち時間は [出力間隔]×[同一ファイルへの書き込み回数] です。出力間隔、同一ファイルへの書き込み回数に大きい値を設定すると、ログの出力を開始してからログを表示できるようになるまでの時間が長くなります。


 2.2.2 ログの出力先ディレクトリを指定する

方法

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [ログ]タブをクリックします。
  3. [ディレクトリ(D)]にディレクトリ名を入力します。

注

  • ログを出力するディレクトリは、ASTEC Eyesまたはリモートモジュールをインストールしたディレクトリからの相対パスで指定します。デフォルトはlogです。
  • ログの出力先ディレクトリは、事前に作成しておく必要があります。


 2.2.3 ログファイルを圧縮して保存する

ログファイルをbzip2で圧縮して保存できます。

方法

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [ログ]タブをクリックします。
  3. [圧縮して出力する(C)]チェックボックスにチェックを付けます。

注

  • ログファイルを圧縮するとログを保存するディスク容量を減らすことできますが、ログの表示に時間がかかります。


 2.2.4 古いログファイルを自動的に削除する

方法

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [ログ]タブをクリックします。
  3. [自動で削除する(R)]チェックボックスにチェックを付け、削除するまでの日数を入力します。


 3 キャプチャ機能

ネットワークに流れているパケットをASTEC Eyes内のバッファ (キャプチャバッファ) に取り込んだり、ファイルに書き出す機能です。

キャプチャバッファはASTEC Eyesまたはリモートモジュールがインストールされているホストのメモリ上に、 インタフェースごとに確保されます。 キャプチャバッファに取り込んだデータやキャプチャファイルから読み込んだデータをキャプチャデータと呼びます。

キャプチャには、 一旦キャプチャを停止してからデータを解析する通常のキャプチャ、 キャプチャしながらデータを解析するリアルタイムデコードキャプチャ、 およびファイルにキャプチャしたデータを保存する連続キャプチャがあります。


 3.1.1 パケットをキャプチャしてデコードする

方法

  1. キャプチャを開始します。
  2. キャプチャを停止します。
  3. キャプチャしたパケットをデコードします。

注

  • デコードしたキャプチャデータを保存せずにデコードビューのウィンドウを閉じると、ウィンドウを閉じてよいかたずねる[ASTEC Eyes]ダイアログが現れます。 <Shift>キーを押しながらデコードビューのウィンドウを閉じると、[ASTEC Eyes]ダイアログは現れず、保存していないデータは失われます。


 3.1.2 パケットをキャプチャしてリアルタイムデコードを行う

方法

  1. リアルタイムデコードキャプチャを行うように、キャプチャ方法を指定します。
  2. キャプチャを開始します。 リアルタイムデコードビューにキャプチャ中のデータのデコード結果が表示されます。

注

  • リアルタイムデコードは、ASTEC Eyes基本パッケージをインストールしたホストのネットワークインタフェースに対してのみ実行できます。
  • リアルタイムデコードビューを閉じても、キャプチャを停止するまでデータをキャプチャし続けます。
  • リアルタイムデコードビューを閉じた後もういちど開くと、リアルタイムデコードビューを閉じていた間に流れたデータの解析結果も表示します。


 3.1.3 キャプチャを開始する

方法1

  1. インタフェースを選びます。
  2. メインウィンドウの[キャプチャ(C)]メニューから[キャプチャ開始(S)]を選びます。
方法2
  1. インタフェースを選びます。
  2. インタフェースツールバーの[キャプチャ開始]ボタン( [image])をクリックします。
方法3
  1. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  2. [キャプチャ開始(S)]を選びます。

注

  • リアルタイムデコードモードのときは、キャプチャを開始するとリアルタイムデコードビューが表示されます。


 3.1.4 キャプチャを停止する

方法1

  1. インタフェースを選びます。
  2. メインウィンドウの[キャプチャ(C)]メニューから[キャプチャ停止(I)]を選びます。
方法2
  1. インタフェースを選びます。
  2. インタフェースツールバーの[キャプチャ停止]ボタン( [image])をクリックします。
方法3
  1. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  2. [キャプチャ停止(I)]を選びます。


 3.1.5 クイックリターン機能を使う

ネットワークの状態を調べるときに、パケットのキャプチャとデコードを繰り返したいことがあります。 そのような場合、キャプチャの停止、デコードビューの作成、キャプチャデータの削除、キャプチャの開始という一連の操作を繰り返す必要があります。 この一連の操作を一つの機能としてまとめたものがクイックリターン機能です。

方法1

  1. インタフェースを選びます。
  2. メインウィンドウの[キャプチャ(C)]メニューから[クイックリターン(Q)]を選びます。
方法4
  1. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  2. [クイックリターン(Q)]を選びます。

注

  • リアルタイムデコード を行っているときは、クイックリターン機能を使えません。
  • クイックリターン機能を使うと、キャプチャバッファのコピーを作ってデコードビューに表示した後、キャプチャバッファのデータを削除してからキャプチャを再開します。データを保存せずにデコードビューを閉じると、デコードビューに表示していたデータは失われます。
    デコードしたキャプチャデータを保存する方法については、 「デコードしたキャプチャデータを保存する」を参照してください。 デコード結果をテキスト形式で保存するには、「デコード結果をテキストファイルに保存する」を参照してください。
  • キャプチャバッファのデータをデコードする方法については、「キャプチャバッファのデータをデコードする」を参照してください。


 3.1.6 キャプチャバッファのデータを保存する

キャプチャバッファのデータはファイルに保存できます。

方法

  1. インタフェースを選びます。
  2. メインウィンドウの[ファイル(F)]メニューから[キャプチャバッファの保存(T)...]を選びます。
  3. ファイル名を指定し、[保存(S)]ボタンをクリックします。

注

  • リアルタイムデコードのウィンドウからはキャプチャバッファのデータを保存できません。 一旦デコードビューを表示してから保存してください。
  • 保存するキャプチャデータのファイル形式はSniffer互換の非圧縮フォーマット (拡張子.enc)、またはそれをbzip2で圧縮した形式です(拡張子.ebz)。 デフォルトではSniffer互換の非圧縮フォーマットで保存します。


 3.1.7 キャプチャバッファのデータを削除する

方法1

  1. インタフェースを選びます。
  2. メインウィンドウの[キャプチャ(C)]メニューから[キャプチャデータの削除(A)]を選びます。
方法2
  1. インタフェースを選びます。
  2. インタフェースツールバーの[キャプチャデータの削除]ボタン( [image])をクリックします。
方法3
  1. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  2. [キャプチャデータの削除(A)]を選びます。

注

  • リアルタイムデコードを行っているときには、キャプチャバッファのデータの削除操作は行えません。
  • キャプチャバッファ内に保存していないデータがあったり、表示していないデータがある場合、データを削除してよいかどうかをたずねる[ASTEC Eyes]ダイアログが現れます。
    <Shift>キーを押しながら操作すると、[ASTEC Eyes]ダイアログを表示せずにキャプチャバッファのデータを削除します。


 3.1.8 キャプチャ方法を指定する

キャプチャデータをリアルタイムでデコードするかどうかを指定します。

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[キャプチャ]をクリックします。
  3. [インタフェース(I)]のリストからインタフェースを選びます。
  4. リアルタイムデコードを行うときは[リアルタイムデコード(R)]のチェックを付けます。リアルタイムデコードを行わないときは[リアルタイムデコード(R)]のチェックをはずします。
リアルタイムデコードを行う場合は、[オプション設定]ダイアログの次の値も指定します。
  1. リアルタイムデコードビューに表示するデータの量を[保持するパケットの総バイト数(H)]に入力します。
  2. データの量が[保持するパケットの総バイト数(H)]を超えたときの動作を指定します。 キャプチャを停止する場合は[この値を超えたらリアルタイムデコードを停止する]にチェックを付け、古いデータに上書きする場合はチェックをはずします。

注

  • [保持するパケットの総バイト数(H)]の最小値は4Mバイトです。最大値は、ASTEC Eyes基本パッケージが動作しているホストの実メモリサイズの1/4です。


 3.1.9 キャプチャバッファのサイズを変える

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[キャプチャ]をクリックします。
  3. [インタフェース(I)]のリストからインタフェースを選びます。
  4. [サイズ(S)]にキャプチャバッファのサイズを入力します。

注

  • キャプチャバッファのサイズの最小値は2Kバイトです。最大値は、ASTEC Eyes基本パッケージまたはリモートモジュールが動作しているホストの実メモリサイズの1/4です。


 3.1.10 キャプチャバッファがいっぱいになったときの動作を設定する

設定できる動作はオーバーライトとキャプチャ停止の2つです。 オーバーライトを選ぶと、バッファ内の最も古いデータから順に上書きします。 キャプチャ停止を選ぶと、自動的にキャプチャを停止します。

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[キャプチャ]をクリックします。
  3. [インタフェース(I)]のリストからインタフェースを選びます。
  4. [オーバーライト(O)]、または[キャプチャ停止(D)]をクリックします。

注

  • リアルタイムデコードモードでは、キャプチャバッファがいっぱいになるとパケットを取りこぼし、リアルタイムデコードビューで取りこぼした直後のパケットがオレンジ色でハイライトされます。


 3.1.11 リモートモジュールでキャプチャしたデータを圧縮して取り込む

リモートモジュールでキャプチャしたデータをデコードするとき、 キャプチャしたデータを圧縮してからローカルホストへ送ることができます。
リモートモジュールとローカルホストとの間のネットワークの帯域が狭い場合やキャプチャデータの量が多い場合、 転送量を減らすことによってネットワークにかける負荷を軽減し、送信時間を短縮できます。

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[キャプチャ]をクリックします。
  3. [インタフェース(I)]のリストからインタフェースを選びます。
  4. [データを圧縮して取り込む(C)]チェックボックスにチェックを付けます。


 3.2 キャプチャフィルタ

通常のキャプチャやリアルタイムデコードキャプチャ に対して、キャプチャするデータやキャプチャの開始、停止のタイミングを指定するフィルタです。 3種類のフィルタがあります。

  • キャプチャフィルタ
  • キャプチャ開始トリガ
  • キャプチャ停止トリガ


 3.2.1 特定の条件を満たすパケットをキャプチャする

特定の条件に合致するパケットのみをキャプチャするには、フィルタエディタを使ってキャプチャフィルタを設定します。 キャプチャフィルタはインタフェースごとに設定します。

方法

  1. フィルタエディタを開きます。
  2. 対象とするインタフェースの[ [image] キャプチャフィルタ]をクリックします。
  3. 論理式を入力します。

注

  • 論理式の入力について、詳しくはユーザーズガイドの7章「フィルタエディタ」を参照してください。


 3.2.2 特定のパケットがネットワークに流れたらキャプチャを開始する

特定のパケットがネットワークに流れたことをきっかけにしてキャプチャを開始するには、 フィルタエディタを使ってキャプチャ開始トリガを設定します。

方法

  1. フィルタエディタを開きます。
  2. 対象とするインタフェースの[ [image] キャプチャ開始トリガ]をクリックします。
  3. 論理式を入力します。

注

  • キャプチャ開始トリガを使うと、キャプチャ開始のきっかけとなったパケットもキャプチャされます。
  • 論理式の入力について、詳しくはユーザーズガイドの7章「フィルタエディタ」を参照してください。


 3.2.3 特定のパケットがネットワークに流れたらキャプチャを停止する

特定のパケットがネットワークに流れたことをきっかけにしてキャプチャを停止するには、 フィルタエディタを使ってキャプチャ停止トリガを設定します。

方法

  1. フィルタエディタを開きます。
  2. 対象とするインタフェースの[ [image] キャプチャ停止トリガ]をクリックします。
  3. 論理式を入力します。

注

  • キャプチャ停止トリガを使うと、キャプチャ停止のきっかけとなったパケットもキャプチャされます。
  • 論理式の入力について、詳しくはユーザーズガイドの7章「フィルタエディタ」を参照してください。


 3.3 連続キャプチャ機能

ネットワークに流れているパケットをキャプチャし、ファイルに保存する機能です。 キャプチャバッファを最大サイズに設定してもバッファに収まらないような大きなデータをキャプチャしたいときは、連続キャプチャ機能を使います。 連続キャプチャしたデータは複数のファイルに分けて保存されます。

連続キャプチャを行うためには、対象とするインタフェースがインストールされているホストの設定権限が必要です。


 3.3.1 連続キャプチャの開始

方法

  1. 設定権限がない場合には、設定権限を取得します。
  2. [ホストのプロパティ]ダイアログを開きます。
  3. [連続キャプチャ]タブをクリックします。
  4. 必要に応じて次の項目を設定します。
    • 1つの連続キャプチャファイルのサイズ
    • ファイルを保存するディレクトリ
    • 連続キャプチャを停止するハードディスクの空き容量
    • 自動削除を行うかどうか
  5. [ステータス(S)]領域で、対象とするインタフェースをクリックします。
  6. [出力(O)]ボタンをクリックします。

注

  • 連続キャプチャ中は、ASTEC Eyesまたはリモートモジュールが動作しているホストのハードディスクの空き容量は減りつづけます。 ハードディスクの空き容量が指定したサイズ以下になると、連続キャプチャは自動的に停止します。


 3.3.2 連続キャプチャの停止

方法

  1. 設定権限がない場合には、設定権限を取得します。
  2. [ホストのプロパティ]ダイアログを開きます。
  3. [連続キャプチャ]タブをクリックします。
  4. [ステータス(S)]領域で、対象とするインタフェースをクリックします。
  5. [停止(I)]ボタンをクリックします。

注

  • 連続キャプチャ中は、ASTEC Eyesまたはリモートモジュールが動作しているホストのハードディスクの空き容量は減りつづけます。 ハードディスクの空き容量が指定したサイズ以下になると、連続キャプチャは自動的に停止します。


 3.3.3 連続キャプチャファイルの出力先ディレクトリを指定する

方法

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [連続キャプチャ]タブをクリックします。
  3. [ディレクトリ(D)]にディレクトリ名を入力します。

注

  • 連続キャプチャしたファイルを保存するディレクトリは、ASTEC Eyes基本パッケージまたはリモートモジュールをインストールしたディレクトリからの相対パスで指定します。
  • 連続キャプチャの出力先ディレクトリは、事前に作成しておく必要があります。


 3.3.4 連続キャプチャファイルのサイズを指定する

連続キャプチャしたデータは、複数のファイルに分けて保存されます。 1つのファイルに何Kバイト書き込んだら次のファイルへ書き込み始めるかを指定できます。

方法

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [連続キャプチャ]タブをクリックします。
  3. [最大ファイルサイズ(M)]にサイズを入力します。


 3.3.5 ディスクの空き容量が指定値以下になったら連続キャプチャを停止する

インタフェースがインストールされているホストのディスクの空き容量が一定の値以下になると、連続キャプチャの出力は自動的に止まります。 連続キャプチャを停止する際のディスクの空き容量を設定できます。

方法

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [連続キャプチャ]タブをクリックします。
  3. [出力停止(E)]にサイズを入力します。


 3.3.6 パケットの先頭部分のみ保存する

連続キャプチャで保存するパケットの内容を先頭から一定のバイト数までで切り捨てると、 パケットの詳細を全て見ることはできなくなりますが、 連続キャプチャファイルの容量を削減し、 より多くの(より長期間の)パケットを保存することができます。

方法

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [連続キャプチャ]タブをクリックします。
  3. [切り捨てを行う(S)]チェックボックスにチェックを付け、 保存するパケットの最大の長さをバイト数で指定します。

注

  • 保存するパケットの最大の長さには、68バイト以上の値を指定します。 これより短いと送信元、受信先やアプリケーションプロトコルを判別できなくなるためです。


 3.3.7 常に最新のパケットを残すようにキャプチャしつづける

連続キャプチャの自動削除の機能を利用すると、 ハードディスクの空き容量が減ってきたときでもキャプチャを停止しないで、 古いファイルから順に削除し、 常に最新のパケットを保存したファイルが残るようにキャプチャし続けることができます。

方法

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [連続キャプチャ]タブをクリックします。
  3. [自動削除を行う(R)]チェックボックスにチェックを付け、[ディスク空き容量]を指定します。

注

  • [ディスク空き容量]には、[出力停止(E)]よりも大きな値を指定します。


 3.3.8 連続キャプチャデータのプロパティを表示する

方法

  1. インタフェースセレクタウィンドウ内の連続キャプチャデータのエントリを右クリックします。
  2. [プロパティ(P)...]を選びます。


 3.4 連続キャプチャフィルタ

連続キャプチャに対して、キャプチャするデータやキャプチャの開始、停止のタイミングを指定するフィルタです。 3種類のフィルタがあります。

  • 連続キャプチャフィルタ
  • 連続キャプチャ開始トリガ
  • 連続キャプチャ停止トリガ


 3.4.1 特定の条件を満たすパケットを連続キャプチャする

特定の条件に合致するパケットのみを連続キャプチャするには、フィルタエディタを使って連続キャプチャフィルタを設定します。

方法

  1. フィルタエディタを開きます。
  2. 対象とするインタフェースの[ [image] 連続キャプチャフィルタ]をクリックします。
  3. 論理式を入力します。

注

  • 論理式の入力について、詳しくはユーザーズガイドの7章「フィルタエディタ」を参照してください。


 3.4.2 特定のパケットがネットワークに流れたら連続キャプチャを開始する

特定のパケットがネットワークに流れたことをきっかけにして連続キャプチャを開始するには、フィルタエディタを使って連続キャプチャ開始トリガを設定します。

方法

  1. フィルタエディタを開きます。
  2. 対象とするインタフェースの[ [image] 連続キャプチャ開始トリガ]をクリックします。
  3. 論理式を入力します。

注

  • 連続キャプチャ開始トリガを使うと、キャプチャ開始のきっかけとなったパケットもキャプチャされます。
  • 論理式の入力について、詳しくはユーザーズガイドの7章「フィルタエディタ」を参照してください。


 3.4.3 特定のパケットがネットワークに流れたら連続キャプチャを停止する

特定のパケットがネットワークに流れたことをきっかけにして連続キャプチャを停止するには、フィルタエディタを使って連続キャプチャ停止トリガを設定します。

方法

  1. フィルタエディタを開きます。
  2. 対象とするインタフェースの[ [image] 連続キャプチャ停止トリガ]をクリックします。
  3. 論理式を入力します。

注

  • 連続キャプチャ停止トリガを使うと、キャプチャ停止のきっかけとなったパケットもキャプチャされます。
  • 論理式の入力について、詳しくはユーザーズガイドの7章「フィルタエディタ」を参照してください。


 3.5 キャプチャ時間の同期

キャプチャしたパケットに付与される時間(キャプチャ時間)を GUI部が動作するPCのシステム時間と同期することができます。

  • キャプチャ時間を同期する
  • キャプチャ時間の同期を解除する
  • キャプチャ時間を確認する


 3.5.1 キャプチャ時間を同期する

キャプチャ時間を同期する方法には次の2種類があります。

  • 特定のホストのキャプチャ時間を同期する
  • 設定権限のある全てのホストのキャプチャ時間を同期する

特定のホストのキャプチャ時間を同期する

方法

  1. インタフェースセレクタウィンドウ内のホストを選んで分を右クリックします。
  2. [キャプチャ時間を同期(Y)]を選びます。

注

  • GUIの動作するPC (localhost) の場合でも、 キャプチャ時間とシステム時間が一致しているとは限りません。 必要に応じてキャプチャ時間を同期させます。
  • 設定権限のないホストを選んだ場合、 メニューから[キャプチャ時間を同期(Y)]を選ぶことはできません。 キャプチャ時間を同期したい場合は、 設定権限を取得してから行います。

設定権限のある全てのホストのキャプチャ時間を同期する

方法

  1. インタフェースセレクタウィンドウ内の何も表示されていない部分を右クリックします。
  2. [キャプチャ時間を同期(Y)]を選びます。
どのホストのキャプチャ時間を同期したかは、メッセージウィンドウに表示されます。


 3.5.2 キャプチャ時間の同期を解除する

キャプチャ時間の同期を解除する方法には次の2種類があります。

  • 特定のホストとのキャプチャ時間の同期を解除する
  • 設定権限のある全てのホストとのキャプチャ時間の同期を解除する

特定のホストとのキャプチャ時間の同期を解除する

方法

  1. インタフェースセレクタウィンドウ内のホストを選んで分を右クリックします。
  2. [キャプチャ時間の同期を解除(R)]を選びます。

注

  • 設定権限のないホストを選んだ場合、 メニューから[キャプチャ時間の同期を解除(R)]を選ぶことはできません。 キャプチャ時間の同期を解除したい場合は、 設定権限を取得してから行います。

設定権限のある全てのホストとのキャプチャ時間の同期を解除する

方法

  1. インタフェースセレクタウィンドウ内の何も表示されていない部分を右クリックします。
  2. [キャプチャ時間の同期を解除(R)]を選びます。
どのホストとのキャプチャ時間の同期を解除したかは、 メッセージウィンドウに表示されます。


 3.5.3 キャプチャ時間を確認する

キャプチャ時間がGUIの動作するPC のシステム時間とどのくらい違っているかを確認する方法は2種類があります。

  • 特定のホストのキャプチャ時間を確認する
  • 接続している全てのホストのキャプチャ時間を確認する

特定のホストのキャプチャ時間を確認する

方法

  1. インタフェースセレクタウィンドウ内のホストを選んで分を右クリックします。
  2. [キャプチャ時間を取得(T)]を選びます。
結果はメッセージウィンドウに表示されます。

接続している全てのホストのキャプチャ時間を確認する

方法

  1. インタフェースセレクタウィンドウ内の何も表示されていない部分を右クリックします。
  2. [キャプチャ時間を取得(T)]を選びます。
結果はメッセージウィンドウに表示されます。


 4 デコード機能

キャプチャしたデータを解析したり、ファイルに保存しておいたデータや連続キャプチャしたデータを解析する機能です。


 4.1.1 リアルタイムデコードを行う

方法1

  1. リアルタイムでコードキャプチャを行うようにキャプチャ方法を指定します。
  2. インタフェースを選びます。
  3. キャプチャを開始します。
方法2
  1. インタフェースを選びます。
  2. メインウィンドウの[キャプチャ(C)]メニューから[リアルタイムデコードビュー(V)]を選びます。
方法3
  1. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  2. [リアルタイムデコードビュー(V)]を選びます。


 4.1.2 詳細なデコード結果を見る

リアルタイムデコードビューはパケットの概要を表示します。 より詳しい解析結果を見るにはデコードビューを表示します。

方法1

リアルタイムデコードビューのツールバーの[デコードビュー表示(パケット削除)]ボタン( [image])をクリックします。 デコードビューが表示され、リアルタイムデコードビューのデータは削除されます。

方法2

リアルタイムデコードビューのツールバーの[デコードビュー表示]ボタン( [image])をクリックします。 デコードビューが表示されます。リアルタイムデコードビューのデータは削除されません。


 4.1.3 リアルタイムデコードのデータを削除する

方法1

リアルタイムデコードビューのツールバーの[全パケット消去]ボタン( [image])をクリックします。
リアルタイムデコードビューの全てのデータが削除されます。

方法2

リアルタイムデコードビューのツールバーの[選択まで削除]ボタン( [image])をクリックします。
リアルタイムデコードビューのフォーカスがある行までのデータが削除されます。

方法3

リアルタイムデコードビューのツールバーの[デコードビュー表示(パケット削除)]ボタン( [image])をクリックします。
リアルタイムデコードビューのデータは削除され、デコードビューが表示されます。

注

  • [選択まで削除]ボタン( [image])をクリックしたときには、フォーカスのある行も削除されます。


 4.1.4 パケットの取りこぼしを調べる

リアルタイムデコードビューはキャプチャバッファに一時的にキャプチャした後、デコードします。ネットワークを流れるデータ量が多くて、キャプチャバッファのサイズを超えたときには、パケットの取りこぼしが発生します。

リアルタイムデコードビューは、取りこぼした直後のパケットをオレンジ色でハイライトします。 リアルタイムデコードビューのツールバーの[次のドロップ]ボタン( [image])をクリックすると、次のハイライトされたパケットにフォーカスを移動します。


 4.2.1 キャプチャバッファのデータをデコードする

方法1

  1. インタフェースを選びます。
  2. メインウィンドウの[キャプチャ(C)]メニューから[デコードビュー(N)]を選びます。
方法2
  1. インタフェースを選びます。
  2. インタフェースツールバーの[デコードビュー]ボタン( [image])をクリックします。
方法3
  1. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  2. [デコードビュー(N)]を選びます。

注

  • デコードしたキャプチャデータを保存せずにデコードビューのウィンドウを閉じると、データを保存するかどうかをたずねる[ASTEC Eyes]ダイアログが現れます。
    <Shift>キーを押しながら操作すると、[ASTEC Eyes]ダイアログを表示せずにウィンドウを閉じます。


 4.2.2 デコードできるファイルの形式

デコードできるファイルの形式は次のとおりです。
ファイルの形式 | 拡張子
Sniffer互換の非圧縮フォーマット | .enc .cap
Sniffer互換の圧縮フォーマット | .enc
.encファイルをbzip2で圧縮したもの | .ebz .enc.bz2
連続キャプチャ機能の出力ファイル | .jil
.jilファイルをbzip2で圧縮したもの | .jil.bz2
Microsoft Network Monitor互換の非圧縮フォーマット | .cap
Wild Packets Ether Peek互換フォーマット | .pkt
Novell LANalyzer互換フォーマット | .tr1
tcpdumpの出力ファイル | 不定
snoopの出力ファイル | 不定


 4.2.3 キャプチャファイルをデコードする

方法1

  1. メインウィンドウの[ファイル(F)]メニューから[キャプチャデータを開く(O)...]を選びます。
  2. ファイル名を指定します。
方法2
  1. メインウィンドウのコモンツールバーの[キャプチャデータを開く]ボタン( [image])をクリックします。
  2. ファイル名を指定します。
方法3
  1. <Ctrl-O>キーを押します。
  2. ファイル名を指定します。
方法4
ドラッグアンドドロップの機能を使います。デコードしたいファイルをWindowsのエクスプローラやフォルダなどからドラッグし、ASTEC Eyesのメインウィンドウにドロップします。
方法5
Windowsのエクスプローラやフォルダなどで、デコードしたいファイルをダブルクリックします (拡張子が.enc、.ebz、.cap、または.jilのファイルのみ)。


 4.2.4 キャプチャデータマネジャーを使う

キャプチャファイルの一部をデコードしたり、複数のキャプチャファイルをマージしてデコードできます。

方法

  1. メインウィンドウの[ファイル(F)]メニューから[キャプチャデータマネジャーで開く(E)...]を選びます。
  2. ファイルを指定します。複数のファイルを指定できます。
  3. デコードする範囲を指定します。範囲を指定する方法には次の2通りがあります。
    • デコード開始時刻とデコード終了時刻を指定する
    • ヘッダー属性を指定する
  4. [デコード(D)]ボタンをクリックします。

注

[統計情報の表示]ボタン( [image]) をクリックすると、キャプチャデータから統計データを作成し、グラフや表で表示できます。デコードする範囲を指定するときの参考になるでしょう。


 4.2.5 キャプチャファイルの一部をデコードする

ファイルに保存したデータが大きい場合、デコードに時間がかかり、メモリの使用量も増えます。 このような場合には、範囲を指定してキャプチャデータの一部だけをデコードできます。

方法

[キャプチャデータマネジャー]ダイアログを使います。


 4.2.6 複数のキャプチャファイルをマージしてデーコードする

複数のファイルに保存されたキャプチャデータをマージしてデコードできます。 また、期間やパケットのヘッダー属性を指定することにより、デコード範囲を絞り込むこともできます。

方法

  1. [キャプチャデータマネジャー]ダイアログを使います。


 4.2.7 キャプチャデータの統計情報をグラフや表で表示する

キャプチャデータに対して統計処理を行い、グラフや表で表示できます。

方法1

  1. デコードビューのツールバーの[統計情報の表示]ボタン( [image])ボタンをクリックします。
  2. 統計情報の種類を選びます。

方法2

  1. [キャプチャデータマネジャー]ダイアログを開きます。
  2. [統計情報の表示]ボタン( [image])をクリックます。
  3. 統計情報の種類を選びます。

注

  • キャプチャデータを基にした場合、モニタやログの統計情報と次の点が異なります。
    • 「MAC層トラフィック」のウィンドウにピーク値は表示されません。
    • MAC層エラーフレーム数は表示できません。
    • タイムスパンを切り替えられません。
    • 折れ線グラフのプロット間隔を変えられます。


 4.2.8 連続キャプチャデータをデコードする

連続キャプチャデータの出力先として設定したディレクトリのキャプチャデータをデコードします。

方法

  1. インタフェースセレクタウィンドウ内のホストのエントリを右クリックします。
  2. [キャプチャデータの一覧を作成(A)]を選びます。
  3. インタフェースセレクタウィンドウ内の連続キャプチャデータのエントリを右クリックします。
  4. [連続キャプチャデータをデコードする(D)...]を選びます。
  5. [キャプチャデータの取得]領域で[開始時刻]と[終了時刻]を指定します。
  6. [デコード(D)]ボタンをクリックします。[キャプチャデータマネジャー(C)]ボタンをクリックして、キャプチャデータマネジャーを使うこともできます。


 4.2.9 連続キャプチャファイルを保存したディレクトリを指定してデコードする

連続キャプチャファイルが保存されているディレクトリを指定してデコードします。

連続キャプチャファイルの出力先のディレクトリを変更した場合でも、連続キャプチャファイルをデコードできます。 また、別のホストで動作しているASTEC Eyes基本パッケージやリモートモジュールで保存した連続キャプチャファイルをローカルなホストへコピーしてデコードできます。

方法1

  1. メインウィンドウの[ファイル(F)]メニューから[連続キャプチャのディレクトリを開く(J)...]を選びます。
  2. インタフェースセレクタウィンドウ内の連続キャプチャデータのエントリを右クリックします。
  3. [連続キャプチャデータをデコードする(D)...]を選びます。
  4. [キャプチャデータの取得]領域で[開始時刻]と[終了時刻]を指定します。
  5. [デコード(D)]ボタンをクリックします。[キャプチャデータマネジャー(C)]ボタンをクリックして、キャプチャデータマネジャーを使うこともできます。

方法2

  1. インタフェースセレクタウィンドウ内の何も表示されていない部分を右クリックします。
  2. [連続キャプチャのディレクトリを開く(J)...]を選びます。
  3. インタフェースセレクタウィンドウ内の連続キャプチャデータのエントリを右クリックします。
  4. [連続キャプチャデータをデコードする(D)...]を選びます。
  5. [キャプチャデータの取得]領域で[開始時刻]と[終了時刻]を指定します。
  6. [デコード(D)]ボタンをクリックします。[キャプチャデータマネジャー(C)]ボタンをクリックして、キャプチャデータマネジャーを使うこともできます。

注

  • 特定の連続キャプチャファイルをデコードしたり、複数の連続キャプチャファイルを指定してデコードすることもできます。


 4.2.10 ログのウィンドウ上で期間を指定してデコードする

ログと連続キャプチャの両方の出力データがあるときには、ログのウィンドウ上で期間を指定して連続キャプチャデータをデコードできます。

  1. 連続キャプチャデータに対応するログのエントリを作成します。
  2. ログを表示します。
  3. ログのウィンドウにキャプチャデータインディケータを表示します。
  4. デコード期間を指定して、デコードします。
連続キャプチャデータに対応するログのエントリを作成する

方法1

  1. インタフェースセレクタウィンドウ内のホストのエントリを右クリックします。
  2. [ログの一覧を作成(L)]を選びます。
  3. ホストのエントリを右クリックします。
  4. [キャプチャデータの一覧を作成(A)]を選びます。
方法2
  1. メインウィンドウの[ファイル(F)]メニューから[ログのディレクトリを開く(L)...]を選びます。
  2. ログを保存したディレクトリを指定します。
  3. メインウィンドウの[ファイル(F)]メニューから[連続キャプチャのディレクトリを開く(J)...]を選びます。
  4. 連続キャプチャファイルを保存したディレクトリを指定します。
  5. ログと連続キャプチャデータを関連付けます。
方法3
  1. インタフェースセレクタウィンドウ内のエントリが表示されていないところを右クリックします。
  2. [ログのディレクトリを開く(L)...]を選びます。
  3. ログを保存したディレクトリを指定します。
  4. インタフェースセレクタウィンドウのエントリが表示されていないところを右クリックします。
  5. [連続キャプチャのディレクトリを開く(J)...]を選びます。
  6. 連続キャプチャファイルを保存したディレクトリを指定します。
  7. ログと連続キャプチャデータを関連付けます。
キャプチャデータインディケータを表示する

方法1

  1. 折れ線グラフを表示します。
  2. ログのウィンドウのツールバーの[キャプチャデータインディケータ]ボタン( [image])をクリックします。
方法2
  1. 折れ線グラフを表示します。
  2. ウィンドウを右クリックし、[キャプチャデータインディケータ(A)]を選びます。

注

  • [キャプチャデータインディケータ]ボタン( [image])を押すと、キャプチャデータインディケータが表示されます。もう一度押すとキャプチャデータインディケータは非表示になります。
デコード期間を指定する

方法

  1. ログのウィンドウのツールバーの[グラフ解析機能]ボタン( [image])をクリックします。
  2. [垂直カーソル]ボタン( [image])をクリックします。
  3. マウスをドラッグして、デコードする期間を指定します。
  4. [デコードビュー]ボタン( [image])をクリックします。

注

  • グラフ解析機能について、詳しくは「グラフのX軸の値を読む」を参照してください。


 4.2.11 ログと連続キャプチャデータを関連付ける

ログファイルを保存したディレクトリを指定して作成したログのエントリと、連続キャプチャファイルを保存したディレクトリを指定して作成した連続キャプチャデータのエントリを関連付けます。

ログウィンドウ上で期間を指定してデコードするには、連続キャプチャデータを関連付けた後で、ログのウィンドウを表示します。

連続キャプチャデータとログを関連付ける

方法

インタフェースセレクタウィンドウで、連続キャプチャデータのエントリをドラッグし、ログのエントリ上でドロップします。

連続キャプチャデータとログの関連付けを解除する

方法

  1. 連続キャプチャデータのエントリを右クリックします。
  2. [関連付けを解除(U)]を選びます。

注

  • ログと連続キャプチャデータは、同一インタフェースで取得したものを関連付ける必要があります。 そのためには、ログと連続キャプチャデータのプロパティに表示されるNIC IDが同一のものを関連付けると良いでしょう。
    ログおよび連続キャプチャデータのプロパティを表示する方法については、 「ログのプロパティを表示する」と「連続キャプチャデータのプロパティを表示する」を参照してください。


 4.2.12 TCPストリームを再構成してデコードする

方法1

デコードビューのツールバーの[ストリームビュー]ボタン( [image])をクリックします。
方法2
  1. デコードビューを右クリックします。
  2. [ストリームビュー(S)]を選びます。

注

  • 何らかの原因でストリームを構成するパケットが欠けている場合、青色でハイライト表示されたレコードが現れます。このレコードはデータの欠損を示し、TCPのシーケンス番号と欠けているバイト数が表示されます。
    [ストリームID]カラムの見出しをクリックし[青色の行にチェックをつける(B)]を選ぶと、ハイライト表示された行にチェックがつきます。選ぶときに、<Shift>キーを押しながら選ぶと、ハイライト表示された行だけを表示するようになります。


 4.2.13 TCPストリームをセッションごとに表示する

TCPストリームを再構築し、セッションごとにまとめて表示することもできます。 このような表示を行うモードをシーケンスモードと呼びます。

方法1

デコードビューのツールバーの[ストリームビュー(シーケンスモード)]ボタン( [image])をクリックします。
方法2
  1. デコードビューを右クリックします。
  2. [ストリームビュー(シーケンスモード)(M)]を選びます。

注

  • 何らかの原因でストリームを構成するパケットが欠けている場合、赤色の文字で"Lack of Data"と表示された矢印が[シーケンス]領域に現れます。


 4.2.14 特定のパケットが属すストリームだけを表示する

方法

  1. デコードビューの[サマリ]領域で特定のパケットを右クリックします。
  2. [選択されたパケットのストリーム(P)]を選びます。


 4.3.1 デコードしたキャプチャデータを保存する

キャプチャバッファからデコードしてデコードビューに表示されているデータをファイルに保存します。

デコードビューを作成した後でキャプチャバッファの内容を削除したり、キャプチャバッファの内容を変更したときでも、デコードした時点のキャプチャバッファのスナップショットを保存できます。

方法

  1. デコードビューをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[デコードしたキャプチャデータの保存(S)...]を選ぶか、<Ctrl-S>キーを押します。
  3. ファイル名や保存する形式を指定し、[保存(S)]ボタンをクリックします。

注

  • 保存できるファイルの形式は、Sniffer互換の非圧縮フォーマット(拡張子.enc)、またはそれをbzip2で圧縮した形式(拡張子.ebz)です。
  • デコードしたキャプチャデータを保存せずにデコードビューのウィンドウを閉じると、ウィンドウを閉じてよいのかをたずねる[ASTEC Eyes]ダイアログが現れます。
    <Shift>キーを押しながら操作すると、[ASTEC Eyes]ダイアログを表示せずにウィンドウを閉じます。


 4.3.2 特定の条件を満たすパケットのみを保存する

方法

  1. 保存したいキャプチャデータを表示しているデコードビューをクリックします。
  2. 簡易フィルタ、ディスプレイフィルタを使って表示するパケットを絞り込みます。
  3. メインウィンドウの[ファイル(F)]メニューから[表示されているパケットのみ保存(D)...]を選びます。


 4.3.3 デコード結果をテキストファイルに保存する

方法

  1. 保存したいデコード結果を表示しているデコードビューまたはストリームビューをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[デコード結果の保存(F)...]を選びます。
  3. ファイルに出力する範囲などのオプションを設定します。

注

  • デコード結果はWindowsのメモ帳、ワードパッド、Microsoft Word、Microsoft Excelなどのアプリケーションで利用できます。
  • Microsoft Excelでは、ダブルクォーテーション（"）やシングルクォーテーション（'）は特別な意味を持ちます。Microsoft Excelでデコード結果を利用する場合には、クォーテーションマークの出力をカスタマイズする必要があります。


 4.3.4 保存するテキストの形式をカスタマイズする

Microsoft Excelでは、文字列中にダブルクォートが含まれていると、区切り記号として扱われたり、表示が変わったりすることがあります。 また、文字列の先頭のシングルクォートは特別な意味を持ちます。 このため、Microsoft Excelでデータを利用する場合には、クォーテーションマークの出力をカスタマイズする必要があります。

方法

  1. メインウィンドウの[ファイル(F)]メニューから[デコード結果の保存(F)...]を選びます。
  2. [詳細設定(D)...]ボタンをクリックします。
  3. 区切り記号、クォーテーションマークを出力する方法を設定します。

注

  • 区切り記号、クォーテーションマークの出力について、詳しくはユーザーズガイドを参照してください。


 4.3.5 デコード結果を他のアプリケーションにコピーする

リアルタイムデコードビューやデコードビュー、ストリームビューに表示したデコード結果を他のアプリケーションにコピーできます。コピーするデータの範囲は、コピー元の領域や操作によって異なります。

リアルタイムデコードビューのセルの文字列をコピーする

方法

  1. コピーしたいセルをクリックします。
  2. メインウィンドウの[編集(E)]メニューから[コピー(C)]を選ぶか、<Ctrl-C>キーを押します。
  3. ペースト先のアプリケーションをアクティブにし、<Ctrl-V>キーを押します。

デコードビューやストリームビューの[サマリ]領域、[デコード結果]領域のセルの文字列をコピーする

方法

  1. [サマリ]領域または[デコード結果]領域のコピーしたいセルをクリックします。
  2. メインウィンドウの[編集(E)]メニューから[コピー(C)]を選ぶか、<Ctrl-C>キーを押します。
  3. ペースト先のアプリケーションをアクティブにし、<Ctrl-V>キーを押します。

[ダンプ]領域のハイライト表示の部分をコピーする

方法

  1. [ダンプ]領域にフォーカスを移します。
  2. メインウィンドウの[編集(E)]メニューから[コピー(C)]を選ぶか、<Ctrl-C>キーを押します。
  3. ペースト先のアプリケーションをアクティブにし、<Ctrl-V>キーを押します。

選んだ領域全体の内容をコピーする

方法

  1. コピーしたい領域([サマリ]領域、[デコード結果]領域、または[ダンプ]領域)にフォーカスを移します。
  2. 右クリックします。
  3. [領域全体をコピー(W)]を選びます。
  4. ペースト先のアプリケーションをアクティブにし、<Ctrl-V>キーを押します。

注

  • リアルタイムデコードビューは全体をコピーすることはできません。
  • デコードビューのすべての領域の全内容をコピーすることはできません。


 4.3.6 キャプチャデータの一部をバイナリモードで保存する

キャプチャデータの一部をバイナリモードでファイルに保存できます。たとえば、HTTPのMessage Body部分だけをファイルに保存し、ブラウザなどで開いてみたい場合に使います。

方法

  1. デコードビューまたはストリームビューを右クリックします。
  2. [バイナリ保存(B)...]を選びます。
  3. [始点(S)]と[終点(E)]、および[長さ(L)]に値を入力して、保存範囲を指定します。
  4. [OK]ボタンをクリックし、保存するファイル名を指定します。

注

  • 複数のパケットまたはレコードに渡ってデータを保存することはできません。


 4.4.1 領域間でフォーカスを移す

方法1

フォーカスを移したい領域をクリックします。
方法2
  1. デコードビューまたはストリームビューのウィンドウをクリックします。
  2. <Tab>キーまたは<Shift-Tab>キーを押します。


 4.4.2 特定の領域を拡大表示する

デコードビューおよびストリームビューの[サマリ]領域、[デコード結果]領域、[ダンプ]領域、[セッションリスト]領域、[シーケンス]領域の一つをウィンドウ全体に拡大表示できます。

方法1

拡大表示したい領域をダブルクリックします。もう一度ダブルクリックすると元の状態に戻ります。

方法2

拡大したい領域にフォーカスを移し、ツールバーの[拡大表示]ボタン( [image])をクリックします。もう一度クリックすると元の状態に戻ります。

方法3

  1. 拡大したい領域にフォーカスを移します。
  2. 右クリックし、[表示(V)]を選びます。
  3. [拡大表示(M)]を選びます。もう一度[拡大表示(M)]を選ぶと元の状態に戻ります。
方法4
拡大したい領域にフォーカスを移し、<Z>キーを押します。もう一度<Z>キーを押すと元の状態に戻ります。


 4.4.3 パケットまたはレコードを選ぶ

方法1

[サマリ]領域または[シーケンス]領域で、表示したいパケット、またはレコードに対応する行をクリックします。

方法2

  1. デコードビューまたはストリームビューのウィンドウを右クリックします。
  2. [ジャンプ(J)...]を選びます。
  3. フレームIDまたはストリームIDを指定します。ストリームIDを指定したときには、指定したストリームの先頭のレコードが選ばれます。

方法3

  1. <Ctrl-G>キーを押します。
  2. フレームIDまたはストリームIDを指定します。ストリームIDを指定したときには、指定したストリームの先頭のレコードが選ばれます。

方法4

  1. [サマリ]領域または[シーケンス]領域にフォーカスを移します。
  2. <↑>、<↓>、<Page Up>、<Page Down>、<Home>、または<End>キーを押します。

方法5

<Ctrl-↑>、<Ctrl-↓>、<Ctrl-Home>または<Ctrl-End>キーを押します。この方法では、フォーカスを[サマリ]領域に移す必要はありません。

注

  • 方法2、方法3、方法5はシーケンスモードのストリームビューでは操作できません。


 4.4.4 [デコード結果]領域にデフォルトで表示される行を指定する

  次々にパケットやレコードを見て行く場合、[デコード結果]領域に特定のプロトコルの特定のフィールドが常に見えている状態にできます。

方法

  1. [デコード結果]領域で、特定のプロトコルの特定のフィールドをクリックします。
  2. 他のパケットまたはレコードを選びます。


 4.4.5 レコードを構成しているパケットを探す

方法1

  1. ストリームビューでレコードを選びます。
  2. ストリームビューのツールバーの[デコードビュー]ボタン()をクリックします。
  3. <Alt-↓>または<Alt-↑>キーを押します。

方法2

  1. ストリームビューのレコードを右クリックします。
  2. [構成しているパケットを表示(P)]を選びます。

注

  • 通常のストリームビューでのみ操作できます。
  • 選んだレコードを構成しているパケットは緑色でハイライト表示されます。[フレームID]カラムの見出しをクリックし[緑色の行にチェックをつける(G)]を選ぶと、ハイライト表示された行にチェックがつきます。選ぶときに<Shift>キーを押しながら選ぶと、ハイライト表示された行だけを表示するようになります。


 4.4.6 セッションを構成しているパケットを表示する

方法

  1. [セッションリスト]領域の行をクリックします。
  2. 選んだセッションを構成しているパケットは、デコードビュー上でオレンジ色にハイライト表示されます。
  3. [フレームID]カラムの見出しをクリックし[オレンジ色の行にチェックをつける(O)]を選ぶと、ハイライト表示された行にチェックがつきます。選ぶときに<Shift>キーを押しながら選ぶと、ハイライト表示された行だけを表示するようになります。

注

  • シーケンスモードのストリームビューでのみ操作できます。


 4.4.7 文字列を検索する([サマリ]領域)

デコードビュー、ストリームビューでは、領域ごとに文字列を検索できます。

方法

  1. [サマリ]領域にフォーカスを移します。
  2. メインウィンドウの[編集(E)]メニューから[検索(F)]を選ぶか、<Ctrl-F>キーを押します。
  3. 文字列を入力し、[次を検索(F)]ボタンをクリックします。

注

  • [サマリ]領域では正規表現を使って検索できます。[正規表現(E)]チェックボックスにチェックを付けて、[検索する文字列(N)]に正規表現を入力します。


 4.4.8 文字列を検索する([シーケンス]領域)

[シーケンス]領域では、現在[セッションリスト]領域で選んでいるセッションのレコードを検索の対象とします。 [シーケンス]領域に表示されているレコードのみではなく、すべてのレコードのデコード結果を対象にすることもできます。

方法

  1. [シーケンス]領域にフォーカスを移します。
  2. メインウィンドウの[編集(E)]メニューから[検索(F)]を選ぶか、<Ctrl-F>キーを押します。
  3. すべてのレコードを対象に検索する場合は、[セッションを越えて検索(W)]チェックボックスにチェックを付けます。
  4. 文字列を入力し、[次を検索(F)]ボタンをクリックします。

注

  • 正規表現を使って検索できます。[正規表現(E)]チェックボックスにチェックを付けて、[検索する文字列(N)]に正規表現を入力します。


 4.4.9 文字列を検索する([デコード結果]領域、[ダンプ]領域)

[デコード結果]領域では、通常は[サマリ]領域で選んでいるパケットまたはレコードのデコード結果を検索の対象とします。
[ダンプ]領域では、現在[サマリ]領域で選んでいるパケットまたはレコードの16進ダンプを検索の対象にします。
[サマリ]領域で選んでいるパケットやレコードのみではなく、すべてのパケットやレコードのデコード結果を対象にすることもできます。

方法

  1. [デコード結果]領域または[ダンプ]領域にフォーカスを移します。
  2. メインウィンドウの[編集(E)]メニューから[検索(F)]を選ぶか、<Ctrl-F>キーを押します。
  3. すべてのパケットまたはレコードを対象に検索する場合は、[パケット/レコードを越えて検索(W)]チェックボックスまたは[セッションを越えて検索(W)]チェックボックスにチェックを付けます。
  4. 文字列を入力し、[次を検索(F)]ボタンをクリックします。

注

  • [デコード結果]領域では正規表現を使って検索できます。[正規表現(E)]チェックボックスにチェックを付けて、[検索する文字列(N)]に正規表現を入力します。
  • [ダンプ]領域は縦線で3つの部分に分かれています。一番左にはパケットの先頭を0とするアドレスが表示されています。ここは検索の対象になりません。
  • [ダンプ]領域では中央の部分と右側の部分を検索の対象として、16進表示または文字列で検索できます。
    キャラクタとして表示できないデータを検索するときには、[ダンプ]領域でデータの16進表示を入力して検索します。 例えば、“Keep”という文字列を探す場合、“Keep”、“4b656570”、または“4b 65 65 70”と入力して検索できます。


 4.4.10 デコードしたデータの統計情報をグラフや表で表示する

デコードしたデータについて統計処理を行い、グラフや表で表示することができます。

方法1

  1. デコードビューのツールバーの[統計情報の表示]ボタン( [image])をクリックします。
  2. モニタ情報の種類を選びます。

方法2

  1. デコードビューのウィンドウを右クリックします。
  2. [統計情報の表示(G)]を選びます。
  3. モニタ情報の種類を選びます。

注

  • [MAC層エラーフレーム数]と[TCPステータス情報]のウィンドウは開けません。
  • 折れ線グラフ表示のウィンドウで、ツールバーの[グラフ解析機能]ボタン( [image])をクリックし、マウスをドラッグして範囲を指定すると、指定した範囲に対応する[サマリ]領域の行が、赤紫色でハイライト表示されます。
    [フレームID]または[ストリームID]カラムの見出しをクリックし[赤紫色の行にチェックをつける(E)]を選ぶと、ハイライト表示された行にチェックがつきます。選ぶときに、<Shift>キーを押しながら選ぶと、ハイライト表示された行だけを表示するようになります。
  • デコードビューから作成したトラフィックウィンドウでは、折れ線グラフのプロット間隔を変更できます。ウィンドウを右クリックし、[プロット間隔(L)...]を選びます。


 4.4.11 データをキャプチャしたときのネットワーク使用率を調べる

キャプチャデータのMAC層トラフィックの統計情報を表示し、データの単位として使用率を選ぶと、データをキャプチャしたときのネットワークの使用率がわかります。

使用率を表示するにはリンクスピードを入力する必要があります。 デフォルトのリンクスピードが設定されていない場合には、[リンクスピードの設定]ダイアログが現れます。

方法1

  1. デコードビューのウィンドウを右クリックします。
  2. [統計情報の表示(G)]を選びます。
  3. [1 MAC層トラフィック]を選びます。
  4. ウィンドウを右クリックします。
  5. [データの単位(U)]を選びます。
  6. [使用率(U)]を選びます。
  7. リンクスピードがわからない場合は[リンクスピードの設定]ダイアログが現れます。 リンクスピードを入力します。

方法2

  1. デコードビューのツールバーの[統計情報の表示]ボタン( [image])をクリックします。
  2. [1 MAC層トラフィック]を選びます。
  3. ウィンドウを右クリックします。
  4. [データの単位(U)]を選びます。
  5. [使用率(U)]を選びます。
  6. リンクスピードがわからない場合は[リンクスピードの設定]ダイアログが現れます。 リンクスピードを入力します。

リンクスピードを入力する

デフォルトのリンクスピードを指定しておくと、キャプチャファイルからネットワークの使用率のグラフを表示するときに、デフォルトのリンクスピードを使って計算します。

方法1

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[デコード]をクリックします。
  3. [デフォルトのリンクスピード(L)]のフィールドに、リンクスピードを入力します。

方法2

  1. デコードビューから表示した統計情報のウィンドウを右クリックします。
  2. [プロパティ(O)...]を選びます。
  3. [情報]タブをクリックします。
  4. [リンクスピード]にリンクスピードを入力します。

注

  • リンクスピードが判明している場合は、[リンクスピードの設定]ダイアログは現れません。
    • [グラフのプロパティ]ダイアログでリンクスピードを設定をしてある場合や、
    • リンクスピードの情報を得られるNICでキャプチャしたキャプチャバッファのデータである場合など
  • [リンクスピードの設定]ダイアログの[デフォルトに設定する(D)]にチェックをつけると、指定したリンクスピードがデフォルトのリンクスピードとして設定されます。
  • フィルタを適用してキャプチャしたデータから、正しいネットワーク使用率を求めることはできません。


 4.4.12 IPアドレスの代わりにホスト名を表示する

パケットのデータをデコードした結果得られたIPアドレスをホスト名で表示できます。ホスト名の検索に利用できるネームサービスは、DNS、WINS(NetBIOS)、NISの3つです。

方法

  1. デコードビューまたはストリームビューの[サマリ]領域で、アドレスのカラムにIPアドレスが含まれる行を右クリックします。
  2. [ホスト名の検索(H)]を選びます。
  3. [DNS(D)]、[NetBIOS(B)]、[NIS(ドメイン名)(N)]のいずれかを選びます。

注

  • あらかじめNISのドメイン名を指定しておかないと、[NIS(ドメイン名)(N)]は選べません。


 4.4.13 新たに見つかったホスト名を表示する

デコードビュー、ストリームビューを表示した後にホスト名を検索したり、ホスト名の表示の優先順位を変更した場合には、デコードビューやストリームビューに表示するホスト名を最新のものに更新できます。

方法1

デコードビューまたはストリームビューのツールバーの[ホスト名の更新]ボタン( [image])をクリックします。

方法2

  1. デコードビューまたはストリームビューのウィンドウを右クリックします。
  2. [ホスト名の更新(U)]を選びます。


 4.5.1 簡易フィルタ

簡易フィルタは、リアルタイムデコードビューやデコードビュー、ストリームビューでGUIの操作だけで手軽にパケットやレコードを絞り込むことができるフィルタです。あらかじめ論理式を設定しておく必要はありません。

簡易フィルタには次の3種類があります。

  • 見出しフィルタ
  • ヘッダー属性フィルタ
  • デコード結果フィルタ


 4.5.2 見出しフィルタ(簡易フィルタ)

見出しフィルタは簡易フィルタの一つで、リアルタイムデコードビューの[シーケンス]領域、またはデコードビューやストリームビューの[サマリ]領域の各カラムの内容で表示するパケットを絞り込むことができます。

見出しフィルタを適用すると、デコードビューのフレームIDまたはストリームビューのストリームIDの文字の色が青に変わります。


 4.5.2.1 特定の値と一致するパケットまたはレコードを表示する

方法

  1. リアルタイムデコードビューまたは、デコードビューやストリームビューの[サマリ]領域で、▼マークのついたカラムの見出しをクリックします。
  2. 絞り込みたい値に対応するメニュー項目を選びます。


 4.5.2.2 複数の値のいずれかと一致するパケットまたはレコードを表示する

方法

  1. デコードビューまたはストリームビューの[サマリ]領域で、▼マークの付いたカラムの見出しをクリックします。
  2. [オプション(P)...]を選びます。
  3. [複数選択(M)]を選びます。
  4. 表示させたい内容をリストから選びます。
    このとき、文字列を入力し、[検索(F)]ボタンをクリックすると、リスト内の文字列を検索できます。


 4.5.2.3 指定した範囲内の値を持つパケットまたはレコードを表示する

次のカラムにおいて、指定した範囲の値を持つパケットまたはレコードのみを表示します。

  • フレームID
  • ストリームID
  • 長さ
  • 発信元ポート番号
  • 受信先ポート番号
  • ポート1
  • ポート2
方法
  1. カラムの見出しをクリックします。
  2. [オプション(P)...]を選びます。
  3. [範囲指定(R)]を選び、範囲を入力します。


 4.5.2.4 指定した文字列を含むパケットまたはレコードを表示する

  次のカラムにおいて、指定した文字列を含むパケットまたはレコードのみを表示します。

  • 発信元アドレス
  • 受信先アドレス
  • プロトコル
  • サマリ
  • アドレス1
  • アドレス2
  • アドレス<=>アドレス… (ストリームビューのシーケンスモード)

方法

  1. デコードビューまたはストリームビューの[サマリ]領域で、カラムの見出しをクリックします。
  2. [オプション(P)...]を選びます。
  3. [部分一致(P)]を選び、文字列を入力します。


 4.5.2.5 メニュー項目が多いときに目的の値を見つける

カラムの値の種類が多すぎて、カラムの見出しをクリックすると現れるメニューに、目的の値に対応するメニュー項目が表示されないことがあります。このような場合は候補リストダイアログを使います。

方法

  1. デコードビューまたはストリームビューの[サマリ]領域で、▼マークの付いたカラムの見出しをクリックします。
  2. [候補リスト(T)...]を選びます。
  3. リストから目的の値を選びます。
    このとき、文字列を入力し、[検索(F)]ボタンをクリックすると、リスト内の文字列を検索できます。

注

  • メニュー項目が16個以下のときは[候補リスト(T)...]は現れません。


 4.5.2.6 見出しフィルタを解除する

1つの見出しフィルタを解除する
この操作は、指定した見出しフィルタのみを解除し、他の見出しフィルタや簡易フィルタは残ります。

方法

  1. デコードビューまたはストリームビューの[サマリ]領域で、▼マークの付いたカラムの見出しをクリックします。
  2. [すべて(L)]を選びます。

すべての簡易フィルタを解除する
この操作は、デコードビューまたはストリームビューのすべての簡易フィルタを解除します。

方法1

デコードビューまたはストリームビューのツールバーの[フィルタ解除]ボタン( [image])をクリックします。

方法2

デコードビューを右クリックし、[フィルタ(F)]の[フィルタ解除(R)]を選びます。

方法3

ストリームビューを右クリックし、[フィルタ解除(R)]を選びます。


 4.5.3 ヘッダー属性フィルタ(簡易フィルタ)

ヘッダー属性フィルタは簡易フィルタの一つで、パケットヘッダーのフィールドの値を基に表示するパケットを絞り込むフィルタです。

ヘッダー属性フィルタは、デコードビューでのみ使えます。ヘッダー属性フィルタを適用すると、デコードビューのフレームIDの文字の色が青に変わります。


 4.5.3.1 特定のヘッダー属性と一致するパケットを表示する

方法1

  1. デコードビューのツールバーの[ヘッダー属性フィルタ]ボタン( [image])をクリックします。
  2. ヘッダー属性に対応するメニュー項目を選びます。
  3. 目的の値に対応するメニュー項目を選びます。

方法2

  1. デコードビューのウィンドウを右クリックします。
  2. [フィルタ(F)]を選びます。
  3. [ヘッダー属性フィルタ(A)]を選びます。
  4. ヘッダー属性に対応するメニュー項目を選びます。
  5. 目的の値に対応するメニュー項目を選びます。


 4.5.3.2 複数のヘッダー属性のいずれかと一致するパケットを表示する

方法1

  1. デコードビューのツールバーの[ヘッダー属性フィルタ]ボタン( [image])をクリックします。
  2. ヘッダー属性に対応するメニュー項目を選びます。
  3. [オプション(P)...]を選びます。
  4. [複数選択(M)]を選びます。
  5. リストから目的の値を選びます。
    このとき、文字列を入力し、[検索(F)]ボタンをクリックすると、リスト内の文字列を検索できます。

方法2

  1. デコードビューのウィンドウを右クリックします。
  2. [フィルタ(F)]を選びます。
  3. [ヘッダー属性フィルタ(A)]を選びます。
  4. ヘッダー属性に対応するメニュー項目を選びます。
  5. [オプション(P)...]を選びます。
  6. [複数選択(M)]を選びます。
  7. リストから目的の値を選びます。
    このとき、文字列を入力し、[検索(F)]ボタンをクリックすると、リスト内の文字列を検索できます。


 4.5.3.3 指定した文字列がヘッダー属性に含まれるパケットを表示する

方法1

  1. デコードビューのツールバーの[ヘッダー属性フィルタ]ボタン( [image])をクリックします。
  2. ヘッダー属性に対応するメニュー項目を選びます。
  3. [オプション(P)...]を選びます。
  4. [部分一致(P)]を選び、文字列を入力します。

方法2

  1. デコードビューのウィンドウを右クリックします。
  2. [フィルタ(F)]を選びます。
  3. [ヘッダー属性フィルタ(A)]を選びます。
  4. ヘッダー属性に対応するメニュー項目を選びます。
  5. [オプション(P)...]を選びます。
  6. [部分一致(P)]を選び、文字列を入力します。


 4.5.3.4 メニュー項目が多いときに目的の値を見つける

ヘッダー属性の値の種類が多すぎて、目的の値に対応するメニュー項目が表示されないことがあります。このような場合には候補リストダイアログを使います。

方法1

  1. デコードビューのツールバーの[ヘッダー属性フィルタ]ボタン( [image])をクリックします。
  2. ヘッダー属性に対応するメニュー項目を選びます。
  3. [候補リスト(T)...]を選びます。
  4. リストから目的の値を選びます。
    このとき、文字列を入力し、[検索(F)]ボタンをクリックすると、リスト内の文字列を検索できます。

方法2

  1. デコードビューのウィンドウを右クリックします。
  2. [フィルタ(F)]を選びます。
  3. [ヘッダー属性フィルタ(A)]を選びます。
  4. ヘッダー属性に対応するメニュー項目を選びます。
  5. [候補リスト(T)...]を選びます。
  6. リストから目的の値を選びます。
    このとき、文字列を入力し、[検索(F)]ボタンをクリックすると、リスト内の文字列を検索できます。

注

  • メニュー項目が16個以下のときは[候補リスト(T)...]は現れません。


 4.5.3.5 ヘッダー属性フィルタを解除する

1つのヘッダー属性フィルタを解除する
この操作は、指定したヘッダー属性フィルタのみを解除し、他のヘッダー属性フィルタや簡易フィルタは残ります。

方法1

  1. デコードビューのツールバーの[ヘッダー属性フィルタ]ボタン( [image])をクリックします。
  2. ヘッダー属性に対応したメニュー項目を選びます。
  3. [すべて(L)]を選びます。

方法2

  1. デコードビューのウィンドウを右クリックします。
  2. [フィルタ(F)]を選びます。
  3. [ヘッダー属性フィルタ(A)]を選びます。
  4. ヘッダー属性に対応したメニュー項目を選びます。
  5. [すべて(L)]を選びます。

すべての簡易フィルタを解除する
この操作は、デコードビューまたはストリームビューのすべての簡易フィルタを解除します。

方法1

デコードビューのツールバーの[フィルタ解除]ボタン( [image])をクリックします。

方法2

デコードビューを右クリックし、[フィルタ(F)]の[フィルタ解除(R)]を選びます。


 4.5.3.6 2つのホスト間で送受信したパケットを表示する

ヘッダー属性フィルタを利用すると、2つのホスト間でやり取りされたパケットだけを表示することができます。

方法1

  1. デコードビューのツールバーの[ヘッダー属性フィルタ]ボタン( [image])をクリックします。
  2. [3 MAC層ホストペア]または[7 IP層ホストペア]を選びます。
  3. 表示したいホストの組み合わせに対応するメニュー項目を選びます。

方法2

  1. デコードビューのウィンドウを右クリックします。
  2. [フィルタ(F)]を選びます。
  3. [ヘッダー属性フィルタ(A)]を選びます。
  4. [3 MAC層ホストペア]または[7 IP層ホストペア]を選びます。
  5. 表示したいホストの組み合わせに対応するメニュー項目を選びます。


 4.5.3.7 TCP上の特定のプロトコルに関連したパケットをすべて表示する

TCP上のアプリケーションが通信する場合、次の順番で処理が進みます。

  1. TCPの接続を確立する
  2. アプリケーションのデータを送受信する
  3. TCPの接続を切断する
アプリケーションのデータを送受信するパケットの場合、デコードビューの[サマリ]領域のプロトコルカラムには、アプリケーションのプロトコル名が表示されます。一方、TCPの接続の確立と切断のパケットについては、プロトコル名としてTCPと表示されます。
ヘッダー属性フィルタを使えば、これらの2種類のパケットの両方を表示することができます。

方法1

  1. デコードビューのツールバーの[ヘッダー属性フィルタ]ボタン( [image])をクリックします。
  2. [8 IP層プロトコル]を選びます。
  3. 表示したいアプリケーションプロトコルに対応するメニュー項目を選びます。

方法2

  1. デコードビューのウィンドウを右クリックします。
  2. [フィルタ(F)]を選びます。
  3. [ヘッダー属性フィルタ(A)]を選びます。
  4. [8 IP層プロトコル]を選びます。
  5. 表示したいアプリケーションプロトコルに対応するメニュー項目を選びます。


 4.5.4 デコード結果フィルタ(簡易フィルタ)

デコード結果フィルタは、簡易フィルタの一つです。デコードビューまたはストリームビューの[デコード結果]領域の文字列や値を利用してパケットやレコードを絞り込みます。

デコード結果フィルタは、デコードビューおよびシーケンスモードでないストリームビューでのみ使えます。


 4.5.4.1 指定した文字列を含むパケットまたはレコードを表示する

[デコード結果]領域に特定の文字列を含むパケットやレコードのみを表示できます。

方法1

  1. デコードビューまたはストリームビューのツールバーの[デコード結果フィルタ]ボタン( [image])をクリックします。
  2. [含まれる文字列(K)]を選びます。
  3. ドロップダウンコンボボックスに文字列を入力し、[OK]ボタンをクリックします。

方法2

  1. デコードビューまたはストリームビューのウィンドウを右クリックします。
  2. [フィルタ(F)]を選びます。
  3. [デコード結果フィルタ(F)...]を選びます。
  4. [含まれる文字列(K)]を選びます。
  5. ドロップダウンコンボボックスに文字列を入力し、[OK]ボタンをクリックします。

注

  • [プロトコルを指定する(P)]チェックボックスにチェックを付け、[選択(S)...]ボタンをクリックすると、[候補リスト(複数選択)]ダイアログが現れます。ここでプロトコルを選ぶと、選んだプロトコルのデコード結果だけが対象になります。
  • デコード結果によってはフィルタの適用に時間がかかることがあります。フィルタの適用を途中で止めるときは、[ASTEC Eyes]ダイアログの[キャンセル]ボタンをクリックします。


 4.5.4.2 フィールドの値が特定の値と一致するパケットまたはレコードを表示する

[デコード結果]領域の特定のフィールドに特定の値を含むパケットまたはレコードのみを表示することができます。

方法1

  1. デコードビューまたはストリームビューのツールバーの[デコード結果フィルタ]ボタン( [image])をクリックします。
  2. [場所を指定する(L)]を選びます。
  3. [フィールド名(F)]と[値(V)]を入力し、[OK]ボタンをクリックします。

方法2

  1. デコードビューまたはストリームビューのウィンドウを右クリックします。
  2. [フィルタ(F)]を選びます。
  3. [デコード結果フィルタ(F)...]を選びます。
  4. [場所を指定する(L)]を選びます。
  5. [フィールド名(F)]と[値(V)]を入力し、[OK]ボタンをクリックします。

注

  • [プロトコルを指定する(P)]チェックボックスにチェックを付け、[選択(S)...]ボタンをクリックすると、[候補リスト(複数選択)]ダイアログが現れます。ここでプロトコルを選ぶと、選んだプロトコルのデコード結果だけが対象になります。
  • デコード結果によってはフィルタの適用に時間がかかることがあります。フィルタの適用を途中で止めるときは、[ASTEC Eyes]ダイアログの[キャンセル]ボタンをクリックします。


 4.5.4.3 デコード結果フィルタを解除する

デコード結果フィルタだけを解除する
この操作では、デコード結果フィルタだけが解除され、他の簡易フィルタは残ります。

方法1

  1. デコードビューまたはストリームビューのツールバーの[デコード結果フィルタ]ボタン( [image])をクリックします。
  2. [解除(R)]ボタンをクリックします。

方法2

  1. デコードビューまたはストリームビューのウィンドウを右クリックします。
  2. [フィルタ(F)]を選びます。
  3. [デコード結果フィルタ(F)...]を選びます。
  4. [解除(R)]ボタンをクリックします。

すべての簡易フィルタを解除する
この操作では、選択中のデコードビューまたはストリームビューのすべての簡易フィルタが解除されます。

方法1

  1. デコードビューまたはストリームビューのツールバーの[フィルタ解除]ボタン( [image])をクリックします。

方法2

  1. デコードビューまたはストリームビューのウィンドウを右クリックします。
  2. [フィルタ解除(R)]を選びます。


 4.5.5 簡易フィルタを組み合わせて使う

簡易フィルタはデコードビューまたはストリームビューに現在表示されているパケットを対象にフィルタをかけます。そのため、複数のフィルタをかけると、複数条件に当てはまるパケットのみが表示されます。つまり、複数の条件の論理積でフィルタを適用できます。

複数の条件の論理和のフィルタをかける直接的な方法はありませんが、デコードビューの[フレームID]カラムまたはストリームビューの[ストリームID]カラムのチェックボックスを使うことで実現できます。

方法

  1. 1つ目のフィルタ をかけます。
  2. [フレームID]カラムまたは[ストリームID]カラムの見出しをクリックします。
  3. [表示行にチェックをつける(S)]を選びます。
  4. ツールバーの[フィルタ解除]ボタン( [image])をクリックします。
  5. 2つ目のフィルタをかけます。
  6. [フレームID]カラムまたは[ストリームID]カラムの見出しをクリックします。
  7. [表示行にチェックをつける(S)]を選びます。
  8. ツールバーの[フィルタ解除]ボタン( [image])をクリックします。
  9. [フレームID]カラムまたは[ストリームID]カラムの見出しをクリックします。
  10. （チェックマーク）を選びます。


 4.5.6 ディスプレイフィルタ

簡易フィルタでは指定できない複雑な条件を設定してパケットを絞り込むためのフィルタです。ディスプレイフィルタを設定するには、フィルタエディタを使います。

ディスプレイフィルタは、デコードビューでのみ使えます。


 4.5.6.1 特定の条件を満たすパケットを表示する

ディスプレイフィルタを適用するには、まずフィルタエディタでディスプレイフィルタを作ります。次に作ったディスプレイフィルタをデコードビューに適用します。

ディスプレイフィルタを適用する方法

方法1

  1. デコードビューのツールバーの[ディスプレイフィルタ]ボタン( [image])をクリックします。
  2. 適用したいフィルタ名に対応するメニュー項目を選びます。

方法2

  1. デコードビューのウィンドウを右クリックします。
  2. [フィルタ(F)]を選びます。
  3. [ディスプレイフィルタ(D)]を選びます。
  4. 適用したいフィルタ名に対応するメニュー項目を選びます。

注

  • ディスプレイフィルタを適用した結果は新しいデコードビューに表示されます。
  • ディスプレイフィルタを適用して現れたデコードビューのフレームIDの色は緑色です。
  • ストリームビューにはディスプレイフィルタを適用できません。ディスプレイフィルタを適用したデコードビューからストリームビューを作ります。


 4.5.6.2 パケットの情報からディスプレイフィルタを作る

ドラッグアンドドロップ操作やポップアップメニューを利用して、特定のパケットの

  • コネクション
  • ホストペア
  • プロトコル
  • フレームID
  • 日付
を表す論理式を作成し、フィルタエディタに設定できます。

方法1

  1. デコードビューのパケットを右クリックします。
  2. [フィルタ(F)]を選びます。
  3. [フィルタの生成(I)]を選びます。
  4. [フィルタエディタに送る(F)]を選びます。
  5. 適用したい条件に対応するメニュー項目を選びます。
  6. フィルタエディタの[適用(A)]ボタンをクリックします。
方法2
  1. フィルタエディタを開きます。
  2. デコードビューのパケットをドラッグし、フィルタエディタの[ [image] ディスプレイフィルタ]にドロップします。
  3. フィルタエディタの[適用(A)]ボタンをクリックします。


 4.5.6.3 一時的なディスプレイフィルタを使ってパケットを表示する

ドラッグアンドドロップ操作やポップアップメニューを利用して、特定のパケットの

  • コネクション
  • ホストペア
  • プロトコル
  • フレームID
  • 日付
を条件とするディスプレイフィルタを一時的に作成し、デコードビューに適用できます。

方法

  1. デコードビューのパケットを右クリックします。
  2. [フィルタ(F)]を選びます。
  3. [フィルタの生成(I)]を選びます。
  4. [一時的に生成して適用する(I)]を選びます。
  5. 適用したい条件に対応するメニュー項目を選びます。

注

  • この操作で作成した論理式はフィルタエディタには設定されません。


 4.6.1 [サマリ]領域や[シーケンス]領域のカラムを並べ替える

デコードビューやストリームビューの[サマリ]領域や[シーケンス]領域のカラムの順序を変更できます。 また、 [サマリ]領域のカラムの順序を初期状態に戻すことができます。

カラムを並び替える

方法1

  1. [サマリ]領域や[シーケンス]領域のカラムの見出しを左右にドラッグします。
  2. 移動先にドロップします。

方法2

  1. [サマリ]領域のカラムの見出しを右クリックします。
  2. [カラムの設定...]を選びます。
  3. リストの中のカラムに対応する項目をクリックします。
  4. [上へ(U)]ボタンや[下へ(D)]ボタンをクリックしてリスト中の位置を変更します。

注

  • カラムの見出しをドラッグすると、移動先のカラムの見出しの区切りが青に変わります。カラムをドロップすると、青い区切りの位置に挿入されます。
  • カラムの見出しをドラッグするときは、マウスカーソルをカラムの見出しの中心あたりに合わせるようにします。カラムの端のほうに合わせると、マウスカーソルがカラムの幅を変える操作のためのカーソルに変わります。

カラムの順序を初期状態に戻す

方法

  1. [サマリ]領域のカラムの見出しを右クリックします。
  2. [カラムの設定...]を選びます。
  3. [デフォルトに戻す(F)]ボタンをクリックします。
    この操作は、カラムの表示、非表示の設定やカラムの幅も初期状態に戻します。

注

  • カラムの幅が0ピクセルだったり、デコードビューやストリームビューのウィンドウ幅よりも大きいなど、カラムの端にマウスカーソルをあわせるのが難しいときには、[カラムの設定]ダイアログの[選択したカラムの幅(W)]を指定することによってカラムの幅を変更できます。


 4.6.2 [サマリ]領域のカラムの表示、非表示を切り替える

方法1

  1. [サマリ]領域のカラムの見出しを右クリックします。
  2. カラムに対応するメニュー項目を選びます。

方法2

  1. [サマリ]領域のカラムの見出しを右クリックします。
  2. [カラムの設定...]を選びます。
  3. カラムに対応するチェックボックスをクリックします。

注

  • フレームIDとストリームIDのカラムは非表示にできません。


 4.6.3 ツールバーの表示、非表示を切り替える

方法

  1. デコードビューまたはストリームビューのウィンドウを右クリックします。
  2. [ツールバーの表示(T)]を選びます。


 4.7.1 Well knownポートを使っていないプロトコルを正しくデコードする

ASTEC Eyesは、TCPまたはUDPのポート番号を使ってアプリケーション層のプロトコルを判別しています。 このため、プロキシサーバーの設定によってWell knownポートとは異なるポートを使っているプロトコルや、Well knownポートを持たないプロトコルは正しくデコードできません。
このような場合、デコードヒントを設定します。

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[デコードヒント]をクリックします。
  3. デコードヒントを設定します。

注

  • 誤ったデコードヒントを設定した場合、デコード時にエラーが発生することがあります。
  • すでに表示されているデコードビューまたはストリームビューにデコードヒントの設定を反映させるには、再デコードします。


 4.7.2 ASTEC Eyesが対応していないプロトコルを区別する

ASTEC Eyesが対応していないアプリケーション層のプロトコルをデコードヒントに設定しておけば、誤ったプロトコルとして解釈されないようにできます。

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[デコードヒント]をクリックします。
  3. IPアドレス、トランスポート層、およびポート番号を指定し、プロトコル名のカラムに任意の文字列を入力します。

注

  • デコードビューの該当するパケットの表示は次のようになります。
    • [サマリ]領域のプロトコルカラムには、デコードヒントで設定したプロトコル名が表示されます。
    • [サマリ]領域のサマリカラムには、“Maybe a packet of プロトコル名 protocol”と表示されます。
    • [デコード結果]領域のアプリケーション層のフィールドには、“Unknown Data”と表示されます。
  • ストリームビューの該当するストリームの表示は次のようになります。
    • [サマリ]領域のプロトコルカラムには、デコードヒントで設定したプロトコル名が表示されます。
    • [サマリ]領域のサマリカラムには、“Maybe a record of プロトコル名 protocol”と表示されます。
    • [デコード結果]領域には、“Unknown Data”と表示されます。


 4.7.3 チェックサムの値を検査する

ASTEC Eyesは、デコード時にIPv4、UDP、TCPのチェックサムの値を検査することができます。 検査の結果チェックサムが誤っている場合には、そのパケットのデコードを中止します。

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[デコード]をクリックします。
  3. [チェックサムの値を検査する(C)]チェックボックスにチェックを付けます。

注

  • チェックサムオフロード機能を持つNIC(ネットワークインタフェースカード)を使っている場合は、チェックサムの値の検査は行わない方がよいでしょう。
  • チェックサムを検証しないように設定しても、すでに表示されているデコードビューには反映されません。反映させるには、再デコードする必要があります。


 4.7.4 再デコードする

次のオプションの変更や追加をデコードビューやストリームビューに反映させるには、再デコードが必要です。

  • デコードヒントの追加、削除、および変更
  • デコード時にチェックサムの値の検査を行うかどうか
  • ストリームビュー のレコードの並び順(時系列またはストリームID順)の変更

方法1

  1. デコードビューまたはストリームビューのツールバーの[再デコード]ボタン( [image] 、 [image])をクリックします。
方法2
  1. デコードビューまたはストリームビューのウィンドウを右クリックします。
  2. [再デコード(Q)]を選びます。


 4.7.5 日本語のエンコードを指定して再デコードする

日本語を含むデータについて、エンコードを指定して再デコードすることができます。

特定のパケットまたはレコードのエンコードを変える

  1. デコードビュー またはストリームビューを右クリックします。
  2. [日本語エンコード(C)]を選びます。
  3. エンコードを選びます。
    • JIS
    • EUC
    • SJIS
    • Unicode(UCS-2とUTF-8)
表示されているデータのエンコードを変える

選んでいるパケットまたはレコードだけでなく、表示されている全データのエンコードを一度に変えられます。

  1. デコードビュー またはストリームビューを右クリックします。
  2. [日本語エンコード(C)]を選びます。
  3. [表示行を全て変更]を選びます。
  4. エンコードを選びます。
    • JIS
    • EUC
    • SJIS
    • Unicode(UCS-2とUTF-8)

注

  • 特定のパケットまたはレコードのエンコードを変えたいとき、デコードビューやストリームビューのどこをクリックしてもポップアップメニューは現れますが、[サマリ]領域をクリックするときには注意が必要です。右クリックした行が選ばれるので、エンコードを変えたい行をクリックするようにします。
  • フィルタの適用などにより、表示されていないパケットやレコードのエンコードは変わりません。
  • プロトコルとしてエンコードが固定されている場合は、エンコードは変えられません。この操作を行ってもデコード結果に影響を与えられません。


 4.7.6 デコード時にエラーが発生したら

間違ったデコードヒントを設定したり、誤りを含むデータをデコードした場合など、エラーが発生し正しくデコードできないことがあります。このような場合、次のような表示になります。

  • デコードビューの正しくデコードできなかったパケットのフレームIDのチェックボックスが赤色になる
  • メッセージウィンドウに、デコードできなかったフレームIDまたはストリームIDとプロトコル名を含むメッセージが表示される
  エラーが発生した場合には、必要なデータを保存してASTEC Eyesを一旦終了されることをおすすめします。
  また、デコードヒントを正しく設定しているにもかかわらず、エラーが起きた場合は、サポートまでご連絡ください。


 5 トラフィックジェネレータ機能

作成したパケットやキャプチャしたパケットを送信する機能です。


 5.1.1 パケットの作成と送信

  1. パケット送信ウィンドウを開きます。
  2. パケットを追加します。
  3. [追加(A)...]メニューをクリックします。
  4. パケットを編集します。
  5. [送信(S)...]ボタンをクリックします。
  6. [パケット送信]ダイアログからパケットを送信します。

パケット送信ウィンドウを開く

方法

メインウィンドウの[ツール(T)]の[パケット送信(M)...]を選びます。

パケットの追加

方法

  1. [追加(A)...]メニューをクリックします。
  2. 追加するパケットの種類を選びます。

パケットの編集

方法1

  1. 編集したいパケットをクリックします。
  2. [パケット]領域の編集したいデータをマウスでクリックします。
  3. データの値を16進数で入力します。

方法2

  1. [追加(A)...]メニューをクリックしたときにICMPパケットを選ぶと、 [パケット生成パラメータ]ダイアログが現れます。
  2. [データ]領域の[長さ(L)]を指定します。
  3. 編集したいデータをマウスでクリックします。
  4. データの値を16進数で入力します。


 5.1.2 ICMP パケットを作成する

パケット送信ウィンドウで[追加(A)...]メニューをクリックしたときに、 [2 ICMP Echo Request]を選ぶと、 ICMP Echoリクエストパケットを容易に作成できます。

方法

  1. [追加(A)...]メニューをクリックし、[2 ICMP Echo Request] を選びます。 [パケット生成パラメータ]ダイアログが現れます。
  2. [MACアドレス]領域の[発信元(S)]および[受信先(D)]に、それぞれ発信元のMACアドレスと受信先のMACアドレスを入力します。
  3. [IPアドレス]領域の[発信元(R)]および[受信先(E)]に、それぞれ発信元のIPアドレスと受信先のIPアドレスを入力します。
  4. ICMPのデータの長さ(ICMPヘッダの長さは除く)を[データ]領域の[長さ(L)]に入力します。
  5. [データ]領域のデータを編集します。
  6. [OK]ボタンをクリックします。
指定したアドレスおよびデータのICMPパケットがパケット送信ウィンドウに追加されます。


 5.2.1 キャプチャしたパケットを送信する

  1. 送信したいデータを表示しているデコードビューのツールバーの[パケット編集ウィンドウ]ボタン( [image])をクリックします。 パケット編集ウィンドウが現れます。
  2. パケットを編集します。
  3. ツールバーの[パケット送信]ボタン( [image])をクリックします。
  4. [パケット送信]ダイアログからパケットを送信します。

パケットの編集

方法

  1. [サマリ]領域の編集したいパケットをマウスでクリックします。
  2. [ダンプ]領域の編集したいデータをマウスでクリックします。
  3. データの値を16進数で入力します。

パケットの送信

方法

  1. 必要ならパケットの送信方法をカスタマイズします。
  2. [適用(A)]ボタンをクリックします。
  3. [送信開始(B)]ボタンをクリックします。

注

  • パケットを編集すると、[サマリ]領域の[フレームID]カラムに*マークが表示されます。
  • 編集した内容の解析結果を[デコード結果]領域に反映させるには、ツールバーの[再デコード]ボタン( [image])をクリックします。
  • ケットの送信方法を変更しない場合でも、[適用(A)]ボタンをクリックする必要があります。


 5.2.2 パケットの編集結果の取り消しとやり直し

パケット編集ウィンドウ上で行った変更を取り消したり、いったん取り消した変更をもう一度反映させることができます。

変更の取り消し

パケット編集ウィンドウのツールバーの[元に戻す]ボタン( [image])をクリックします。

変更のやり直し

パケット編集ウィンドウのツールバーの[やり直し]ボタン( [image])をクリックします。

注

  • [元に戻す]ボタン( [image])を連続してクリックすると、複数回に渡る変更を遡って順に取り消すことができます。
  • [やり直し]ボタン( [image])を連続してクリックすると、複数回に渡る取り消しを、順に再度反映させることができます。


 5.2.3 フィルタを使う

パケット編集ウィンドウでは簡易フィルタを使って、GUIの操作だけで手軽にパケットを絞り込むことができます。

簡易フィルタには次の3種類があります。

  • 見出しフィルタ
  • ヘッダー属性フィルタ
  • デコード結果フィルタ


 5.2.4 アドレスを一括変更する

送信パケットに含まれるMACヘッダやIPヘッダのアドレスが、

  • 送信元のコンピュータのMACアドレスやIPアドレス
  • 送信先のコンピュータのMACアドレスやIPアドレス
  • 送信経路のネットワークのIPアドレス
などと矛盾しているとパケットは意図どおり配送されません。 複数の送信パケットのアドレスをまとめて変更することができます。

方法

  1. パケット編集ウィンドウのツールバーの[パケット編集ツール]ボタン( [image])をクリックします。
  2. [アドレス]ページを開き、変更対象のパケットの範囲やアドレスの種類、変更後のアドレスを指定します。


 5.2.5 パケットの内容を一括変更する

複数の送信パケットに含まれるデータをまとめて変更できます。

方法

  1. パケット編集ウィンドウのツールバーの[パケット編集ツール]ボタン( [image])をクリックします。
  2. [置換]ページや[フィールド]ページを開き、データの置換方法を指定します。


 5.3 パケットの送信

方法

  1. [パケット送信]ダイアログを開く。
  2. [設定]領域のパラメータを指定する。
  3. [適用(A)]ボタンをクリックする。
  4. [送信開始(B)]ボタンをクリックする。
[パケット送信]ダイアログの開き方

方法

[パケット送信]ダイアログの[送信(S)...]ボタンをクリックします。

方法

パケット編集ウィンドウのツールバーの[送信(S)...]ボタンをクリックします。

注

  • パケットの送信状況は、[送信状況]領域に表示されます。


 5.3.1 送信を停止する

方法

[パケット送信]ダイアログの[送信停止(I)]ボタンをクリックします。

注

  • パケットの送信や停止の状況は、[送信状況]領域に表示されます。


 5.3.2 送信方法をカスタマイズする

パケットを送信するときに、[パケット送信]ダイアログでチェックサムを再計算したり、パケット毎の送信間隔や送信回数などを指定することができます。

チェックサムの再計算

パケットの内容を変更すると、新しい内容に合わせたチェックサムを設定する必要があります。

方法

[パケット送信]ダイアログの[再計算]ボタンをクリックします。

パケット毎の送信間隔の指定

方法

  1. [送信間隔]の[変更する]チェックボックスにチェックを付けます。
  2. 時間間隔の単位(ミリ秒、または秒)を選びます。
  3. 時間間隔を入力します。

注

  • 送信間隔を0ミリ秒または0秒にすると、 可能な限り短い時間間隔でパケットを送信します。

送信回数の指定

パケットの繰り返し送信回数を指定します。

方法

  1. [送信回数]を入力します。

注

  • チェックサムの再計算は、IPヘッダ、TCPヘッダ、UDPヘッダ、ICMPヘッダに含まれるチェックサムに対して行います。
  • キャプチャしたデータの場合、送信間隔を指定しなければ、個々のパケットをキャプチャしたときの時間間隔に従って送信されます。


 6 アドレスとホスト情報の管理

モニタウィンドウやデコードビュー等に表示するIPアドレスやMACアドレスの代わりに、ホスト名を表示できます。ホスト名として、DNS、NetBIOS、NISから検索した結果を表示できるほか、ユーザーが定義した名前を使うこともできます。アドレスとホスト名の対応を確認したり管理する際に、アドレス帳を利用できます。


 6.1.1 ホストの識別に使うホスト名を選ぶ

モニタウィンドウ、デコードビュー、ストリームビューなどでホストを識別するために、IPアドレスやMACアドレスだけではなく、ネームサービスに登録されているホスト名やユーザー定義名も利用できます。

  • MACアドレスに対応するホスト名として使えるのは、デコード時に見つけたNetBIOS名とユーザー定義名の2つです。使うホスト名の種類は指定できます。
  • IPアドレスに対応するホスト名として使えるのは、DNS名、NetBIOS名、NIS名、およびユーザー定義名の4つです。あるIPアドレスに対して複数のネームサービスにホスト名が登録されている場合、どのホスト名を使うかの優先順位を指定できます。
  • あるアドレスについて、複数のユーザ定義名を指定できます。また、1つのネームサービスに複数のホスト名が登録されていることがあります。このような場合、アドレス帳でどのホスト名を使うのかを選べます。方法は「アドレス帳を使って表示するホスト名を選ぶ」を参照してください。

表示するホスト名と優先順位設定する

方法1

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[ホスト名]をクリックします。
  3. [表示する名前と優先順位(P)]領域 で表示するホスト名にチェックをつけます。
  4. 優先順位を上げたい（下げたい）ホスト名をクリックします。
  5. [上へ(H)]ボタン（[下へ(L)]ボタン）をクリックします。

方法2

  1. メインウィンドウの[ツール(T)]メニューから[ホスト名の検索(H)...]を選ぶか、<Ctrl-L>キーを押します。
  2. [表示の優先順位を設定(R)...]ボタンをクリックします。
  3. 表示したいホスト名にチェックをつけます。
  4. 優先順位を上げたい（下げたい）ホスト名をクリックします。
  5. [上へ(H)]ボタン（[下へ(L)]ボタン）をクリックします。

方法3

  1. メインウィンドウの[編集(E)]メニューから[MAC層アドレス帳の編集(M)]または[IP層アドレス帳の編集(I)]を選びます。
  2. アドレス帳のウィンドウを右クリックします。
  3. [表示の優先順位を設定(P)...]を選びます。
  4. 表示したいホスト名にチェックをつけます。
  5. 優先順位を上げたい（下げたい）ホスト名をクリックします。
  6. [上へ(H)]ボタン（[下へ(L)]ボタン）をクリックします。

注

  • ASTEC Eyes on the net バージョン 7.1では、IPv6アドレスの検索にWINS(NetBIOS名)を使うことはできません。


 6.1.2 NISのドメイン名とサーバーを指定する

方法1

  1. メインウィンドウの[ツール(T)]メニューの[ホスト名の検索(H)...]を選ぶか、<Ctrl-L>キーを押します。
  2. [NIS(N)]チェックボックスにチェックを付けます
  3. [NISドメイン名(I)]にNISのドメイン名を、[NISサーバーアドレス(S)]にNISサーバーのアドレスまたはホスト名を入力します。

方法2

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[ホスト名]をクリックします。
  3. [NISドメイン名(I)]にNISのドメイン名を、[NISサーバーアドレス(S)]にNISサーバーのアドレスまたはホスト名を入力します。


 6.1.3 アドレス帳を使って表示するホスト名を選ぶ

特定のネームサービスで1つのアドレスに対して複数の名前が登録されている場合や、複数のユーザー定義名をつけた場合に、どの名前を表示するかを選べます。

方法1

  1. メインウィンドウの[編集(E)]メニューから[MAC層アドレス帳の編集(M)]または[IP層アドレス帳の編集(I)]を選びます。
  2. 設定したいセルを2回クリックします。
  3. ドロップダウンリストボックスから名前を選びます。

方法2

  1. メインウィンドウの[編集(E)]メニューから[MAC層アドレス帳の編集(M)]または[IP層アドレス帳の編集(I)]を選びます。
  2. <↑>、<↓>、<←>、<→>キーで設定したいセルへ白い枠を移動します。
  3. <F2>キーを押します。
  4. <↑>または<↓>キーで名前を選び、<Enter>キーを押します。

注

  • 特定のネームサービスで1つのアドレスに対して複数の名前が登録されている場合や、複数のユーザ定義名を持つ場合、ホスト名またはユーザ定義名の右端に候補の数がカッコ付きで表示されます。また、ホスト名の一覧がツールチップで表示されます。


 6.1.4 ホスト名を検索する

モニタ中に見つかったIPアドレスや、キャプチャしたデータから得られたIPアドレスに対応するホスト名をまとめて検索できます。利用できるネームサービスはDNS、WINS(NetBIOS)、およびNISです。

方法

  1. メインウィンドウの[ツール(T)]メニューから[ホスト名の検索(H)...]を選ぶか、<Ctrl-L>キーを押します。
  2. 検索の対象とするIPアドレスの範囲と利用するネームサービスを指定します。
  3. [検索(F)]ボタンをクリックします。

注

  • NISを使うときは、NISのドメイン名を指定する必要があります。
  • ASTEC Eyes on the net バージョン 7.1では、IPv6アドレスの検索にWINS(NetBIOS名)を使うことはできません。


 6.2.1 Whoisを実行する

ASTEC EyesからWhois情報を検索できます。 Whois情報を検索するためには次の操作を行います。

  1. [Whois]ダイアログを開く
  2. Whoisサーバーなどを設定し、検索する

[Whois]ダイアログを開く

方法1 (ホスト名を指定して検索する)

メインウィンドウの[ツール(T)]メニューから[Whoisツール(W)...]を選びます。

方法2 (トラフィックウィンドウのホストを検索する)

  1. IP層のホストで分類したトラフィックを表示しているトラフィックウィンドウで、検索したいホストに対応するグラフアイテムまたは行をクリックします。
  2. ウィンドウを右クリックします。
  3. [ネットワークユーティリティ(N)]を選びます。
  4. [Whois(W)]を選びます。複数の項目が表示されたときには、検索したいホストやドメインを選びます。

方法3 (アドレス表やアドレス帳のホストを検索する)

  1. IPアドレス表、MACアドレス-IPアドレス対応表、IPアドレス帳のウィンドウで、検索したいホストの行を右クリックします。
  2. [ネットワークユーティリティ(N)]を選びます。
  3. [Whois(W)]を選びます。複数の項目が表示されたときには、検索したいホストやドメインを選びます。

方法4 (デコードビューやストリームビューのホストを検索する)

  1. IPアドレスを含むデコードビューのパケットまたはストリームビューのレコードを右クリックします。
  2. [ネットワークユーティリティ(N)]を選びます。
  3. [Whois(W)]を選びます。複数の項目が表示されたときには、検索したいホストやドメインを選びます。

Whoisサーバーなどを設定し、検索する

方法

  1. 検索キーを入力します。
    トラフィックウィンドウやデコードビューなどから[Whois]ダイアログを開いたときには、検索キーが設定されています。
  2. [Whoisサーバー(S)]ドロップダウンコンボボックスからWhoisサーバーを選びます。リストにないWhoisサーバーを使うときは、キー入力します。
  3. SOCKSサーバーを利用してWhoisサーバーに接続する場合は、[SOCKSを使用する(O)]チェックボックスにチェックを付けてSOCKSサーバーを選びます。
    リストにないSOCKSサーバーを使う場合には、[詳細設定(D)...]ボタンをクリックして    SOCKSサーバーの情報を設定します。
  4. [実行]ボタンをクリックします。
    [結果をメッセージウィンドウに出力する(M)]チェックボックスにチェックを付けると、検索結果を[実行結果(R)]領域に表示する代わりに、メインウィンドウのメッセージウィンドウに表示します。


 6.2.2 Pingを実行する

ASTEC Eyesからpingを実行できます。 pingを実行するためには次の操作を行います。

  1. [Ping]ダイアログを開く
  2. パラメータを指定してpingを実行する

[Ping]ダイアログを開く

方法1 (ホスト名を指定してpingを実行する)

メインウィンドウの[ツール(T)]メニューから[Pingツール(P)...]を選びます。

方法2 (トラフィックウィンドウのホストに対してpingを実行する)

  1. IP層ホストで分類したトラフィックを表示しているトラフィックウィンドウで、グラフアイテムを選びます。
  2. ウィンドウを右クリックします。
  3. [ネットワークユーティリティ(N)]を選びます。
  4. [Ping(P)]を選びます。複数の項目が表示されたときには、pingの対象とするホストを選びます。

方法3 (アドレス表やアドレス帳のホストに対してpingを実行する)

  1. IPアドレス表、MACアドレス-IPアドレス対応表、IPアドレス帳の行を右クリックします。
  2. [ネットワークユーティリティ(N)]を選びます。
  3. [Ping(P)]を選びます。複数の項目が表示されたときには、pingの対象とするホストを選びます。

方法4 (デコードビューやストリームビューのホストに対してpingを実行する)

  1. IPアドレスを含むデコードビューのパケットまたはストリームビューのレコードを右クリックします。
  2. [ネットワークユーティリティ(N)]を選びます。
  3. [Ping(P)]を選びます。複数の項目が表示されたときには、pingの対象とするホストを選びます。

パラメータを指定してPingを実行する

方法

  1. pingの対象とするホストのIPアドレスまたはホスト名を入力します。
    トラフィックウィンドウやデコードビューなどから[Ping]ダイアログを開いたときには、ホストは設定されています。
  2. pingで送るパケットのデータのサイズと送信回数を指定します。
  3. SOCKSサーバーを利用してLANの外側にあるホストに対してpingを実行する場合には、[SOCKSを使用する(O)]チェックボックスにチェックを付けてSOCKSサーバーを選びます。
    リストにないSOCKSサーバーを使う場合には、[詳細設定(D)...]ボタンをクリックして    SOCKSサーバーの情報を設定します。
  4. [実行]ボタンをクリックします。
    [結果をメッセージウィンドウに出力する(M)]チェックボックスにチェックを付けると、検索結果を[実行結果(R)]領域に表示する代わりに、メインウィンドウのメッセージウィンドウに表示します。


 6.2.3 Tracerouteを実行する

ASTEC Eyesからtracerouteを実行できます。 tracerouteを実行するためには次の操作を行います。

  1. [Traceroute]ダイアログを開く
  2. パラメータを指定してtracerouteを実行する

[Traceroute]ダイアログを開く

方法1 (ホスト名を指定してtracerouteを実行する)

メインウィンドウの[ツール(T)]メニューから[Tracerouteツール(T)...]を選びます。

方法2 (トラフィックウィンドウのホストに対してtracerouteを実行する)

  1. IP層のホストで分類したトラフィックを表示しているトラフィックウィンドウで、グラフアイテムを選びます。
  2. ウィンドウを右クリックします。
  3. [ネットワークユーティリティ(N)]を選びます。
  4. [Traceroute(T)]を選びます。複数の項目が表示されたときには、tracerouteの対象とするホストを選びます。

方法3 (アドレス表やアドレス帳のホストに対してtracerouteを実行する)

  1. IPアドレス表、MACアドレス-IPアドレス対応表、IPアドレス帳の行を右クリックします。
  2. [ネットワークユーティリティ(N)]を選びます。
  3. [Traceroute(T)]を選びます。複数の項目が表示されたときには、tracerouteの対象とするホストを選びます。

方法4 (デコードビューやストリームビューのホストに対してtracerouteを実行する)

  1. IPアドレスを含むデコードビューのパケットまたはストリームビューのレコードを右クリックします。
  2. [ネットワークユーティリティ(N)]を選びます。
  3. [Traceroute(T)]を選びます。複数の項目が表示されたときには、tracerouteの対象とするホストを選びます。

Tracerouteを実行する

方法

  1. tracerouteの対象とするホストを入力します。
    トラフィックウィンドウやデコードビューなどから[Traceroute]ダイアログを開いたときには、ホストが設定されています。
  2. tracerouteで送るパケットの最大ホップ数とタイムアウト時間を指定します。
  3. SOCKSサーバーを利用してLANの外側にあるホストに対してtracerouteを実行する場合には、[SOCKSを使用する(O)]チェックボックスにチェックを付けてSOCKSサーバーを選びます。
    リストにないSOCKSサーバーを使う場合には、[詳細設定(D)...]ボタンをクリックして    SOCKSサーバーの情報を設定します。
  4. [実行]ボタンをクリックします。
    [結果をメッセージウィンドウに出力する(M)]チェックボックスにチェックを付けると、検索結果を[実行結果(R)]領域に表示する代わりに、メインウィンドウのメッセージウィンドウに表示します。


 6.3 アドレス帳

ASTEC Eyesでは、ホストの識別にIPアドレスやMACアドレスだけではなく、ホスト名を使うことができます。アドレス帳を使うと次のようなことができます。

  • IPアドレスに対応する名前を検索する。
  • MACアドレスやIPアドレスにユーザー定義名を付ける。
  • 特定のネームサービスで1つのアドレスに対して複数の名前が登録されている場合や、複数のユーザー定義名をつけた場合に、どの名前を使うかを選ぶ。
アドレス帳にはMAC層用のものとIP層用のものがあります。前者をMAC層アドレス帳、後者をIP層アドレス帳と呼びます。アドレス帳はインタフェースごとに管理されているわけではありません。見つかったすべてのMACアドレスやIPアドレスが表示されます。

注

  • ユーザー定義名とはホストに対しユーザーが任意に設定できる名前です。


 6.3.1 MAC層アドレス帳を見る

方法

メインウィンドウの[編集(E)]メニューから[MAC層アドレス帳の編集(M)]を選びます。

注

  • MAC層アドレス帳には次のホスト名が表示されます。
    • キャプチャデータをデコードして見つかったもの
    • アドレス帳のファイルから読み込んだもの


 6.3.2 IP層アドレス帳を見る

方法

メインウィンドウの[編集(E)]メニューから[IP層アドレス帳の編集(I)]を選びます。

注

  • IP層アドレス帳には次のホスト名が表示されます。
    • モニタ中に見つかったもの
    • ログに記録されていたもの
    • キャプチャデータをデコードして見つかったもの
    • アドレス帳のファイルから読み込んだもの


 6.3.3 IPアドレスに対応するホスト名を検索する

方法

  1. IP層アドレス帳のウィンドウで、検索したいIPアドレスの行を右クリックします。
  2. [ホスト名の検索(H)]を選びます。
  3. [DNS(D)]、[NetBIOS(B)]、または[NIS(ドメイン名)(N)]を選びます。

注

  • あらかじめNISのドメイン名を指定しておかないと、[NIS(ドメイン名)(N)]は選べません。


 6.3.4 ユーザー定義名を入力する

方法1

  1. ユーザー定義名を入力したい行をクリックします。
  2. ユーザー定義名のセルをクリックします。
  3. 任意の文字列を入力し、<Enter>キーを押します。

方法2

  1. 入力したいユーザー定義名のセルを右クリックします。
  2. [編集(E)]を選びます。
  3. ユーザー定義名を入力し、<Enter>キーを押します。
方法3
  1. <↑>、<↓>キーでユーザー定義名を入力したい行に移動します。
  2. <←>、<→>キーで白い枠をユーザー定義名のセルに移動します。
  3. <F2>キーを押します。
  4. 任意の文字列を入力し、<Enter>キーを押します。

注

  • 複数のユーザー定義名をつけた場合は、名前の数がユーザー定義名セルの右端にカッコ付きで表示されます。


 6.3.5 ユーザー定義名を削除する

方法1

  1. 複数のユーザ定義名がある場合は、削除したいユーザー定義名を選びます。
  2. 削除したいユーザー定義名のセルを右クリックします。
  3. [名前の削除(D)]を選びます。

方法2

  1. 複数のユーザ定義名がある場合は、削除したいユーザー定義名を選びます。
  2. 削除したいユーザー定義名のセルを右クリックします。
  3. [編集(E)]を選びます。
  4. <Delete>または<Backspace>キーを押してユーザー定義名を消し、<Enter>キーを押します。

方法3

  1. 複数のユーザ定義名がある場合は、削除したいユーザー定義名を選びます。
  2. ユーザー定義名を削除したいアドレスに対応する行をクリックします。
  3. ユーザー定義名のセルをクリックします。
  4. <Delete>または<Backspace>キーを押してユーザー定義名を消し、<Enter>キーを押します。

方法4

  1. 複数のユーザー定義名がある場合は、削除したいユーザー定義名を選びます。
  2. <↑>、<↓>、<←>、<→>キーで白い枠を削除したいユーザー定義名のセルに移動します。
  3. <F2>キーを押します。
  4. <Delete>または<Backspace>キーを押してユーザー定義名を消し、<Enter>キーを押します。


 6.3.6 アドレス帳の行を並べ替える

方法1

並べ替えの基準とするカラムの見出しをクリックします。一度クリックすると昇順に、もう一度クリックすると降順に並びます。
方法2
  1. アドレス帳のウィンドウを右クリックします。
  2. [整列(A)]を選びます。
  3. 並べ替えの基準を選びます。一度選ぶと行が昇順に並びます。もう一度同じメニュー項目を選ぶと、降順に並びます。


 6.3.7 アドレス帳で文字列を検索する

方法

  1. アドレス帳のウィンドウをクリックします。
  2. メインウィンドウの[編集(E)]メニューから[検索(F)]を選ぶか、<Ctrl-F>キーを押します。
  3. テキストフィールドに文字列を入力し、[次を検索(F)]ボタンをクリックします。

注

  • 正規表現を使って検索するには、[正規表現(E)]チェックボックスにチェックを付けて、[検索する文字列(N)]に正規表現を入力します。


 6.3.8 アドレス帳を更新する

アドレス帳は定期的に更新されますが、ただちに最新の状態にしたいときにこの機能を使います。

方法

  1. アドレス帳のウィンドウを右クリックします。
  2. [最新の情報に更新(R)]を選びます。


 6.3.9 アドレス帳に表示されるカラム

[オプション設定]ダイアログの[ホスト名]ペインでチェックされている名前に対応するカラムがアドレス帳に表示されます。また、表示の優先順位の高いものが左側になります。
[オプション設定]ダイアログで、表示する名前や優先順位を設定する方法は「ホストの識別にホスト名を使う」を参照してください。


 6.3.10 ホスト名の数とホスト名を得た方法を表示する

アドレス帳のユーザー定義名、DNS名、WINS名、NIS名のカラムに、見つかったホスト名の数や検出方法を表示できます。

方法

  1. アドレス帳のウィンドウを右クリックします。
  2. [表示(V)]を選びます。
  3. [詳細(D)]を選びます。

注

  • 元の表示に戻したい場合は、手順3で[一覧(L)]を選びます。


 6.3.11 IPアドレスの表示桁をそろえる

IPアドレスの表示桁をそろえると、IPv4アドレスでは、“192.168.11.1”のように表示されていたIPアドレスが、“192.168. 11. 1”のように表示されます。また、IPv6アドレスでは、“2002:3d79:c191:c::1”のように省略表記されていたアドレスが、“2002:3d79:c191:000c:0000:0000:0000:0001”のように表示されます。

方法

  1. アドレス帳のウィンドウを右クリックします。
  2. [表示(V)]を選びます。
  3. [各桁を揃える(A)]を選びます。もう一度選ぶと、元の表示に戻ります。


 6.3.12 アドレス帳のデータの保存と読み込み

アドレス帳のデータをファイルへ保存する

方法

  1. メインウィンドウの[編集(E)]メニューから[アドレス帳の保存(W)...]を選びます。
  2. 保存するファイル名を指定します。

アドレス帳のデータをファイルから読み込む

方法

  1. メインウィンドウの[編集(E)]メニューから[アドレス帳の読み込み(A)...]を選びます。
  2. 読み込むファイル名を指定します。


 6.3.13 起動時に自動的にアドレス帳を読み込む

方法

ASTEC Eyesがインストールされているディレクトリに“default-address.txt”というファイル名でアドレス帳ファイルを保存しておけば、次にASTEC Eyesを起動したときに自動的にアドレス帳のデータを読み込みます。


 6.4 DHCPを使っているときの注意点

DHCPなどを使ってIPアドレスを動的に割り当てているときは、コンピュータを再起動したときに、そのコンピュータが以前と同じIPアドレスを取得できるとは限りません。このため、実際のIPアドレスとホスト名との対応が、アドレス帳のものとは異なる場合があります。


 7 リモート監視機能

  離れた場所にあるネットワークのトラフィックを監視したり、パケットをキャプチャする機能です。他のコンピュータで動作しているASTEC Eyesまたはリモートモジュールに接続するだけで、ローカルホストで動作しているASTEC Eyesを操作するのと全く同じようにリモートモジュールを操作できます。


 7.1 リモートモジュールに接続する

リモートモジュールに接続する方法には次の2種類があります。

  • インタフェースセレクタウィンドウに表示されていないホストに接続する
  • インタフェースセレクタウィンドウに表示されているホストに接続する

インタフェースセレクタウィンドウに表示されていないホストに接続する

方法1

  1. メインウィンドウの[ファイル(F)]メニューから[リモートへの接続(C)...]を選びます。
  2. [接続ホスト(H)]にリモートモジュールが動作しているホストのIPアドレスまたはホスト名を入力します。
  3. [接続]ボタンをクリックします。
方法2
  1. インタフェースセレクタウィンドウ内の何も表示されていない部分を右クリックします。
  2. [リモートへの接続(C)...]を選びます。
  3. [接続ホスト(H)]にリモートモジュールが動作しているホストのIPアドレスまたはホスト名を入力します。
  4. [接続]ボタンをクリックします。

インタフェースセレクタウィンドウに表示されているホストに接続する

方法

  1. 接続が切れているホスト( [image])のエントリを右クリックします。
  2. [接続(C)]を選びます。

注

  • [接続ホスト(H)]には、ローカルホストが識別できるIPアドレスやDNS名、NetBIOS名などを入力します。
  • リモートモジュールとIPv6で接続する場合は、[接続ホスト(H)]の右側にあるドロップダウンリストボックスからIPv6を選びます。
  • ASTEC Eyesは8887/TCPを使ってリモートモジュールと接続します。


 7.2 接続先のポート番号を変えて接続する

ASTEC Eyesは8887/TCPを使ってリモートモジュールと接続します。
SSHのポートフォワーディング機能を利用する場合など、デフォルト以外のポートを使ってリモートモジュールと接続する場合などは、ASTEC Eyesがリモートモジュールへ接続する際のポート番号を変更できます。

方法1

  1. メインウィンドウの[ファイル(F)]メニューから[リモートへの接続(C)...]を選びます。
  2. [接続ホスト(H)]に接続先のホストを入力します。
  3. [接続先ポート番号を変更する(A)]チェックボックスにチェックを付けます。
  4. 接続先のポート番号を入力します。
  5. [接続]ボタンをクリックします。
方法2
  1. インタフェースセレクタウィンドウ内の何も表示されていない部分を右クリックします。
  2. [リモートへの接続(C)...]を選びます。
  3. [接続ホスト(H)]に接続先のホストを入力します。
  4. [接続先ポート番号を変更する(A)]チェックボックスにチェックを付けます。
  5. 接続先のポート番号を入力します。
  6. [接続]ボタンをクリックします。

注

  • [接続ホスト(H)]には、ローカルホストが識別できるIPアドレスやDNS名、NetBIOS名などを入力します。
  • リモートモジュールとIPv6で接続する場合は、[接続ホスト(H)]の右側にあるドロップダウンリストボックスからIPv6を選びます。
  • 接続先のポート番号の設定を標準の値に戻すには、[標準に戻す(P)]ボタンをクリックします。


 7.3 SOCKSを使って接続する

ASTEC Eyesでは、SOCKSを経由してリモートモジュールに接続できます。 SOCKSを利用して接続するには、次の操作を行います。

  1. [接続]ダイアログを開く
  2. SOCKSサーバーを指定して接続する

[接続]ダイアログを開く

方法1

メインウィンドウの[ファイル(F)]メニューの[リモートへの接続(C)...]を選びます。
方法2
  1. インタフェースセレクタウィンドウ内の何も表示されていない部分を右クリックします。
  2. [リモートへの接続(C)...]を選びます。

SOCKSサーバーを指定して接続する

方法

  1. [SOCKSを使用する(O)]チェックボックスにチェックを付けます。
  2. ドロップダウンリストボックスから使用するSOCKSの設定を選びます。 設定がない場合は[詳細設定(D)...]ボタンをクリックしてSOCKSサーバーの情報を設定します。
  3. [接続]ボタンをクリックします。

注

  • [接続ホスト(H)]には、ローカルホストが識別できるIPアドレスやDNS名、NetBIOS名などを入力します。
  • [接続先ポート番号を変更する(A)]チェックボックスと[SOCKSを使用する(O)]チェックボックスの両方にチェックが付いている場合、ASTEC EyesはSOCKSサーバーを経由して、接続先ホストの指定されたポート番号へ接続します。


 7.4 SOCKSサーバーの情報を設定する

方法

  1. 一番上の空の行をクリックします。
  2. [識別名(I)]に設定を区別するための任意の文字列を入力します。
  3. [サーバー(S)]と[ポート(P)]に、SOCKSサーバーが動作しているホストとポート番号を入力します。
  4. SOCKSサーバーのバージョンを選びます。必要に応じてSOCKSサーバーへ接続する際のユーザーIDなどを入力します。
  5. 1～4の操作を繰り返します。
  6. [OK]ボタンをクリックします。


 7.5 リモートモジュールとの接続を切断する

方法

  1. インタフェースセレクタウィンドウ内のホストのエントリを右クリックします。
  2. [切断(S)]を選びます。

注

  • 切断されたホストとそのインタフェースのアイコンには、×が重ねて表示されます（ [image] 、 [image] ）。


 7.6 ホストのエントリを削除する

方法

  1. リモートモジュールとの接続を切断します。
  2. インタフェースセレクタウィンドウ内のホストのエントリを右クリックします。
  3. [削除(D)]を選びます。


 7.7 設定権限の取得と開放

次の操作を行うには設定権限が必要です。

  • インタフェースのエントリのラベルを登録する
  • インタフェースを有効にする、または無効にする
  • モニタをリセットする
  • ログの設定およびログの出力の開始と停止
  • 連続キャプチャ機能の設定および連続キャプチャの開始と停止
  • 連続キャプチャフィルタ、連続キャプチャ開始トリガ、連続キャプチャ停止トリガを適用する
  • モニタのエキスパート機能を設定する
  • 通知機能を設定する
  • SNMP機能を設定する
設定権限を取得する

方法1

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [取得(G)]ボタンをクリックします。

方法2

  1. インタフェースセレクタウィンドウ内のホストのエントリを右クリックします。
  2. [設定権限を取得(G)]を選びます。

設定権限を開放する

方法1

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [解放(R)]ボタンをクリックします。

方法2

  1. インタフェースセレクタウィンドウ内のホストのエントリを右クリックします。
  2. [設定権限を開放(F)]を選びます。

注

  • 設定権限を取得できるのは、他のASTEC Eyesが設定権限を持っていない場合だけです。
  • 設定権限を持つホストのアイコンの左上には☆が表示されます（ [image] ）。


 8.1 フィルタエディタを開く

方法1

メインウィンドウの[編集(E)]メニューから[フィルタエディタ(E)...]を選びます。
方法2
<Ctrl-E>キーを押します。


 8.2 フィルタを作る

複雑な条件を指定するにはフィルタエディタを使います。フィルタエディタでは次のフィルタを作ることができます。

  • ディスプレイフィルタ
  • モニタフィルタ
  • イベントフィルタ
  • キャプチャフィルタ
  • キャプチャ開始トリガ
  • キャプチャ停止トリガ
  • 連続キャプチャフィルタ
  • 連続キャプチャ開始トリガ
  • 連続キャプチャ停止トリガ

  フィルタを作成するには、次の操作を行います。

  1. 作成するフィルタの種類を選ぶ。
  2. 論理式を入力する。

作成するフィルタの種類を選ぶ

方法

  1. フィルタエディタを開きます。
  2. [フィルタビューア]領域上のツリー形式で表示されているフィルタ名をクリックします。

論理式を入力する

方法1

  1. [新規条件(E)]ボタンまたは[新規グループ(G)]ボタンをクリックします。
  2. 条件グループや条件論理式の種類、条件、値などを指定します。

方法2

  1. フィルタ名を右クリックします。
  2. [新規条件(N)]または[新規グループ(G)]を選びます。
  3. 条件グループや条件論理式の種類、条件、値などを指定します。

注

  • 連続キャプチャフィルタ、連続キャプチャ開始トリガ、連続キャプチャ停止トリガを定義するには、ホストの設定権限が必要です。
  • フィルタの種類ごとに、定義できるフィルタの数や論理式の構造に制約があります。詳しくはユーザーズガイドを参照してください。


 8.3 フィルタをファイルに保存する

方法

  1. フィルタエディタの[保存(S)...]ボタンをクリックします。 [名前を付けて保存]ダイアログが現れます。
  2. ファイル名を入力し、[保存(S)]ボタンをクリックします。

注

  • [名前を付けて保存]ダイアログでは、1つのファイルに保存するフィルタの種類を指定できます。
    • すべてのフィルタを1つのファイルに保存する
    • 1つのインタフェースのフィルタを1つのファイルに保存する
    • 1つのフィルタを1つのファイルに保存する


 8.4 フィルタをファイルから読み込む

方法

  1. フィルタエディタの[読込み(L)...]ボタンをクリックします。
  2. 読み込むファイルを選び、[開く(O)]ボタンをクリックします。


 8.5 起動時に自動的にフィルタを読み込む

方法

次のフィルタについては、フィルタの論理式をASTEC Eyesがインストールされているディレクトリに、“default-filters.fts”というファイル名で保存すれば、次にASTEC Eyesを起動した時に自動的に読み込みます。
  • ディスプレイフィルタ
  • モニタフィルタ
  • イベントフィルタ
  • ローカルホストのキャプチャフィルタ
  • ローカルホストの[ [image] キャプチャ開始トリガ]
  • ローカルホストの[ [image] キャプチャ停止トリガ]


 9 エキスパート機能

ASTEC Eyesには2種類のエキスパート機能があります。モニタエキスパート機能とデコーダエキスパート機能です。

モニタエキスパート機能は、 ネットワークのモニタ中に、トラブルの予兆を発見し、表示する機能です。 トラブルの予兆となるようなイベントを監視し、見つかったイベントをイベントビューアに表示したり、メールやSNMPトラップで知らせたりします。

デコーダエキスパート機能は、キャプチャデータの解析中にトラブルの種になりうるイベントを発見し、表示する機能です。ネットワーク機器の設定が適切でない可能性や、トラブルを起こす可能性のあるパケットが流れたことを示します。


 9.1.1 検出したモニタイベントを表示する

方法1

  1. インタフェースを選びます。
  2. モニタを開始していない場合は、モニタを開始します。
  3. メインウィンドウの[モニタ(M)]メニューから[イベントビューア(V)]を選びます。
方法2
  1. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  2. モニタを開始していない場合は、モニタを開始します。
  3. [モニタウィンドウ(M)]を選びます。
  4. [イベントビューア(V)]を選びます。

注

  • 以下の項目の内容が同じで発生した時刻だけが異なるイベントはまとめて表示されます。
    • イベントの種類
    • 発信元アドレス
    • 発信元ポート番号
    • 受信先アドレス
    • 受信先ポート番号
  • まとめて表示されているイベントでは、イベントのカラムの右端に、まとめられているイベント数がカッコ内に表示されます。
  • まとめられているイベントを展開するには、「まとめられたイベントを展開する」を参照して下さい。
  • モニタイベントでは「フレームID」は表示されません。


 9.1.2 検出したデコードイベントを表示する

方法1

  1. キャプチャデータをデコードします。
  2. デコードビューのツールバーの[イベントビューア]ボタン( [image]) をクリックします。

方法2

  1. キャプチャデータをデコードします。
  2. デコードビューを右クリックし、[イベントビューア(E)]を選びます。


 9.1.3 まとめられたイベントを展開する

イベントビューアでは、イベントの種類と発信元、および受信先が同じで、発生した時刻だけが異なるイベントはまとめて表示されます。まとめて表示されているイベントを展開することができます。

すべてのイベントを展開する

  1. イベントビューアを右クリックします。
  2. [集約表示(C)]を選びます。
  3. 元の表示に戻したい場合は、もう一度[集約表示(C)]を選びます。
特定のイベントを展開する
  1. 展開したいイベントに対応する行をダブルクリックします。
  2. 元の表示に戻したい場合は、展開された行をダブルクリックします。


 9.1.4 イベントビューアに常に最新のイベントを表示する

モニタエキスパートの機能では、新しく報告されたイベントはイベントビューアの最後尾に追加されます。一番下の行(アイコンが [image] の行)を選んだ状態にしておくと、常に最新のイベントを表示できます。


 9.1.5 イベントビューアの表示形式を切り替える

イベントビューアは表形式、または折れ線グラフ形式で表示できます。

方法1

イベントビューアのツールバーの

  • [折れ線グラフ(履歴)]ボタン( [image])
  • [表(詳細)]ボタン( [image])
のいずれかをクリックします。

方法2

  1. イベントビューアを右クリックします。
  2. [表示形式(V)]を選びます。
  3. 次のいずれかを選びます。
    • [折れ線グラフ(H)]
    • [表形式(T)]


 9.1.6 凡例の表示、非表示を切り替える

方法1

イベントビューア(折れ線グラフ形式)のツールバーの[凡例]ボタン( [image])をクリックします。

方法2

  1. イベントビューア(折れ線グラフ形式)を右クリックします。
  2. [凡例(L)]を選びます。


 9.1.7 イベントの履歴を表示する

モニタエキスパート機能では、イベントビューアの折れ線グラフに標準で表示される期間は、モニタの短期タイムスパンで設定した期間です。短期タイムスパンよりも長い期間を表示することもできます。

方法

  1. イベントビューアを右クリックします。
  2. [履歴を表示(H)]をクリックします。

注

  • ログに保存したイベントを表示する場合を除き、イベントビューアに表示される件数の上限は1000件です。


 9.1.8 イベントの情報をファイルに保存する

  エキスパート機能で検出したイベントの情報ををCSV(カンマ区切り)形式、bmp形式、メタファイル形式、およびエンハンスドメタファイルの形式で保存できます。

方法

  1. 保存したいイベントの情報を表示しているイベントビューアをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[モニタ情報の保存(G)...]を選びます。
  3. 保存するファイル名とその形式を指定します。

注

  • 表形式で表示したイベントの情報はCSV形式でのみ保存できます。
  • 保存したイベントの情報は他のアプリケーションで利用することができます。例えば、Microsoft Wordにbmp形式の画像を挿入したり、Microsoft ExcelでCSV形式のデータを読み込んだりできます。


 9.2.1 特定の値と一致するイベントを表示する

表形式のイベントビューアでは、見出しフィルタを使ってカラムの値が特定の値と一致するイベントのみを表示できます。見出しフィルタは、[イベント]、[発信元アドレス]、[発信元ポート番号]、[受信先アドレス]、[受信先ポート番号]、[情報]のカラムで使えます。 見出しフィルタの操作については、「特定の値と一致するパケットまたはレコードを表示する」を参照してください。


 9.2.2 複数の値のいずれかと一致するイベントを表示する

方法

  1. イベントビューアで、▼マークの付いたカラムの見出しをクリックします。
  2. [オプション(P)...]を選びます。
  3. [複数選択(M)]を選びます。
  4. リストから目的の値を選びます。複数の値を選択できます。
    このとき、文字列を入力し、[検索(F)]ボタンをクリックすると、リスト内の文字列を検索できます。


 9.2.3 メニュー項目が多いときに目的の値を見つける

カラムの値の種類が多すぎて、カラムの見出しをクリックして現れるメニューに、目的の値に対応するメニュー項目が表示されないことがあります。このような場合は候補リストダイアログを使います。

方法

  1. イベントビューアで、▼マークの付いたカラムの見出しをクリックします。
  2. [候補リスト(T)...]を選びます。
  3. リストから目的の値を選びます。
    このとき、文字列を入力し、[検索(F)]ボタンをクリックすると、リスト内の文字列を検索できます。

注

  • メニュー項目が16個以下のときは[候補リスト(T)...]は現れません。


 9.2.4 見出しフィルタを解除する

1つのフィルタを解除する方法

フィルタを設定した見出しをクリックしてメニューを開き、[すべて(L)]を選びます。

フィルタをすべて解除する方法

イベントビューアのツールバーの[フィルタ解除]ボタン( [image])をクリックします。


 9.3.1 検出するモニタイベントを設定する

検出するモニタイベントの種類やその閾値は、[ホストのプロパティ]ダイアログで行います。設定はネットワークインタフェース毎に行います。

方法

  1. 設定権限がない場合は、設定権限を取得します。
  2. [ホストのプロパティ]ダイアログを開きます。
  3. [エキスパート]タブをクリックします。
  4. 設定したいインタフェースをクリックします。
  5. 検出したいイベントの[検出]カラムのチェックボックスにチェックを付けます。
  6. 次のイベントを検出する場合は閾値も入力します。
    • TCP window frozen
    • TCP long ack time
    • TCP connection table threshold over
    • MAC traffic under threshold

特定の条件を満たすときのみイベントを検出したい場合には、イベントフィルタを作成して適用します。

方法

  1. フィルタエディタを開くか、[イベント]カラムを右クリックして[フィルタエディタ(F)...]を選びます。
  2. [ [image] イベントフィルタ]を作成します。
  3. 検出条件を設定したいイベントの[イベント]カラムを右クリックし、フィルタを選びます。


 9.3.2 ユーザー定義イベントを作成する

ユーザーが指定した条件に一致するデータが流れたり、指定した状況になったときにモニタイベントを発生させることができます。このようなイベントを、ユーザー定義イベントと言います。

方法

  1. フィルタエディタを開きます。
  2. [ [image] イベントフィルタ]を作成します。
  3. 設定権限がない場合は、設定権限を取得します。
  4. [ホストのプロパティ]ダイアログを開きます。
  5. [エキスパート]タブをクリックします。
  6. 設定したいインタフェースをクリックします。
  7. [NIC user filter]の[イベント]カラムを右クリックします。
  8. イベントフィルタを選びます。
  9. [検出]カラムにチェックを付けます。


 9.3.3 イベントをメールやSNMPで通知する

通知機能を使えば、モニタイベントが発生したことをメールやSNMPトラップで通知できます。 通知するイベントの設定はインタフェースごとに行います。 また、メールやSNMPの通知方法などの設定はASTEC Eyesやリモートモジュールごとに行います。

メールによる通知方法

  1. 設定権限がない場合は、設定権限を取得します。
  2. [ホストのプロパティ]ダイアログを開きます。
  3. [通知機能]タブをクリックします。
  4. メールの設定をします。
  5. [エキスパート]タブをクリックします。
  6. 通知機能を有効にしたいインタフェースについて、[通知機能]チェックボックスにチェックをつけます。
  7. 通知したいイベントの[通知]のカラムのチェックボックスにチェックを付けます。
  8. イベントが発生したときにすぐに通知したいイベントのみ、[即時配信]のカラムのチェックボックスにもチェックを付けます。

SNMPによる通知方法

  1. 設定権限がない場合は、設定権限を取得します。
  2. [ホストのプロパティ]ダイアログを開きます。
  3. [SNMP機能]タブをクリックします。
  4. SNMPの設定をします。
  5. [エキスパート]タブをクリックします。
  6. 通知機能を有効にしたいインタフェースについて、[通知機能]チェックボックスにチェックをつけます。
  7. 通知したいイベントの[SNMP]のカラムのチェックボックスにチェックを付けます。

注

  • [通知]、[即時配信]、[SNMP]カラムにチェックをつける際は、[検出]カラムにもチェックを付けてください。


 9.3.4 検出するデコードイベントを設定する

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[デコードエキスパート]をクリックします。
  3. [デコードエキスパート機能を利用する(D)]チェックボックスにチェックをつけます。
  4. 検出したいイベントの[検出]カラムにチェックをつけます。検出したくないイベントからはチェックを外します。

注

  • デフォルトでは、デコード時にイベントを検出しないようになっています。


 10 インタフェースセレクタウィンドウでの操作

インタフェースセレクタウィンドウは、インタフェースに関するさまざまな操作を行う機能を備えています。


 10.1 ネットワークインタフェースを選ぶ

方法1

インタフェースセレクタウィンドウ内のインタフェースのエントリをクリックします。

方法2

  1. <Alt-1>キーを押してインタフェースセレクタウィンドウにフォーカスを移します。
  2. <↑>、<↓>キーで目的のインタフェースを選び、<Enter>キーを押します。

方法3

メインウィンドウのインタフェースツールバーのインタフェース選択リスト( [image])からインタフェースを選ぶ。

注

  • 選ばれたネットワークインタフェースのアイコンは緑色で表示され（ [image] ）、それ以外のインタフェースのアイコンは灰色で表示されます（ [image] ）。


 10.2 ホストのラベルを変える

方法

  1. [ホストのプロパティ]ダイアログを開きます。
  2. [情報]タブをクリックします。
  3. テキストフィールドにホストのラベルを入力します。


 10.3 インタフェースのラベルを変える

方法

  1. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  2. [プロパティ(P)...]を選びます。
  3. [情報]タブをクリックします。
  4. テキストフィールドにインタフェースのラベルを入力します。
  5. ラベルをリモートモジュールに登録したい場合は、[ラベルをリモートモジュールに登録する(R)]ボタンをクリックします。

注

  • ラベルをリモートモジュールに登録するには、設定権限が必要です。
  • 新しいラベルをリモートモジュールに登録しなかった場合、次にASTEC Eyesを起動したときには、以前のラベルが使われます。
  • ラベルをリモートモジュールに登録すると、別のホストで動作しているASTEC Eyesからリモートモジュールに接続しても、登録したラベルが表示されます。
  • ローカルホストのインタフェースのラベルは設定情報ファイルに保存できます。


 10.4 ネットワークインタフェースを有効または無効にする

方法

  1. 設定権限がない場合は、設定権限を取得します。
  2. インタフェースセレクタウィンドウ内のインタフェースのエントリを右クリックします。
  3. [インタフェースを無効にする(D)]または[インタフェースを有効にする(W)]を選びます。

注

  • 無効なインタフェースのアイコンには×が重ねて表示されています（ [image] ）。有効にすると、×が消えます（ [image] または [image] ）。


 10.5 ホストのプロパティダイアログを開く

方法1

  1. メインウィンドウの[設定(O)]メニューから設定したい機能を選びます。
    • [ログ機能(G)]
    • [連続キャプチャ機能(J)]
    • [エキスパート機能(E)]
    • [通知機能(N)]
    • [SNMP機能(S)]
  2. ホストを選びます。

方法2

  1. インタフェースセレクタウィンドウ内のホストのエントリを右クリックします。
  2. [プロパティ(P)...]を選びます。

方法3

  1. インタフェースツールバーに[ホストのプロパティ]ボタン( [image])がないときは、インタフェースツールバーにボタンを追加します。
  2. [ホストのプロパティ]ボタン( [image])をクリックします。

注

  • [ホストのプロパティ]ボタン( [image])をクリックしたときの対象となるホストは、現在選ばれているインタフェースが属しているホストです。


 11 ワークスペースの操作

ワークスペースは複数作ることができます。モニタウィンドウやデコードビュー、ストリームビューなど、ダイアログ以外のウィンドウは選択中のワークスペースに表示されます。ワークスペースを利用すれば複数のウィンドウを整理できます。


 11.1 ワークスペースにフォーカスを移す

方法1

ワークスペースをマウスでクリックします。
方法2
<Alt-0>キーを押します。


 11.2 ワークスペースを選ぶ

方法1

  1. メインウィンドウの[表示(V)]メニューを開きます。
  2. ワークスペースに対応するメニュー項目を選びます。
方法2
ワークスペースのタブをクリックします。
方法3
  1. ワークスペースのタブを右クリックします。
  2. ワークスペースに対応するメニュー項目を選びます。
方法4
  1. ワークスペース内のウィンドウが表示されていない部分を右クリックします。
  2. ワークスペースに対応するメニュー項目を選びます。

方法5

<Ctrl-Alt-←>、<Ctrl-Alt-→>、<Ctrl-PageUp>、または<Ctrl-PageDown>キーを押します。


 11.3 ワークスペースを追加する

方法1

メインウィンドウの[表示(V)]メニューから[ワークスペースの追加(A)]を選びます。
方法2
  1. ワークスペースのタブを右クリックします。
  2. [ワークスペースの追加(A)]を選びます。
方法3
  1. ワークスペース内のウィンドウが表示されていない部分を右クリックします。
  2. [ワークスペースの追加(A)]を選びます。
方法4
  1. ワークスペース内のウィンドウのタイトルバーを右クリックします。
  2. [新しいワークスペース(N)]を選びます。この方法ではクリックしたウィンドウが新しいワークスペースに移動します。


 11.4 ワークスペースを削除する

方法1

  1. 削除したいワークスペースに移動します。
  2. メインウィンドウの[表示(V)]メニューから[ワークスペースの削除(D)]を選びます。

方法2

  1. 削除したいワークスペースのタブを右クリックします。
  2. [ワークスペースの削除(D)]を選びます。
方法3
  1. 削除したいワークスペースに移動します。
  2. ウィンドウが何も表示されていない部分を右クリックします。
  3. [ワークスペースの削除(D)]を選びます。

注

  • 削除するワークスペースにウィンドウがある場合は、ワークスペースと同時にウィンドウも削除してよいかどうかを確認する[ASTEC Eyes]ダイアログが現れます。
  • ワークスペースが1つだけのときは、そのワークスペースを削除できません。


 11.5 ワークスペースのラベルを変える

方法1

  1. ワークスペースのタブを右クリックします。
  2. [プロパティ(P)...]を選びます。
  3. [ラベル(L)]にラベルを入力します。

方法2

  1. ワークスペース内のウィンドウが表示されていない部分を右クリックします。
  2. [プロパティ(P)...]を選びます。
  3. [ラベル(L)]にラベルを入力します。


 11.6 ワークスペースとネットワークインタフェースを関連付ける

ワークスペースとインタフェースを関連付けておけば、ワークスペースを選んだときに、関連付けられたインタフェースが自動的に選ばれた状態になります。

方法

  1. ワークスペースのタブまたはワークスペース内の何も表示されていない部分を右クリックします。
  2. [プロパティ(P)...]を選びます。
  3. [インタフェースに関連付ける(B)]チェックボックスにチェックを付けます。
  4. ドロップダウンリストボックスからインタフェースを選びます。


 11.7 ウィンドウを別のワークスペースに移す

方法1

  1. ウィンドウのタイトルバーを右クリックします。
  2. 移動先のワークスペースに対応するメニュー項目を選びます。

方法2

  1. 移動したいウィンドウをクリックします。
  2. メインウィンドウの[ウィンドウ(W)]から[ワークスペースへ移動(M)]を選びます。
  3. 移動先のワークスペースに対応するメニュー項目を選びます。


 11.8 隠された状態のウィンドウをアクティブにする

方法

  1. メインウィンドウの[ウィンドウ(W)]メニューを開きます。
  2. アクティブにしたいウィンドウに対応するメニュー項目を選びます。


 11.9 ウィンドウを整列する

方法

  1. メインウィンドウの[ウィンドウ(W)]メニューを開きます。
  2. 整列の基準を選びます。
    • [重ねて表示(C)]
    • [上下に並べて表示(H)]
    • [左右に並べて表示(T)]
    • [アイコンの整列(A)]


 11.10 ワークスペースのタブの位置を変える

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[その他]をクリックします。
  3. [タブを上に配置する(U)]または[タブを下に配置する(D)]を選びます。


 12 レポート機能

モニタのグラフや表をレポートとして出力する機能です。 HTML形式のファイルとして出力して印刷したり、Webブラウザから見ることができます。


 12.1 ウィザードを使ってレポート設定を作成する

方法

  1. メインウィンドウの[設定(O)]メニューから[レポート設定の追加]を選びます。
  2. レポートの設定を行うワークスペースを選び、[次へ(N)>]ボタンをクリックします。
  3. ウィンドウのサイズを指定し、[次へ(N)>]ボタンをクリックします。
  4. レポートの出力タイミングを選択し、[次へ(N)>]ボタンをクリックします。
  5. レポートの出力先ディレクトリを指定します。
  6. 出力先ディレクトリにスタイルシートとイメージファイルがなければ、[コピー(C)]ボタンをクリックしてコピーします。
  7. [次へ(N)>]ボタンをクリックします。

注

  • ウィザードの最後のページで、[ウィザード終了後、一度レポートを出力する(T)]にチェックを付けると、ウィザード終了後すぐにレポートが出力されます。


 12.2 ワークスペースを元にレポート設定を作成する

既にあるワークスペース上のモニタウィンドウをレポートとして出力できます。

方法

  1. モニタウィンドウを出力したいワークスペースのタブを右クリックします。
  2. [レポートの設定(H)...]を選びます。
  3. [レポート]ページで出力のタイミングを指定します。
  4. [詳細]ページで出力先ディレクトリやテンプレートファイル、グラフの順序を指定します。


 12.3 レポートを出力する

すぐにレポートを出力する方法と定期的にレポートを出力する方法があります。

すぐにレポートを出力する

方法1

  1. メインウィンドウの[設定(O)]から[レポート設定の追加]を選びます。
  2. ウィザードの最後で、[ウィザード終了後、一度レポートを出力する(T)]にチェックを付けます。

方法2

  1. ワークスペースのタブを右クリックします。
  2. [レポートの設定(H)...]を選びます。
  3. [レポート]ページの[手動で出力する]領域の[今すぐ出力する(T)]ボタンをクリックします。

定期的にレポートを出力する

方法1

  1. メインウィンドウの[設定(O)]から[レポート設定の追加]を選びます。
  2. ウィザードの[出力のタイミング]のページで、レポートの出力タイミングを指定します。

方法2

  1. ワークスペースのタブを右クリックします。
  2. [レポートの設定(H)...]を選びます。
  3. [レポート]ページの[最新の状態を更新する(C)]または[レポートを定期的に出力する(O)]にチェックを付けます。

注

  • レポートの出力はWebブラウザで確認できます。
    ワークスペースのタブを右クリックし、[表示]ページの[一覧(L)]で出力ページを選んで[レポートを表示(S)]ボタンをクリックします。


 12.4 レポートの出力先を変更する

方法

  1. ワークスペースのタブを右クリックします。
  2. [レポートの設定(H)...]を選びます。
  3. [詳細]タブをクリックします。
  4. [レポートディレクトリ(P)]に、レポートの出力先ディレクトリを指定します。

注

  • レポートの出力先ディレクトリを変更するときには、スタイルシートとイメージファイルを出力先ディレクトリへコピーする必要があります。 [管理]ページを開き、[ファイル]領域の[コピー(C)]ボタンをクリックします。


 12.5 レポートに表示するグラフのサイズを変更する

方法1

ワークスペース上のウィンドウのフレーム上でマウスの左ボタンをドラッグし、ウィンドウのサイズを変更します。

方法2

  1. メインウィンドウの[ウィンドウ(W)]メニューから[グラフのサイズ(G)]を選びます。
  2. [グラフのサイズ]ダイアログにグラフの幅と高さを入力します。


 12.6 レポートのレイアウトを変更する

方法

  1. レイアウトを変更したHTMLのテンプレートファイルを作成します。
  2. ワークスペースのタブを右クリックします。
  3. [レポートの設定(H)...]を選びます。
  4. [詳細]ページでテンプレートファイルを指定します。


 12.7 古いレポートファイルを削除する

方法

  1. ワークスペースのタブを右クリックします。
  2. [レポートの設定(H)...]を選びます。
  3. [管理]タブをクリックします。
  4. [レポートの削除]領域の[日付(D)]で、削除するレポートの日付を指定します。
  5. [削除(T)]ボタンをクリックします。

注

  • レポートファイルの削除後、[リンクの再構築]領域の[再構築(R)]ボタンをクリックすると、リンク先のレポートが削除されている場合はリンクを張らないように再構築されます。


 13 印刷機能

次のウィンドウの情報を印刷できます。また、プレビューで印刷イメージを確認してから印刷することもできます。

  • モニタウィンドウ
  • ログウィンドウ
  • デコードビュー、ストリームビュー
  • MAC層アドレス帳、IP層アドレス帳
  • イベントビューア
  • 音声品質のウィンドウ
  • シーケンス表示のウィンドウ


 13.1 モニタ情報を印刷する

モニタウィンドウに表示されているグラフや表を印刷できます。

方法1

  1. 印刷したいモニタウィンドウをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[印刷(P)...]を選ぶか、<Ctrl-P>キーを押します。
  3. 使用するプリンタ、印刷部数、印刷範囲を指定します。

方法2

  1. 印刷したいモニタウィンドウをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[印刷プレビュー(V)]を選びます。
  3. 印刷イメージを確認して、良ければ[印刷(P)...]ボタンをクリックします。
  4. 使用するプリンタ、印刷部数、印刷範囲を指定します。


 13.2 ログを印刷する

ログのウィンドウに表示されているグラフや表を印刷できます。

方法1

  1. 印刷したいログのウィンドウをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[印刷(P)...]を選ぶか、<Ctrl-P>キーを押します。
  3. 使用するプリンタ、印刷部数、印刷範囲を指定します。
方法2
  1. 印刷したいログのウィンドウをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[印刷プレビュー(V)]を選びます。
  3. 印刷イメージを確認して、よければ[印刷(P)...]ボタンをクリックします。
  4. 使用するプリンタ、印刷部数、印刷範囲を指定します。


 13.3 デコード結果を印刷する

デコードビューまたは通常のストリームビューを印刷する

方法1

  1. 印刷したいデコードビューまたはストリームビューをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[印刷(P)...]を選ぶか、<Ctrl-P>キーを押します。
  3. 印刷するフレームまたはストリームの範囲、印刷する内容、倍率を指定します。

方法2

  1. 印刷したいデコードビューまたはストリームビューをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[印刷プレビュー(V)]を選びます。
  3. 印刷するフレームまたはストリームの範囲、印刷する内容、倍率を指定し、[OK]ボタンをクリックします。
  4. 印刷イメージを確認して、よければ[印刷(P)...]ボタンをクリックします。
  5. 使用するプリンタ、印刷部数、印刷範囲を指定します。

シーケンスモードのストリームビューを印刷する

方法1

  1. 印刷したいストリームビューをクリックします。
  2. 印刷したいセッションをクリックします。
  3. メインウィンドウの[ファイル(F)]メニューから[印刷(P)...]を選ぶか、<Ctrl-P>キーを押します。
  4. 使用するプリンタ、印刷部数、印刷範囲を指定します。

方法2

  1. 印刷したいストリームビューをクリックします。
  2. 印刷したいセッションをクリックします。
  3. メインウィンドウの[ファイル(F)]メニューから[印刷プレビュー(V)]を選びます。
  4. 印刷イメージを確認して、良ければ[印刷(P)...]ボタンをクリックします。
  5. 使用するプリンタ、印刷部数、印刷範囲を指定します。

注

  • デコード結果にフィルタをかけてから印刷すると、表示されているパケットのみが印刷されます。フィルタの使い方について詳しくは、デコード機能の簡易フィルタ、またはディスプレイフィルタの項目を参照してください。


 13.4 音声品質を印刷する

音声品質のウィンドウに表示されているグラフや表を印刷できます。

方法1

  1. 印刷したい音声品質のウィンドウをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[印刷(P)...]を選ぶか、<Ctrl-P>キーを押します。
  3. 使用するプリンタ、印刷部数、印刷範囲を指定します。

方法2

  1. 印刷したい音声品質のウィンドウをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[印刷プレビュー(V)]を選びます。
  3. 印刷イメージを確認して、良ければ[印刷(P)...]ボタンをクリックします。
  4. 使用するプリンタ、印刷部数、印刷範囲を指定します。


 13.5 VoIPのシーケンスを印刷する

シーケンス表示のウィンドウに表示されているシーケンスを印刷できます。セッションが複数ある場合は、一つずつ選んで印刷します。

方法1

  1. シーケンス表示のウィンドウで印刷したいセッションをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[印刷(P)...]を選ぶか、<Ctrl-P>キーを押します。
  3. 使用するプリンタ、印刷部数、印刷範囲を指定します。

方法2

  1. シーケンス表示のウィンドウで印刷したいセッションをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[印刷プレビュー(V)]を選びます。
  3. 印刷イメージを確認して、良ければ[印刷(P)...]ボタンをクリックします。
  4. 使用するプリンタ、印刷部数、印刷範囲を指定します。


 13.6 アドレス帳を印刷する

方法1

  1. 印刷したいアドレス帳をクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[印刷(P)...]を選ぶか、<Ctrl-P>キーを押します。
  3. 使用するプリンタ、印刷部数、印刷範囲を指定します。

方法2

  1. 印刷したいアドレス帳をクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[印刷プレビュー(V)]を選びます。
  3. 印刷イメージを確認し、よければ[印刷(P)...]ボタンをクリックします。
  4. 使用するプリンタ、印刷部数、印刷範囲を指定します。


 13.7 イベントビューアを印刷する

イベントビューアの表示を印刷できます。

方法1

  1. メインウィンドウの[ファイル(F)]メニューから[印刷(P)...]を選ぶか、<Ctrl-P>キーを押します。
  2. 使用するプリンタ、印刷部数、印刷範囲を指定します。

方法2

  1. メインウィンドウの[ファイル(F)]メニューから[印刷プレビュー(V)]を選びます。
  2. 印刷イメージを確認して、よければ[印刷(P)...]ボタンをクリックします。
  3. 使用するプリンタ、印刷部数、印刷範囲を指定します。


 13.8 印刷のプレビューを見る

印刷する前にプレビューでどのように印刷されるかを確認できます。

方法

  1. プレビューしたいウィンドウをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[印刷プレビュー(V)]を選びます。
  3. デコードビューまたはストリームビューのプレビューを見る場合は、フレームやストリームの範囲、印刷する内容、倍率を指定します。
  4. 印刷する場合は、[印刷(P)...]ボタンをクリックします。


 14 設定情報

ワークスペース、モニタウィンドウ、オプションなどで設定した情報のことです。設定情報を保存したファイルを次にASTEC Eyesを起動した時に読み込めば、見た目を同じにでき、デコードヒントなどを設定しなおす必要もありません。


 14.1 オプション設定ダイアログを開く

ASTEC Eyesの設定情報は[オプション設定]ダイアログで設定します。

方法1

メインウィンドウのコモンツールバーの[オプション設定]ボタン( [image])をクリックします。

方法2

メインウィンドウの[設定(O)]メニューから[オプション設定(O)...]を選びます。


 14.2 デコードヒントを設定する

デコードヒントは[オプション設定]ダイアログの[デコードヒント]ペインで設定します。

方法1

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[デコードヒント]をクリックします。
  3. デコードヒントが設定されていない一番上の行をクリックします。
  4. 値を入力するカラムをクリックします。
  5. 値を入力します。IPアドレスおよびプロトコルのカラムでは、ドロップダウンコンボボックスから値を選ぶこともできます。また、トランスポート層のカラムではドロップダウンリストボックスから値を選びます。
  6. 選んだ行のすべてのカラムに適切な値を入力し終わるまで、2～3を繰り返します。

方法2

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[デコードヒント]をクリックします。
  3. <↑>または<↓>キーを押してデコードヒントが設定されていない行を選びます。
  4. <←>または<→>キーを押して値を入力するカラムに移動し、<F2>キーを押します。
  5. 値を入力します。IPアドレスおよびプロトコルのカラムでは、ドロップダウンコンボボックスから値を選ぶこともできます。また、トランスポート層のカラムではドロップダウンリストボックスから値を選びます。
  6. <Enter>または<F2>キーを押して値を確定します。
  7. 選んだ行のすべてのカラムに適切な値を入力し終わるまで、2～4を繰り返します。

注

  • プロトコルのカラムには、プロトコル情報に表示されるプロトコル名またはユーザが指定した任意の名前を設定できます。
  • 値が入力できる状態になっているときに<Tab>または<Shift-Tab>キーを押すと、入力できる状態のままカラムを移動できます。
  • 上の行に設定されたデコードヒントほど優先順位が高くなります。優先順位を変更するには、変更したい行を選んで、[上へ(H)]ボタンまたは[下へ(L)]ボタンをクリックします。
  • 入力したデコードヒントをデコードビューまたはストリームビューに反映させるには、デコードビューまたはストリームビューのツールバーの[再デコード]ボタン( [image] 、 [image])をクリックします。


 14.3 フォントを変える

次のウィンドウのフォントを変えられます。

  • デコードビュー
  • ストリームビュー
  • 表形式のモニタウィンドウ
  • 表形式のイベントビューア
  • アドレス帳
  • シーケンス表示のウィンドウ

方法

  1. [オプション設定]ダイアログを開きます。
  2. ダイアログの左側にあるツリーの中の[その他]をクリックします。
  3. [フォントの変更(C)...]ボタンをクリックします。
  4. フォントを設定します。

注

  • 日本語OSをお使いの場合には、日本語のフォントを選んでください。 英語のフォントを選ぶと、デコードビューの見出しなどが正しく表示されません。


 14.4 コモンツールバー、インタフェースツールバーのカスタマイズ

コモンツールバー、インタフェースツールバーに配置するボタンや区切りを選ぶことができます。

方法

  1. [ツールバーの変更]ダイアログを開きます。
  2. ツールバーをカスタマイズします。

[ツールバーの変更]ダイアログを開く

方法1

メインウィンドウの[設定(O)]メニューから[コモンツールバーの設定(C)...]または[インタフェースツールバーの設定(I)...]を選びます。

方法2

  1. コモンツールバーまたはインタフェースツールバーを右クリックします。
  2. [コモンツールバーの設定...]または[インタフェースツールバーの設定...]を選びます。

ツールバーをカスタマイズする

ツールバーにボタンや区切り記号を追加する方法

  1. [利用できるツールバーボタン(V)]に表示されているボタンや区切りのうち、追加したいものをクリックします。
  2. [追加(A)]ボタンをクリックします。

ツールバーからボタンや区切り記号を削除する方法

  1. [現在のツールバーボタン(T)]に表示されているボタンや区切りのうち、削除したいものをクリックします。
  2. [削除(R)]ボタンをクリックします。

ツールバーのボタンや区切り記号を並べ替える方法

  1. [現在のツールバーボタン(T)]に表示されているボタンや区切りのうち、移動したいものをクリックします。
  2. [上へ(U)]ボタンまたは[下へ(D)]ボタンをクリックし、ボタンまたは区切りを目的の位置まで移動します。

ツールバーのボタンや区切り記号をデフォルトに戻す方法

[リセット(E)]ボタンをクリックします。


 14.5 メインウィンドウのカスタマイズ

メインウィンドウ上の次のウィンドウやツールバーの表示、非表示を切り替えることができます。

  • インタフェースセレクタウィンドウ
  • メッセージウィンドウ
  • ステータスバー
  • コモンツールバー
  • インタフェースツールバー

方法1

  1. ウィンドウのグリップバーまたはツールバーを右クリックします。
  2. 表示、非表示を切り替えたいウィンドウまたはツールバーに対応するメニュー項目をクリックします。
    チェックマーク（ [image] ）のついているメニュー項目に対応するウィンドウやツールバーがメインウィンドウに表示されます。

方法2

  1. メインウィンドウの[表示(V)]メニューを開きます。
  2. 表示、非表示を切り替えたいウィンドウまたはツールバーに対応するメニュー項目をクリックします。
    チェックマーク（ [image] ）のついているメニュー項目に対応するウィンドウやツールバーがメインウィンドウに表示されます。

注

  • ウィンドウのグリップバーまたはツールバーから現れたポップアップメニューには、ステータスバーの表示、非表示を切り替えるメニュー項目はありません。


 14.6 設定情報を保存する

方法1

メインウィンドウの[設定(O)]メニューから[設定情報の保存(W)...]を選びます。
方法2
メインウィンドウのコモンツールバーの[設定情報の保存]ボタン( [image])をクリックします。


 14.7 設定情報を読み込む

方法1

メインウィンドウの[設定(O)]メニューから[設定情報の読み込み(L)...]を選びます。
方法2
メインウィンドウのコモンツールバーの[設定情報の読み込み]ボタン( [image])をクリックします。


 14.8 起動時に設定情報を自動的に読み込む

方法

ASTEC Eyesをインストールしているディレクトリに“default-workspace.wsi”というファイル名で設定情報を保存すると、起動時に自動的に読み込みます。


 14.9 設定ファイルに保存する情報

ASTEC Eyesが動作しているホストに関して、次の情報を設定ファイルに保存します。

  • ワークスペースの情報
    • ワークスペースの構成とそのプロパティ
    • レポートの設定情報
  • 表示しているトラフィックウィンドウの情報
    • トラフィックの種類とその表示形式
    • 凡例の表示、非表示、および凡例の領域のサイズ
    • ジオメトリ情報
    • 選んでいるタイムスパン
  • 表示しているTCPステータス情報のウィンドウのジオメトリ情報
  • 表示しているモニタのイベントビューアの情報
    • 表示形式
    • 凡例の表示、非表示、および凡例の領域のサイズ
    • ジオメトリ情報
    • 折れ線グラフの期間を短期タイムスパンで表示するか、履歴で表示するか
  • [オプション設定]ダイアログで設定した値
    • キャプチャのオプション
      • キャプチャバッファのサイズ
      • キャプチャバッファがいっぱいになったときの動作
      • データを圧縮して転送するかどうか
      • リアルタイムデコードを行うかどうか
      • リアルタイムデコードウィンドウのバッファサイズ
      • リアルタイムデコードウィンドウのバッファがいっぱいになったときの動作
    • デコードのオプション
      • デコード時にIPv4、UDP、TCPのチェックサムの値を検査するかどうか
      • ストリームビューのレコードの並び順(時系列またはストリームIDごと)
      • [ダンプ]領域の強調部分の色を濃くするかどうか
      • [サマリ]領域の時刻カラムの桁(ミリ秒または100ナノ秒)
      • [ダンプ]領域の背景色をプロトコルごとに変えるかどうか
      • デフォルトのリンクスピード
    • デコードヒント
    • デコードエキスパート
      • デコード時にイベントを検出するかどうか
      • 検出するイベントの種類
    • ホスト名のオプション
      • 表示するホスト名の種類と優先順位
      • NISドメイン名
      • NISサーバーのアドレス
    • モニタのオプション
      • 各タイムスパンの期間
      • 短期タイムスパンを選んでいるときのグラフの更新間隔
      • TCPステータス情報のウィンドウのデータの更新間隔
    • グラフのオプション
      • Y軸の各データの種類(バイト、フレーム、使用率)におけるY軸の単位、 Y軸の最大値、Y軸の最小値
      • ホストとホストペアのグラフで表示する項目数
      • 折れ線グラフでの、ホストとホストペアのグラフの表示方法
      • 凡例の表示、非表示
      • ツールバーの表示、非表示
    • グラフの色のオプション
      • モニタウィンドウ、イベントビューア、および音声品質のウィンドウの前景色、背景色
      • 各種ウィンドウに表示する個々のグラフアイテムの色
    • SOCKSのオプション
      • 各SOCKSサーバーの設定情報と履歴
    • その他のオプション
      • フォント情報
      • ワークスペースのタブの位置
      • 最近開いたキャプチャファイルの履歴数
      • レポートの出力結果を記録するログファイル
    • R値測定のパラメータ
    • R値測定のコーデックのパラメータ
    • 音声の再生の設定
      • RTP Timestampを無視して音声データを再構成するかどうか
      • 表示方法(波形/デシベル音圧/リニア音圧/オクターブ)
      • 再描画の間隔
      • 描画データの期間
      • 音声データを再生するデバイス
      • 音声データをミキシングする際の音量の調整倍率
  • インタフェースセレクタウィンドウの情報
    • ホストのラベル
    • ホストのインタフェースのラベル

注

  • ASTEC Eyes on the net バージョン 5.0からはリモートモジュールに関する情報も保存するようになりました。


 14.10 自動的にレジストリに保存する情報

次の情報は自動的にレジストリに保存され、次回起動時に自動的に読み込まれます。

  • 接続ホストの履歴
  • 開いたキャプチャファイルの履歴
  • メインウィンドウのジオメトリ情報
  • メッセージウィンドウのジオメトリ情報
  • インタフェースセレクタウィンドウのジオメトリ情報
  • デコードビュー、ストリームビューの[サマリ]領域のカラムについての情報
    • 表示するカラム
    • 各カラムの幅
    • カラムの並び順
  • コモンツールバー、インタフェースツールバー上のボタンとジオメトリ情報
  • [ファイルを開く]ダイアログおよび[名前を付けて保存]ダイアログで指定するパス
  • Whoisコマンドに関する情報
    • Whoisコマンドの引数として指定した検索キーの履歴
    • Whoisサーバーの履歴
    • SOCKSサーバーの選択状態
  • ステータスバーの表示、非表示


 14.11 キャプチャモジュールに保存する情報

次の情報はキャプチャモジュールに保存されます。情報をキャプチャモジュールに保存したり変更したりするには、設定権限が必要です。

  • インタフェースのラベル
  • ログ出力の設定
    • ログを出力するかどうか
    • ログを出力するインタフェース
    • ログの出力間隔
    • ログの同一ファイルへの書き込み回数
    • ログファイルを出力するディレクトリ
    • ログファイルを圧縮するかどうか
    • ログファイルを自動的に削除するかどうか、また削除する場合の経過日数
  • 連続キャプチャの設定
    • 連続キャプチャを行うインタフェース
    • キャプチャモジュールの起動時に連続キャプチャを開始するかどうか
    • 連続キャプチャファイルの最大サイズ
    • 連続キャプチャの出力先ディレクトリ
    • ディスクの残りが何Mバイトになったら連続キャプチャを停止するか
    • 連続キャプチャファイルを自動削除するか、 自動削除する場合には何Mバイトになったら自動削除を始めるか
  • エキスパート機能の設定
    • モニタイベントを検出するインタフェース
    • 検出するモニタイベントの種類
    • 検出したモニタイベントをメールで通知するかどうか
    • 検出したモニタイベントを直ちにメールで通知するかどうか
    • 検出したモニタイベントをSNMPトラップで通知するかどうか
    • モニタイベントに設定したフィルタ
  • 通知機能の設定
    • 電子メールでの通知を有効にするかどうか
    • SMTPサーバー
    • メールの送り先 (To ヘッダー)
    • メールの送り元 (From ヘッダー)
    • メールの本文の形式
    • メールの件名の形式
    • メールの送信間隔
    • 送信に失敗したときに通知機能を停止するかどうか
  • SNMP機能の設定
    • SNMPトラップを有効にするかどうか
    • SNMPトラップホスト
    • SNMPコミュニティ
    • 送信に失敗したときにSNMPトラップ機能を停止するかどうか


 15.1 文字列検索で使用できる正規表現

[検索]ダイアログ、[オプション]ダイアログ、およびデコード結果フィルタでは、正規表現を使って文字列を検索できます。

ASTEC Eyesは次の正規表現のパターンをサポートしています。
パターン | 説明
文字 | 一つの文字は、正規表現で最も基本的なパターンです。このパターンはその文字自身にマッチします。 たとえば、 A というパターンは、検索対象の文字列に A が含まれている場合にマッチします。 正規表現の中で特別な意味を持つ文字(メタキャラクタと呼びます)を本来の文字として扱う場合には、その直前に ¥ (半角の円記号) または [image] (半角のバックスラッシュ) を置きます。 たとえば、* という文字を検索する場合は * (アスタリスク)がメタキャラクタなのでパターンとして ¥* を指定します。 ASTEC Eyes の正規表現におけるメタキャラクタは、 ¥ ^ $ ( ) | . [ - ] * + ? { , } の16 文字です。 文字として日本語の文字(Shift JIS コードの2 バイト文字)も指定できます。
文字列 (パターンの連結 (concatination)) | 文字を連結した文字列をパターンとして指定できます。 たとえば、flags というパターンは、検索対象に‘f’, ‘l’, ‘a’, ‘g’, ‘s’ という文字がこの順序で現れた場合にマッチします。 文字に限らず一般的なパターンも同様にして連結できます。 パターン R とパターン S を連結したパターン RS は、 R にマッチした直後に S にマッチすることを表します。
| (選択肢 (alternative)) | パターン R にマッチするか、またはパターン S にマッチするパターンを R|S と書きます。 foo|bar は、文字列 foo にマッチするかまたは文字列 bar にマッチするパターンです。
* (閉包 (closure)) | * の直前のパターンを 0 回以上の任意回数連結したパターンにマッチするパターンを表します。 たとえば ab* は、a, ab, abb, abbb, abbb … b という文字列にマッチします。
‘(’および‘)’ (グルーピング) | 括弧は、パターンのグループを示すために使います。 たとえば、 a(bc)* は、a, abc, abcbc, abcbcbc, abcbcbc…bc という文字列にマッチします。 また foo (bar|baz) は、foobar または foobaz にマッチします。

良く使うパターンを簡単に表現できるように、 ASTEC Eyesでは次のメタキャラクタを定義しています。
メタキャラクタ | 機能
. | 任意の一文字にマッチします。 すべての文字を | でつなぎ、 全体を括弧でくくったパターン(a|b|c|…|0|1|2|…|あ|い|う|…)と等価です。
‘[’および‘]’ | 文字の集合を表します。‘[’と‘]’で囲まれた文字のいずれかとマッチします。 [abc] は、a または b または c とマッチするパターンで、(a|b|c) と等価です。 - (マイナス記号)で文字の範囲を指定できます。 [A-Za-z] は、大文字と小文字のアルファベットいずれかにマッチします。 文字の範囲はASCII コードを基に定義されます。 ‘[’の直後に^(サーカムフレックス)を置くと否定の意味になります。 [^0-9] は、数字以外の任意の文字にマッチします。 ‘[’と‘]’は、1 バイトASCII コードの集合を表します。 日本語の文字(Shift JIS コードでの2 バイト文字)は、直接表現できません。 ‘[’と‘]’で囲まれた場所では、¥ ^ - ] の4文字以外のメタキャラクタは通常の文字として扱います。 また、[ の直後以外では ^ も通常の文字として扱います。 このとき、これらの文字の直前に ¥ (円記号)を置く必要はありません(置いても意味は変わりません)。
{m ,n } | 直前のパターンの m 回以上、n 回以下の繰り返しを表します。 m は 0 以上の整数、n は1 以上の整数です。 ここでm ≦ n である必要があります。 また、{m ,} は m 回以上の任意回の繰り返しを表します。 {,n } は {0,n } と等価です。 {n } は {n ,n } と等価で、 ちょうど n 回の繰り返しを表します。
? | 直前のパターンの0回または1回のマッチを表します。 パターン R に対し、R? は R{0,1} と等価です。
+ | 直前のパターンを1回以上の任意回数連結したパターンを表します。 パターン R に対し、R+ は RR* または R{1,} と等価です。
^ | 検索対象文字列の先頭にマッチします。 ^foo は、foobar にはマッチしますが、barfoo にはマッチしません。
$ | 検索対象文字列の末尾にマッチします。 foo$ は、barfoo にはマッチしますが、foobar にはマッチしません。

^ $ - , の4 文字は、特定のパターンにおいてのみメタキャラクタとして扱います。 次の表はそのパターンを示します。
文字 | メタキャラクタとして扱うパターン
^ | パターンの先頭にある場合。または、[ の直後にある場合。
$ | パターンの末尾にある場合。
- | ‘[’と‘]’で囲まれている場合。
, | ‘{’と‘}’で囲まれている場合。
この表以外のパターンでは、通常の文字として扱います。このとき、 直前に ¥ (円記号)を置く必要はありません(置いても意味は変わりません)。

¥ (円記号)を前に置くと特別な意味をもつ文字があります。 この ¥ (円記号)と文字の組み合わせは、エスケープシーケンスと呼ばれます。 ASTEC Eyes の正規表現がサポートするエスケープシーケンスの一覧を次に示します。
エスケープシーケンス | 意味
¥a | 0x07 (BEL,Alert)
¥b | 0x08 (BS, Back Space)
¥d | 数字 ([0-9]と等価)
¥D | 数字以外 ([^0-9]と等価)
¥f | 0x0c (FF, Form Feed)
¥n | 0x0a (NL, New Line)
¥r | 0x0d (CR, Carriage Return)
¥s | 空白文字 ([ ¥t¥r¥n¥f]と等価)
¥S | 空白文字以外 ([^ ¥t¥r¥n¥f]と等価)
¥t | 0x09 (HT, Horizontal Tab)
¥w | 英数字 ([0-9a-zA-Z]と等価)
¥W | 英数字以外 ([^0-9a-zA-Z]と等価)
¥xhh , ¥Xhh | hh は1桁または2桁の16進数(0-9, a-f, A-F)


 15.2 プロトコルの情報を調べる

ASTEC Eyesが対応しているプロトコルの種類や正式名称、Well knownポート番号などを表示します。

方法

メインウィンドウの[ツール(T)]メニューから[プロトコル情報(I)...]を選びます。

注

  • [プロトコル情報]ダイアログでは文字列を検索できます。


 15.3 緊急時のメッセージ出力

ASTEC Eyesを使い続けるうちに、PCの使用可能なメモリが極端に少なくなったり、致命的なエラーが起きることがあります。このような場合、ASTEC Eyesはエラーメッセージを表示し、ASTEC Eyesをインストールしたディレクトリにエラー情報を記録したEmergency.logファイルを出力します。

  Emergency.logファイルが出力されたときには、このファイルを添えて、サポートまでご連絡ください。


 15.4 ユーザーズガイドを表示する

方法

メインウィンドウの[ヘルプ(H)]メニューから[ユーザーズガイド(G)]を選びます。

注

  • ユーザーズガイドを見るには、アドビシステムズ社のAcrobat Readerがインストールされている必要があります。


 15.5 クイックリファレンスを表示する

方法

メインウィンドウの[ヘルプ(H)]メニューから[クイックリファレンス(R)]を選びます。


 15.6 バージョン情報を見る

方法

  1. メインウィンドウの[ヘルプ(H)]メニューから[バージョン情報(V)...]を選びます。
  2. バージョン情報を見たいタブをクリックします。
    • ASTEC Eyes
    • ASTEC Eyes for VoIP
    • VoIP Player


 16 キーボードによる操作

ASTEC Eyesでは、マウスだけではなく、キーボードでもさまざまな操作を行うことができます。ここでは、キーボードによる操作の方法を示します。


 16.1 インタフェースセレクタウィンドウのキーバインド

<↑> <↓> | カーソルを移動する
<→> <←> | エントリの下に他のエントリがある場合、そのエントリを展開または縮小する
<Enter> | ネットワークインタフェースを選ぶ


 16.2 モニタウィンドウのキーバインド

通常の状態
<↑> <↓> | グラフアイテムを選ぶ
<←> <→> | 表形式の場合に、1つ左または右のセルを選ぶ
<Shift-↑> <Shift-↓> | 表形式で垂直スクロールバーが表示されているとき、選択行を移動せずに上下にスクロールする
<Shift-←> <Shift-→> | 表形式で水平スクロールバーが表示されているとき、選択したセルを移動せずに左右にスクロールする
<Ctrl-Space> | グラフアイテムの選択、選択解除を切り替える
<Ctrl-C> | グラフ形式の場合は、トラフィックの統計情報をクリップボードにコピーする。表形式の場合は選択したセルの内容をクリップボードにコピーする
<Backspace> | 内訳を表示している場合やいくつかのグラフアイテムを隠している場合、元のグラフに戻る

グラフの値を読み取る状態（垂直カーソルのとき）
キー | グラフ部分をクリックした後 | グラフ部分でドラッグした後
<←> | 5つ前のプロット位置に実線を移動する | ドラッグの終点を5つ前のプロット位置に移動する
<→> | 5つ後のプロット位置に実線を移動する | ドラッグの終点を5つ後のプロット位置に移動する
<Ctrl-←> | 1つ前のプロット位置に実線を移動する | ドラッグの終点を1つ前のプロット位置に移動する
<Ctrl-→> | 1つ後のプロット位置に実線を移動する | ドラッグの終点を1つ後のプロット位置に移動する
<Shift-←> | <←>と同じ | ドラッグの始点を5つ前のプロット位置に移動する
<Shift-→> | <→>と同じ | ドラッグの始点を5つ後のプロット位置に移動する
<Shift-Ctrl-←> | <Ctrl-←>と同じ | ドラッグの始点を1つ前のプロット位置に移動する
<Shift-Ctrl-→> | <Ctrl-→>と同じ | ドラッグの始点を1つ後のプロット位置に移動する

グラフの値を読み取る状態（水平カーソルで、グラフアイテムを選んでいないとき）
キー | グラフ部分をクリックした後 |  | グラフ部分でドラッグした後
<↑> | Y軸の範囲の1/100を単位として、1単位上に実線を移動する |  | Y軸の範囲の1/100を単位として、1単位上にドラッグの終点を移動する
<↓> | Y軸の範囲の1/100を単位として、1単位下に実線を移動する |  | Y軸の範囲の1/100を単位として、1単位下にドラッグの終点を移動する
<Ctrl-↑> | 短期タイムスパン | その他 | 短期タイムスパン | その他
 | 1バイト/秒(フレーム/秒)を単位として、1単位上に実線を移動する | 0.1バイト/秒(フレーム/秒)を単位として、1単位上に実線を移動する | 1バイト/秒(フレーム/秒)を単位として、1単位上にドラッグの終点を移動する | 0.1バイト/秒(フレーム/秒)を単位として、1単位上にドラッグの終点を移動する
<Ctrl-↓> | 短期タイムスパン | その他 | 短期タイムスパン | その他
 | 1バイト/秒(フレーム/秒)を単位として、1単位下に実線を移動する | 0.1バイト/秒(フレーム/秒)を単位として、1単位下に実線を移動する | 1バイト/秒(フレーム/秒)を単位として、1単位下にドラッグの終点を移動する | 0.1バイト/秒(フレーム/秒)を単位として、1単位下にドラッグの終点を移動する
<Shift-↑> | <↑>と同じ |  | Y軸の範囲の1/100を単位として、1単位上にドラッグの始点を移動する
<Shift-↓> | <↓> |  | Y軸の範囲の1/100を単位として、1単位下にドラッグの始点を移動する
<Shift-Ctrl-↑> | <Ctrl-↑> |  | 短期タイムスパン | その他
 |  |  | 1バイト/秒(フレーム/秒)を単位として、1単位上にドラッグの始点を移動する | 0.1バイト/秒(フレーム/秒)を単位として、1単位上にドラッグの始点を移動する
<Shift-Ctrl-↓> | <Ctrl-↓>と同じ |  | 短期タイムスパン | その他
 |  |  | 1バイト/秒(フレーム/秒)を単位として、1単位下にドラッグの始点を移動する | 0.1バイト/秒(フレーム/秒)を単位として、1単位下にドラッグの始点を移動する

グラフの値を読み取る状態（水平カーソルで、グラフアイテムを選んでいるとき）
キー | グラフ部分をクリックした後 | グラフ部分でドラッグした後
<↑> <Ctrl-↑> | 選んでいるグラフアイテムのプロットされた値のうち、次に大きい値に実線を移動する | 選んでいるグラフアイテムのプロットされた値のうち、次に大きい値にドラッグの終点を移動する
<↓> <Ctrl-↓> | 選んでいるグラフアイテムのプロットされた値のうち、次に小さい値に実線を移動する | 選んでいるグラフアイテムのプロットされた値のうち、次に小さい値にドラッグの終点を移動する
<Shift-↑> <Shift-Ctrl-↑> | <↑>と同じ | 選んでいるグラフアイテムのプロットされた値のうち、次に大きい値にドラッグの始点を移動する
<Shift-↓> <Ctrl-↓> | <↓>と同じ | 選んでいるグラフアイテムのプロットされた値のうち、次に小さい値にドラッグの始点を移動する


 16.3 アドレス帳の操作のキーバインド

<↑> <↓> | 選ばれている行を移動する
<←> <→> | 選ばれているセルを移動する
<Shift-↑> <Shift-↓> | 垂直スクロールバーが表示されているとき、選択行を移動せずに上下にスクロールする
<Shift-←> <Shift-→> | 水平スクロールバーが表示されているとき、選択セルを移動せずに左右にスクロールする
<F2> | ユーザー定義名を入力できる状態にする、また、入力できる状態のときは入力できない状態にする
<Enter> | 入力を確定する
<Ctrl-C> | 選択セル表示されている内容をクリップボードにコピーする


 16.4 TCPステータス情報ウィンドウのキーバインド

<↑> <↓> | 1つ上または下の行に移動する
<←> <→> | 1つ左または右のセルを選ぶ
<Shift-↑> <Shift-↓> | 垂直スクロールバーが表示されているとき、選択行を移動せずに上下にスクロールする
<Shift-←> <Shift-→> | 水平スクロールバーが表示されているとき、選択セルを移動せずに左右にスクロールする
<Ctrl-C> | 選択したセルの内容をクリップボードにコピーする


 16.5 イベントビューアのキーバインド

<↑> <↓> | グラフアイテムを選ぶ。表形式の場合は、1つ上または下の行に移動する
<←> <→> | 表形式の場合に、1つ左または右のセルを選ぶ
<Shift-↑> <Shift-↓> | 垂直スクロールバーが表示されているとき、選択行を移動せずに上下にスクロールする
<Shift-←> <Shift-→> | 水平スクロールバーが表示されているとき、選択セルを移動せずに左右にスクロールする
<Ctrl-Space> | グラフアイテムの選択、選択解除を切り替える
<Ctrl-C> | 折れ線グラフ形式の場合は、表示されているイベントをクリップボードにコピーする。表形式の場合は選択したセルの内容をクリップボードにコピーする


 16.6 デコードビュー、ストリームビューのキーバインド

キー | [サマリ]領域 | [デコード結果]領域 | [ダンプ]領域
<Tab> <Shift-Tab> | [サマリ]領域、[デコード結果]領域、[ダンプ]領域の間でフォーカスを移す
<↑> | 選択行を1つ上に移動する |  | アドレスの小さい方の領域に移動する
<↓> | 選択行を1つ下に移動する |  | アドレスの大きい方の領域に移動する
<←> | 選択セルを1つ左に移動する |  | アドレスの小さい方の領域に移動する
<→> | 選択行を1つ右に移動する |  | アドレスの大きい方の領域に移動する
<Shift-↑> <Shift-↓> | 垂直スクロールバーが表示されているとき、選択行を移動せずに上下にスクロールする |  | <↑>、<↓>と同じ
<Shift-←> <Shift-→> | 水平スクロールバーが表示されているとき、選択セルを移動せずに左右にスクロールする |  | <↑>、<↓>と同じ
<Alt-↑> <Alt-↓> | デコードビューでのみ有効。ストリームビューで選択しているレコードに対応するデコードビューのパケットにジャンプする
<Page Up> | 選択行を1ページ上に移動する |  | アドレスの小さいほうに表示ページを切り替える
<Page Down> | 選択行を1ページ下に移動する |  | アドレスの大きいほうに表示ページを切り替える
<Home> | 先頭の行に移動する |  | アドレスの一番小さい領域を表示する
<End> | 末尾の行に移動する |  | アドレスの一番大きい領域を表示する
<Z> | フォーカスのある領域をウィンドウいっぱいに表示する、または元に戻す
<Ctrl-↑> <Ctrl-↓> <Ctrl-Home> <Ctrl-End> | フォーカスがどの領域にあっても、[サマリ]領域のパケットまたはレコードを移動する
<Shift-Ctrl-↑> <Shift-Ctrl-↓> | [サマリ]領域に垂直スクロールバーが表示されているとき、フォーカスがどの領域にあっても、選択行を移動せずに[サマリ]領域を上下にスクロールする
<Shift-Ctrl-←> <Shift-Ctrl-→> | [サマリ]領域に水平スクロールバーが表示されているとき、フォーカスがどの領域にあっても、選択セルを移動せずに[サマリ]領域を左右にスクロールする
<Ctrl-C> | 選択セルの内容をクリップボードにコピーする |  | 反転している部分をクリップボードにコピーする
<Space> | チェックマークが付いていなければチェックを付ける。付いていれば、チェックを外す |  |
<Ctrl-G> | 指定した行へ移動する
<Ctrl-S> | デコードしたキャプチャデータをファイルに保存する
<Ctrl-T> | [サマリ]領域 の表示、非表示を切り替える
<Ctrl-M> | [デコード結果]領域 の表示、非表示を切り替える
<Ctrl-B> | [ダンプ]領域 の表示、非表示を切り替える


 16.7 デコードヒントの設定のキーバインド

<↑> <↓> | 選ばれている行を移動する
<←> <→> | 選ばれているセルを移動する
<Shift-↑> <Shift-↓> | 垂直スクロールバーが表示されているとき、選択行を移動せずに上下にスクロールする
<Shift-←> <Shift-→> | 水平スクロールバーが表示されているとき、選択セルを移動せずに左右にスクロールする
<F2> | セルに値を入力できる状態にする、また、入力できる状態のときは入力できない状態にする
<Tab> <Shift-Tab> | 入力できる状態のままセルを移動する


 16.8 ショートカット

<Alt-0> | ワークスペースにフォーカスを移す
<Alt-1> | インタフェースセレクタウィンドウにフォーカスを移す
<Alt-2> | メッセージウィンドウにフォーカスを移す
<Ctrl-O> | ファイルに保存したデータをデコードする
<Ctrl-Alt-←> <Ctrl-PageUp> | 1つ前のワークスペースに切り替える
<Ctrl-Alt-→> <Ctrl-PageDown> | 1つ後ろのワークスペースに切り替える
<Ctrl-S> | デコードビューで、デコードしたキャプチャデータをファイルに保存する
<Ctrl-L> | [ホスト名の検索]ダイアログを開く
<Ctrl-E> | フィルタエディタを開く
<Ctrl-P> | 印刷する
<Ctrl-F4> | ワークスペース内のフォーカスのあるウィンドウを閉じる
<Ctrl-Tab> <Shift-Ctrl-Tab> <Ctrl-F6> <Shift-Ctrl-F6> | ワークスペース内のフォーカスのあるウィンドウを切り替える
<Ctrl-C> | グラフ形式表示の場合は、トラフィックの統計情報またはイベント情報をコピーする。表形式表示の場合は、フォーカスのあるセルの内容をコピーする
<Ctrl-F> | 「検索」ダイアログを開く
<Ctrl-G> | デコードビューまたはストリームビューで、 [サマリ]領域の指定した行へ移動する


 17 VoIP機能

音声品質の測定および表示機能、シーケンス表示機能、音声再生機能の3つの機能があります。 ASTEC Eyes for VoIP だけの機能です。

  • 音声品質の表示機能
    キャプチャデータに含まれるRTPやRTCPパケットの情報から音声品質を計算して表示する機能です。9種類の音声品質を表示できます。
    • ネットワークR値
    • ネットワークMOS値
    • ネットワークMOS-j値
    • ユーザーR値
    • ユーザーMOS値
    • ユーザーMOS-j値
    • 往復遅延時間
    • ジッタ
    • パケット損失率
    • 操作については、こちらを参照してください。
  • 音声品質の測定機能
    2台のホストにインストールした通話シミュレーションモジュールにより音声データの送受信を行います。そのときのパケットをキャプチャし、音声品質の表示機能を使って音声品質を表示する機能です。
    操作については、こちらを参照してください。
  • シーケンス表示機能
    キャプチャデータに含まれるVoIPセッションを見つけ、VoIPの呼制御から音声データの搬送開始、終了までのシーケンスをグラフィカルに表示する機能です。
    操作については、こちらを参照してください。
  • 音声再生機能
    RTPパケットを基に音声を再生する機能です。G.711およびG.723コーデックに対応しています。この機能を使うためには、VoIP Playerオプションが必要です。
    操作については、こちらを参照してください。


 17.1 キャプチャファイルから音声品質を求める

  1. キャプチャファイルをデコードします。
  2. デコードビューのツールバーの[音声品質の表示]ボタン( [image])をクリックします。
  3. 音声品質の種類を選びます。


 17.2 通話シミュレーションモジュールを使って音声品質を測定する

ASTEC Eyes for VoIPに付属の通話シミュレーションモジュールを2台のホストにインストールして音声品質を測定できます。

  1. 『ASTEC Eyes for VoIP』を参照して、ホストA にASTEC Eyes基本パッケージ、VoIPライブラリ、および通話シミュレーションモジュールをインストールします。
  2. 同様にして、ホストB に通話シミュレーションモジュールをインストールします。
  3. ホストB で着信側の通話シミュレーションモジュールを起動します。
  4. ホストA でASTEC Eyes for VoIPを起動して、音声品質を測定します。
着信側の通話シミュレーションモジュールを起動する
  1. 通話シミュレーションモジュールを起動するホストにAdministrator権限のあるユーザーでログインします。
  2. Windowsの[スタート]メニューをクリックします。
  3. [全てのプログラム(p)]⇒[ASTEC Eyes for VoIP]⇒[着信モジュール起動]
ASTEC Eyes for VoIPを起動して、音声品質を測定する
  1. ASTEC Eyesを起動します。
  2. 音声データの送受信に使うインタフェースを選びます。
  3. メインウィンドウのコモンツールバーの[音声データ送信]ボタン( [image])をクリックします。
  4. 音声データファイル名、着信先ホスト、コーデック、送信回数を指定します。
  5. [送信(S)]ボタンをクリックします。

注

  • ASTEC Eyes for VoIPをインストールしたディレクトリに、sample1.wavおよびsample2.wavという名前のサンプルの音声データファイルがあります。
  • 着信側の通話シミュレーションモジュールからも音声データを送信することができます。
    1. Windowsの[スタート]メニューをクリックします。
    2. [全てのプログラム(p)]⇒[ASTEC Eyes for VoIP]⇒[着信モジュール設定]
    3. [双方向通信(B)]をクリックします。
  • IPv6で通話シミュレーションを行う場合は、 あらかじめ着信側の設定を行っておくことが必要です。
    1. Windowsの[スタート]メニューをクリックします。
    2. [全てのプログラム(p)]⇒[ASTEC Eyes for VoIP]⇒[着信モジュール設定]⇒[詳細設定(E)]
    3. [IPv6]をクリックします。


 17.3 音声品質の算出方法を切り替える

音声品質を計算する方法には3通りあります。

  • RTCPモード: RTCPプロトコルの情報を使って計算する
  • RTPモード: RTPプロトコルの情報を使って計算する
  • 自動モード: RTCPモードで計算できなければRTPモードで計算する
デフォルトでは[自動モード]で計算します。 どの方法で計算するかは切り替えることができます。

音声品質のグラフや表の計算方法を切り替える

方法

音声品質を表示したグラフや表のツールバーの[計算モード切替]ボタン( [image] 、 [image] 、 [image])をクリックします。 このボタンを押すたびに、音声品質の計算方法が、自動、RTCP、RTPと切り替わります。

音声品質の表の表示を変更する

[音声品質(詳細)]の表には、 [計算モード切替]ボタン( [image] 、 [image] 、 [image])によって音声品質の計算方法が切り替わるカラムと、 計算方法が切り替わらず常にRTCPまたはRTPから計算した値を表示するカラムがあります。
標準では音声品質の計算方法が切り替わるカラムのみが表示されていますが、 計算方法が切り替わらないカラムを表示することもできます。

方法

  1. [音声品質(詳細)]の表のカラムの見出しを右クリックします。
  2. [カラムの設定...]を選びます。
  3. カラムに対応するチェックボックスをクリックします。


 17.4 VoIPシーケンスを見る

キャプチャデータからVoIPのセッションを抜き出し、グラフィカルに表示できます。

  1. キャプチャファイルをデコードします。
  2. デコードビューのツールバーの[シーケンス表示]ボタン( [image])をクリックします。
  3. シーケンス表示のウィンドウでセッションを選びます。
エラーを見つける

選んだセッションにエラーが含まれている場合、 エラーまたは警告行に移動し、選択できます。 その方法は3つあります。

  • シーケンス表示のウィンドウのツールバーの[次のエラー]ボタン( [image])または[前のエラー]ボタン( [image])をクリックします。
  • <Alt-↓>キーまたは<Alt-↑>キーを押します。
  • シーケンス表示のウィンドウの下の方の領域([シーケンス表示]領域)で右クリックし、[次のエラー(T)]またま[前のエラー(V)]を選びます。


 17.5 VoIPのセッションをマージする

VoIPのセッションをマージして表示できます。

キャプチャしたデータの不足などが原因で、 本来は同じセッションになるはずのRTCPやRTPのパケットが異なったセッションとして認識される場合があります。
このような場合にはセッションをマージして、 一連のシーケンスとして表示することができます。

  1. VoIPシーケンスを表示します。
  2. マージしたいシーケンスの[セッションリスト]領域の[ID]カラムにチェックをつけます。
  3. ツールバーの[セッションをマージ]ボタン( [image])をクリックします。

注

  • 音声品質のグラフや表には、 マージ後のセッションに含まれる通話の音声品質も表示されます。
  • マージ後のセッションに複数の通話が含まれるときには、 セッション中で最初に流れたRTPまたはRTCPパケットに関する通話の音声品質を表示します。


 17.6 VoIPの情報をファイルに保存する

音声品質情報やシーケンス表示のウィンドウの内容をCSV(カンマ区切り)形式やbmp形式、PNG形式で保存できます。

方法

  1. 音声品質のウィンドウまたはシーケンス表示のウィンドウをクリックします。
  2. メインウィンドウの[ファイル(F)]メニューから[モニタ情報の保存(G)...]を選びます。
  3. ファイル名とファイル形式を指定します。

注

  • 表形式の音声品質のウィンドウとシーケンス表示のウィンドウはCSV形式でのみ保存できます。
  • 保存したモニタ情報は他のアプリケーションで利用できます。 例えば、Microsoft Wordにbmp形式の画像を挿入したり、 Microsoft ExcelでCSV形式のデータを読み込めます。


 17.7 VoIPの情報を他のアプリケーションにコピーする

音声品質のウィンドウやシーケンス表示のウィンドウの情報を他のアプリケーションへコピーできます。

方法 (グラフ形式の場合)

  1. コピー元の音声品質のウィンドウをクリックします。
  2. メインウィンドウの[編集(E)]メニューから[コピー(C)]を選ぶか、<Ctrl-C>キーを押します。
  3. ペースト先のアプリケーションをアクティブにし、<Ctrl-V>キーを押します。

方法 (表形式の場合)

  1. コピー元の音声品質のウィンドウをマウスの右ボタンでクリックします。
  2. [すべてコピー(W)]を選びます。
    表形式の場合に<Ctrl-C>キーを押すと、選択しているセル(白い枠で囲まれます)の文字列だけをコピーします。
  3. ペースト先のアプリケーションをアクティブにし、<Ctrl-V>キーを押します。

方法 (シーケンス表示のウィンドウ)

  1. コピー元のシーケンス表示のウィンドウをクリックします。
  2. コピーしたい領域をクリックします。
  3. メインウィンドウの[編集(E)]メニューから[コピー(C)]を選ぶか、<Ctrl-C>キーを押します。
  4. ペースト先のアプリケーションをアクティブにし、<Ctrl-V>キーを押します。

注

  • Microsoft WordやMicrosoft Excelなどのアプリケーションでは、<Ctrl-V>キーを押す代わりに、[編集(E)]メニューの[形式を選択して貼り付け(S)]を選ぶこともできます。


 17.8 音声を再生する

キャプチャデータから音声データを抜き出し、再生できます。

  1. キャプチャファイルをデコードします。
  2. デコードビューのツールバーの[音声再生]ボタン( [image])をクリックします。
  3. 音声再生のウィンドウでエントリを選びます。
  4. 音声再生のウィンドウのツールバーの[再生]ボタン( [image])をクリックします。

注

  • 音声を再生するには、VoIP Playerオプションが必要です。
  • すべてのエントリに再生可能な音声データが含まれているとは限りません。エントリを選ぶときは、[音声ID]カラムの左側に [image] が表示されているものを選ぶようにします。


 17.9 音声データを保存する

音声再生のウィンドウに表示されているエントリを選んで、音声データをファイルに保存できます。

  1. 音声再生のウィンドウで保存したいエントリをクリックします。
  2. 音声再生のウィンドウのツールバーの[保存]ボタン( [image])をクリックします。

注

  • この機能を使うには、VoIP Playerオプションが必要です。
  • 音声データはWAVE形式(サンプリング周波数8kHz、16bit、モノラル、拡張子 .wav)のファイルに保存されます。
  • 有効な音声データが含まれているエントリは、[音声ID]カラム の左側に [image] が表示されています。


 17.10 音声データをミキシングする

音声再生のウィンドウに表示されている音声データのエントリを複数個選んで、ミキシングできます。

  1. 音声再生のウィンドウで、ミキシングしたいエントリの[ミキシング]カラム にチェックをつけます。
  2. 音声再生のウィンドウのツールバーの[ミキシング]ボタン( [image])をクリックします。
  3. 再生したい場合は、ツールバーの[再生]ボタン( [image])を、保存したい場合は、[保存]ボタン( [image])をクリックします。

注

  • この機能を使うには、VoIP Playerオプションが必要です。
  • 再生可能な音声データが含まれているエントリは、[音声ID]カラム の左側に [image] が表示されています。


 18 用語集
英字 あ か さ た な は ま や ら わ

英字

RFC(Request for Comments)

インターネットに関する技術情報や仕様、運用規則などを定める文書。インターネットに関する技術の標準を定める団体であるIETF(Internet Engineering Task Force)が発行、管理する。ASTEC EyesのインストールCDのUnsupportedディレクトリにある。

TCPステータス情報

TCPの接続状態で、モニタウィンドウに表示されます。

あ行

イベントフィルタ

フィルタエディタで作成するフィルタです。ユーザー定義イベントの条件として使われたり、モニタイベントを発生させる際の条件として使われます。

インタフェース

ネットワークインタフェースのことです。

インタフェースセレクタウィンドウ

インタフェースを選ぶ、リモートモジュールと接続するなど、インタフェースに関する操作を行う機能を備えたウィンドウです。

インタフェースツールバー

メインウィンドウにあるツールバーです。モニタを開始または停止したり、キャプチャを開始または停止するなど、選んでいるインタフェースに対して操作を行うためのボタンがあります。また、配置するボタンはユーザーが設定できます。

エキスパート機能

モニタエキスパート機能とデコードエキスパート機能があります。モニタエキスパート機能は、ネットワークのモニタ中にトラブルの予兆を見つけ、表示する機能です。検出するイベントをユーザーが設定できます。デコードエキスパート機能は、キャプチャデータをデコードする際に、トラブルの元となるかもしれないイベントを見つけ、表示する機能です。検出するイベントを選択できます。

エントリ

インタフェースセレクタウィンドウに表示されているホストやインタフェース、ログ、キャプチャデータ、ログやキャプチャデータのディレクトリのアイコンとそのラベルを指します。

音声品質情報
音声品質を表す R値、MOS値、往復遅延時間、ジッタ、パケット損失率の情報のことです。

か行

簡易フィルタ

デコードビューやストリームビューで、GUI操作だけで手軽にパケットやレコードを絞り込めるフィルタです。簡易フィルタには見出しフィルタ、ヘッダー属性フィルタ、デコード結果フィルタがあります。

期間指定バー

「ログの表示」ダイアログ、「キャプチャデータマネジャー」ダイアログ、「連続キャプチャデータの表示」ダイアログで、データの範囲を指定するためのものです。 データの範囲を指定するための開始時刻と終了時刻をマウス操作で入力できます。

キャプチャ開始トリガ
特定のパケットがネットワークに流れたことをきっかけにしてキャプチャを開始するフィルタです。キャプチャを開始するきっかけとなる条件は、フィルタエディタで設定します。
キャプチャ停止トリガ
特定のパケットがネットワークに流れたことをきっかけにしてキャプチャを停止するフィルタです。キャプチャを停止するきっかけとなる条件はフィルタエディタで設定します。

キャプチャデータ

キャプチャまたは連続キャプチャしたデータのことです。

キャプチャデータインディケータ

ログのウィンドウ上に表示されるインディケータで、 連続キャプチャしたデータがある期間を表します。

キャプチャデータマネジャー
ファイルに保存したデータを部分的にデコードしたり、複数のキャプチャファイルをマージしてデコードする機能です。デコードする範囲を時間やヘッダー属性フィルタで絞り込めます。操作はキャプチャファイルの一部をデコードするや複数のキャプチャファイルをマージしてデコードするを参照してください。

キャプチャバッファ

パケットを取り込むためのバッファです。ASTEC Eyesまたはリモートモジュールをインストールしたホストのメモリ上に確保されます。キャプチャバッファのサイズは変えられます。また、キャプチャバッファがいっぱいになったときの動作を設定することもできます。
キャプチャフィルタ
特定の条件を満たすパケットのみをキャプチャするためのフィルタです。フィルタエディタで論理式を設定します。
グラフアイテム
グラフに表示されている折れ線、棒、または扇形の各要素のことです。
グラフ解析機能
トラフィックウィンドウを折れ線グラフ表示にしているときに、グラフの値を読み取る機能です。読み取った値はメッセージウィンドウに表示されます。
グリップバー
移動できるツールバーやウィンドウの上または左についている部品です。グリップバー上で右クリックすることにより、表示、非表示を設定できます。また、グリップバーをドラッグすれば、ウィンドウやツールバーの位置を変えられます。

更新間隔
トラフィックウィンドウに表示するグラフや表を更新する間隔です。
コモンツールバー
メインウィンドウにあるツールバーです。キャプチャファイルの読み込みや、設定情報の保存または読み込みなど、選択中のインタフェースに依存しない操作を行うためのボタンがあります。配置するボタンはユーザーが設定できます。

さ行

[サマリ]領域

デコードビューまたはストリームビューで、パケットまたはレコードの概要を表示する領域です。デコードビューまたはストリームビューの一番上の領域です。
垂直カーソル
トラフィックウィンドウに表示されているグラフの値を読み取る状態で[垂直カーソル]ボタン( [image])をクリックすると現れるカーソルです。破線で示されます。

水平カーソル
トラフィックウィンドウに表示されているグラフの値を読み取る状態で[水平カーソル]ボタン( [image])をクリックすると現れるカーソルです。破線で示されます。

ステータスバー
ASTEC Eyesの状態を表示したり、トラフィックウィンドウでグラフアイテムを選んだときに、その名前を表示したりする部分です。
ストリームビュー
TCPストリームを再構成して、解析した結果を表示するウィンドウです。
ストリームビューのシーケンスモード
TCPストリームを再構成して、解析した結果をセッションごとにまとめて表示するモードです。
設定権限
ログや連続キャプチャの出力、インタフェースのラベルを変えるなど、インタフェースの設定やホストの設定を変えるために必要な権限です。設定権限の取得方法は「設定権限の取得と開放」を参照してください。
選択したセル
表形式のモニタウィンドウ、デコードビューおよびストリームビューのサマリ領域、「オプション」ダイアログの「デコードヒント」ページなどにおいて、編集または操作の対象としているセルのことです。白い枠で囲まれています。

た行

タイムスパン

トラフィックの統計情報を表示する期間のことです。短期、中期、長期の3つのタイムスパンがあり、それぞれの期間は選択できます。タイムスパンごとにトラフィックの統計情報を作る間隔が異なります。それぞれ1秒、10秒、5分の間隔で統計情報を作ります。

[ダンプ]領域

デコードビューまたはストリームビューでパケットまたはレコードのデータを16進ダンプの形式で表示する領域です。デコードビューまたはストリームビューの一番下の領域です。

デコード結果フィルタ

デコードビューまたはストリームビューの[デコード結果]領域に表示される文字列や値を利用して、パケットまたはレコードを絞り込むフィルタです。
[デコード結果]領域
デコードビューまたはストリームビューでパケットまたはレコードを解析した結果を表示する領域です。デコードビューまたはストリームビューの中央の領域です。
デコードビュー
キャプチャデータやキャプチャファイルを1パケットずつ解析した結果を表示するウィンドウです。
デコードヒント
TCPまたはUDPポートとプロトコルを関連付けるための情報です。特定のIPアドレスを指定してポート番号とプロトコルを対応させることもできます。例えば、プロキシサーバーでWell knownポート以外のポートを使っている場合に、その情報をデコードヒントとして設定します。
ディスプレイフィルタ
デコードビューに表示する解析結果を絞り込むためのフィルタです。条件はフィルタエディタで設定します。
トラフィックウィンドウ
ネットワークのトラフィックの統計情報を折れ線グラフ、棒グラフ、円グラフおよび表の形式で表示するウィンドウです。次の13種類のトラフィックウィンドウが用意されています。
  • MAC層トラフィック
  • MAC層発信元毎のトラフィック
  • MAC層受信先毎のトラフィック
  • MAC層ホストペア毎のトラフィック
  • MAC層プロトコル毎のトラフィック
  • IP層トラフィック
  • IP層発信元毎のトラフィック
  • IP層受信先毎のトラフィック
  • IP層ホストペア毎のトラフィック
  • IP層プロトコル毎のトラフィック
  • MAC層アドレスタイプ毎のトラフィック
  • MAC層サイズ毎のトラフィック
  • MAC層エラーフレーム数

な行

ネットワークインタフェース

ホストにインストールしてあるネットワークインタフェースカード（NIC）のことです。1台のホストに複数のネットワークインタフェースカードをインストールしている場合は、モニタやキャプチャを行う前に、対象とするネットワークインタフェースを選ぶ必要があります。

は行

フィルタエディタ

フィルタエディタは、 ディスプレイフィルタ、 モニタフィルタ、 キャプチャフィルタ、 キャプチャ開始トリガ、 キャプチャ停止トリガ、 連続キャプチャフィルタ、 連続キャプチャ開始トリガ、 連続キャプチャ停止トリガ の条件を論理式で定義するために使います。
ヘッダー属性フィルタ
デコードビューで、パケットヘッダーの値を基に、表示するパケットを絞り込むためのフィルタです。
ポートの状態一覧ダイアログ
トラフィックウィンドウやアドレス表に表示されているホストのTCPやUDPポートの状態を示すダイアログです。ポートへの接続が成功した回数、拒否された回数、タイムアウトになった回数を表示します。

ま行

見出しフィルタ

カラムの内容で表示する行を絞り込むためのフィルタです。見出しに▼マークがついているカラムで使えます。イベントビューア、デコードビューまたはストリームビューの[サマリ]領域で使えます。

メッセージウィンドウ

ASTEC Eyesの重要なメッセージが表示されるウィンドウです。例えば、グラフ解析機能を使って読み取った値や、デコードに失敗した場合にデコードできなかったフレームIDやストリームIDの値とプロトコル名などを表示します。
モニタウィンドウ
モニタ中に収集した情報(トラフィックの統計情報、MACアドレス、IPアドレス、TCPの接続状態)をグラフや表の形式で表示するウィンドウです。次の17種類のモニタウィンドウが用意されています。モニタウィンドウは、トラフィックウィンドウ、アドレス表、TCPステータス情報の3種類に分類されます。
  • MAC層トラフィック
  • MAC層発信元毎のトラフィック
  • MAC層受信先毎のトラフィック
  • MAC層ホストペア毎のトラフィック
  • MAC層プロトコル毎のトラフィック
  • IP層トラフィック
  • IP層発信元毎のトラフィック
  • IP層受信先毎のトラフィック
  • IP層ホストペア毎のトラフィック
  • IP層プロトコル毎のトラフィック
  • MAC層アドレスタイプ毎のトラフィック
  • MAC層サイズ毎のトラフィック
  • MAC層エラーフレーム数
  • MACアドレス表
  • IPアドレス表
  • MACアドレス-IPアドレス対応表
  • TCPステータス情報
モニタ情報
モニタウィンドウに表示されているトラフィックの統計情報やIPアドレス、MACアドレス、TCPの接続に関する情報など、モニタ中に収集した情報のことです。
モニタフィルタ
モニタウィンドウに表示するデータを絞り込むためのフィルタです。条件は、フィルタエディタで設定します。

や行

ユーザー定義イベント

ユーザーが指定した条件に一致するデータが流れたり、指定した状況になったときに発生するイベントです。ユーザー定義イベントの条件は、フィルタエディタのイベントフィルタで指定します。

ら行

リアルタイムデコードビュー

キャプチャしたデータの簡単なデコード結果をリアルタイムで表示するウィンドウです。リアルタイムデコードビューからデコードビューを表示し、 より詳細な解析結果を見ることができます。
リアルタイムデコードキャプチャ
キャプチャしながら解析し、デコード結果をリアルタイムデコードビューに表示する機能です。

リモートモジュール

ASTEC Eyes基本パッケージ と同じ情報収集機能を持ったソフトウェアで、複数のASTEC Eyesに接続して、集めた情報を送ることができます。
離れた場所にあるホストにインストールしておけば、手元のホストで離れた場所にあるネットワークを監視できます。
連続キャプチャ
連続的にキャプチャを行い、キャプチャしたデータを直接ファイルに出力する機能です。操作はこちらを参照してください。
連続キャプチャフィルタ
特定の条件を満たすパケットのみを連続キャプチャするためのフィルタです。条件は、フィルタエディタで設定します。
連続キャプチャ開始トリガ
特定のパケットがネットワークに流れたことをきっかけにして連続キャプチャを開始するフィルタです。きっかけとなる条件は、フィルタエディタで設定します。
連続キャプチャ停止トリガ
特定のパケットがネットワークに流れた事をきっかけにして連続キャプチャを停止するフィルタです。きっかけとなる条件は、フィルタエディタで設定します。
ログ
TCPステータス情報を除く16種類のモニタ情報とイベントの情報を一定時間毎にファイルに出力する機能のことをログ機能と呼びます。ファイルに出力する情報をログ、出力されたファイルのことをログファイルと呼びます。次の17種類の情報がログとして保存されます。

  • MAC層トラフィック
  • MAC層発信元毎のトラフィック
  • MAC層受信先毎のトラフィック
  • MAC層ホストペア毎のトラフィック
  • MAC層プロトコル毎のトラフィック
  • IP層トラフィック
  • IP層発信元毎のトラフィック
  • IP層受信先毎のトラフィック
  • IP層ホストペア毎のトラフィック
  • IP層プロトコル毎のトラフィック
  • MAC層アドレスタイプ毎のトラフィック
  • MAC層サイズ毎のトラフィック
  • MAC層エラーフレーム数
  • MACアドレス表
  • IPアドレス表
  • MACアドレス-IPアドレス対応表
  • イベント
ログに関する操作はこちらを参照してください。

わ行

ワークスペース

モニタウィンドウ、デコードビュー、ストリームビューなど、ダイアログ以外のウィンドウを表示する領域です。ASTEC Eyesでは、複数のワークスペースを切り替えて使うことができます。


 ASTEC Eyes on the net Version 7.2 クイックリファレンス